1
jcweb
Problem with tag module v2.30
  • 2010/12/15 3:05

  • jcweb

  • Quite a regular

  • Posts: 253

  • Since: 2005/4/25


Hi friends
I use the tag module from @trabis v.2.30 for news 1.6.5 and the forum module 4.0.3 beta from the german community. I found a problem and can not understand why this error comes now, i did not see it before or earlier.

If i send some tags with a topic (in both modules) and the tag have numbers (ex. a123) and i click at the topic on a tag, the module shows me "Invalid query".

If i take only words it works fine. I turn the debug mode, but there comes no warnings.

Anyone the same problem or any suggestions?

Xoops 2.5.0 fresh installation
PHP 5.2.14
MySQL 5.0.9x
All requirements supportet

Greety Andy

2
jcweb
Re: Problem with tag module v2.30
  • 2010/12/15 3:23

  • jcweb

  • Quite a regular

  • Posts: 253

  • Since: 2005/4/25


It goes more and more courios ...

12345 or 2011 = only numbers, Invalid query
a1234 or d011 = only 1 letter and some numbers, Invalid query
a123b or aa11 = min 2 letters and some numbers, works!

Andy

3
chco2
Re: Problem with tag module v2.30
  • 2011/1/11 9:55

  • chco2

  • Module Developer

  • Posts: 374

  • Since: 2004/3/5 1


I also encounter problems with the TAG feature.
Tags are supported by the modules I use XCenter and Xnews.
Tags in Xcenter are not redirected propperly but I'll ask Simon for that.

When clicking on a tag in the Tag main screen I just get a breadcrumb but no results.
Any idea ?

Have a look here : http://www.curavista.nl/site/modules/tag/list.tag.php

When the site is fully done, I'll post a YAXS newsitem, but I need tags working :S
“It's amazing the way people cling to insults. Or what they think are insults.”

4
bjuti
Re: Problem with tag module v2.30
  • 2011/1/11 19:39

  • bjuti

  • Just can't stay away

  • Posts: 871

  • Since: 2009/1/7 2


I have problem with tag module and Publisher/Smartsection when urls are rewritten. In Tag module there is only item=xxx not the rewritten name, and it's not good for seo, external comment systems etc. Any solution for this?

5
voltan
Re: Problem with tag module v2.30
  • 2011/1/12 6:52

  • voltan

  • Theme Designer

  • Posts: 724

  • Since: 2006/12/5


Quote:
It goes more and more courios ...

12345 or 2011 = only numbers, Invalid query
a1234 or d011 = only 1 letter and some numbers, Invalid query
a123b or aa11 = min 2 letters and some numbers, works!


I have problem like this

6
chco2
Re: Problem with tag module v2.30
  • 2011/1/12 8:28

  • chco2

  • Module Developer

  • Posts: 374

  • Since: 2004/3/5 1


Sounds like the queries to the sql database are send as numeric numbers instead of texts.
Would be good if Trabis took a peek here.

Quote:

jcweb wrote:
Hi friends
I use the tag module from @trabis v.2.30 for news 1.6.5 and the forum module 4.0.3 beta from the german community. I found a problem and can not understand why this error comes now, i did not see it before or earlier.

If i send some tags with a topic (in both modules) and the tag have numbers (ex. a123) and i click at the topic on a tag, the module shows me "Invalid query".

If i take only words it works fine. I turn the debug mode, but there comes no warnings.

Anyone the same problem or any suggestions?

Xoops 2.5.0 fresh installation
PHP 5.2.14
MySQL 5.0.9x
All requirements supportet

Greety Andy
“It's amazing the way people cling to insults. Or what they think are insults.”

7
kroewing
Re: Problem with tag module v2.30
  • 2011/1/12 14:53

  • kroewing

  • Friend of XOOPS

  • Posts: 7

  • Since: 2008/3/24


Hi folks,

I have the same problem. Did you figure out a solution for this bug. It will be great to hear from you!

Many thanks in advance
Heinz

8
playsome
Re: Problem with tag module v2.30
  • 2011/1/12 18:20

  • playsome

  • Not too shy to talk

  • Posts: 197

  • Since: 2009/4/15


Hi, i just tried to re-create this error on a test install it seems it something to do with how tag module writes its URL's

for example i had the tag 12345 sometimes the tag module will display the tag URL as view.tag.php?10 where 10 is the ID of the tag, when it is like this it seems to be fine and does not produce the invalid query however when tag module displays the URL like view.tag.php?12345 where 12345 is the actual tag (view.tag.php?tagname is OK) name it produces invalid query this is most likely because the module is getting confused and looking for a tag with an ID of 12345 if it is just a text name then there is no problem.

Not sure yet how to fix this but I will try and have a look at it.

9
chco2
Re: Problem with tag module v2.30
  • 2011/1/13 0:30

  • chco2

  • Module Developer

  • Posts: 374

  • Since: 2004/3/5 1


Well it seemed my problem was caused by the Xcenter plugin for TAG. Also.. it seems that XOOPS tag does not load the constants from a module, so you get errors and no info on the actual tags in viewtag.php I manually added the missing constants from xnews and xcenter, then it worked.
There still seems to be a bug in the plugin for Xcenter, as it does not return all the information for a tag to the TAGmodule. (like a title and text, very annoying as I can't figure out how to get it to work..)
“It's amazing the way people cling to insults. Or what they think are insults.”

10
jcweb
Re: Problem with tag module v2.30
  • 2011/1/24 0:57

  • jcweb

  • Quite a regular

  • Posts: 253

  • Since: 2005/4/25


I mean it is not a problem as long i know that problem. But i cannot contact all user, i mean i can, but the most user will not read or did forget that they not use tags with numbers. My problem is, i did not look at this problem on a former version (xoops 2.4.5) if the problem have anything to do withz the core files or only with the modules where my problems grows up (news, cbb 4.03, tag 2.3.0). It would be nice we find a solution, on some websites we have hundreds of articles include the tag module.

Thanks in adavance if you looking at this thread, i hope the devs find the time beside the core development to look at this.

Greets Andy

Login

Username:
Password:

Lost Password? Register now!

Who's Online

61 user(s) are online (46 user(s) are browsing Support Forums)


Members: 1


Guests: 60


heyula,

more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Nov 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits