1
Tarik
Hello, problem with install 2.5.0
  • 2010/11/11 15:20

  • Tarik

  • Not too shy to talk

  • Posts: 170

  • Since: 2010/2/3 1


hello every body,
first congratulation for every body for finally releasing the final version of 2.5.0 so i wanted to install this version but i got this weird error
Could not copy the distribution file to mainfile.php/data/secure.dist.php
i know that the solution is something stupid but i don't what is it
p.s: i gived the permission to all folders and file that required it

2
Tarik
Re: Hello, problem with install 2.5.0
  • 2010/11/11 16:44

  • Tarik

  • Not too shy to talk

  • Posts: 170

  • Since: 2010/2/3 1


i dont know if it would help but if i go throug the install with the error it give me
Warning: include_once(/home/amine/public_html/xoops2.5/class/database/XOOPS_DB_TYPEdatabase.php) [function.include-once]: failed to open streamNo such file or directory in /home/amine/public_html/xoops2.5/install/class/dbmanager.php on line 28  Warning: include_once() [function.include]: Failed opening '/home/amine/public_html/xoops2.5/class/database/XOOPS_DB_TYPEdatabase.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear'in /home/amine/public_html/xoops2.5/install/class/dbmanager.php on line 28  Warningnotrace:Failed to load database of typeXOOPS_DB_TYPE in file: /home/amine/public_html/xoops2.5/class/database/databasefactory.php at line 97 in /home/amine/public_html/xoops2.5/class/database/databasefactory.php on line 97  Fatal errorCall to a member function setPrefix() on a non-object in /home/amine/public_html/xoops2.5/install/class/dbmanager.php on line 48
Some people like what you do,
-- some people hate what you do,
---- but most people simply don’t give a damn.

3
ForMusS
Re: Hello, problem with install 2.5.0
  • 2010/11/11 23:07

  • ForMusS

  • Core Developer

  • Posts: 146

  • Since: 2007/10/19


Hello,

Check your server configuration, because you have some problem with your path.

MusS

4
Tarik
Re: Hello, problem with install 2.5.0
  • 2010/11/11 23:36

  • Tarik

  • Not too shy to talk

  • Posts: 170

  • Since: 2010/2/3 1


o_O what configuration do you mean php version?
i work on a local
and besides there is an installed xoops 2.4.5 in a another folder
could it be that the name of the folder is "xoops2.5"
Some people like what you do,
-- some people hate what you do,
---- but most people simply don’t give a damn.

5
ghia
Re: Hello, problem with install 2.5.0
  • 2010/11/12 2:02

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1


No, I think it is still related with your first post.
With 2.5.0, the database credentials in mainfile.php are moved to /xoops_data/data/secure.php and then included.
It seems there was a problem (maybe directory and file did not have the correct permissions set).
You can try to correct this manually (use the xxxx.dist.php files as example).

Login

Who's Online

143 user(s) are online (106 user(s) are browsing Support Forums)


Members: 0


Guests: 143


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Apr 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits