1
GPboarder
Error When Trying To Change Template Set
  • 2009/5/18 12:16

  • GPboarder

  • Friend of XOOPS

  • Posts: 248

  • Since: 2006/10/6


I am receiving the following error that was also reported here but I'm not able to find the fix.
This page cannot be displayed due to an internal error.

You can provide the following information to the administrators of this site to help them solve the problem:

ErrorSmarty error: [in db:extcal_block_minical.html line 8]: syntax errorunclosed tag {if} (opened line 5). (Smarty_Compiler.class.phpline 326)


The error reported at the bottom of the page is:
ErrorSmarty error: [in db:extcal_block_minical.html line 8]: syntax errorunclosed tag {if} (opened line 5). (Smarty_Compiler.class.phpline 326in file /class/smarty/Smarty.class.php line 1092


The error first appeared for me when trying to change the template set from the default to a clone. Other changes on the admin page work fine so far.

XOOPS Version - XOOPS 2.3.3
PHP Version - 4.4.3
MySQL Version - 4.1.22-standard
Server API Version - cgi
OS Version - Linux

ExtCal 2.2.2

Optimism is the mother of disappointment.

2
AlexSolo
Re: Error When Trying To Change Template Set
  • 2009/5/20 19:53

  • AlexSolo

  • Not too shy to talk

  • Posts: 145

  • Since: 2006/3/8 1


I just had a similar error after running xoopscare (cache and template_c cleaning) on a cloned template package whereby eliminating my ability to have any web pages using the cloned set. Had to revert to the default set. I now cannot use ANY other set other than the default. YTried using a new default set in preferences, i get a similar smarty error. YOU ARE NOT ALONE!

3
sailjapan
Re: Error When Trying To Change Template Set

What happens if you disable that extcal block? Can you go back to the template set that you want to use?
Never let a man who does not believe something can be done, talk to a man that is doing it.

4
AlexSolo
Re: Error When Trying To Change Template Set
  • 2009/5/20 23:52

  • AlexSolo

  • Not too shy to talk

  • Posts: 145

  • Since: 2006/3/8 1


I don't have extcal even installed and I'm getting these similar errors in other alpplications like news and xoopscare totally destroyed my cloned default templates. Funny thing is my local install, xampp on a Mac works perfectly fine. No major problems to think of. I am emailing my provider to see what PHP I have installed and get an upgrade to 5.0. maybe that is the whole problem!

5
GPboarder
Re: Error When Trying To Change Template Set
  • 2009/5/21 2:54

  • GPboarder

  • Friend of XOOPS

  • Posts: 248

  • Since: 2006/10/6


I don't have the block in question in use anywhere and never have had. Are you suggesting something more than just making the block invisible?

I had issues with cloned templates in an earlier version. I'm not sure of the resolution if any.

This really makes customization difficult at least as I understand it.

I will be interested to hear if it is an issue with my version of PHP.
Optimism is the mother of disappointment.

6
AlexSolo
Re: Error When Trying To Change Template Set
  • 2009/5/21 12:46

  • AlexSolo

  • Not too shy to talk

  • Posts: 145

  • Since: 2006/3/8 1


I reported a similar issue with the xoopscare ( reported elsewhere) module. same kind of smarty eror. Just checked my server install:
XOOPS Version - XOOPS 2.3.3
PHP Version - 5.1.6
MySQL Version - 5.0.27
Server API Version - apache2handler
OS Version - Linux

safe_mode - Off
register_globals - Off
magic_quotes_gpc - On
allow_url_fopen - On
fsockopen - On
allow_call_time_pass_reference - Off
post_max_size - 8M
max_input_time - 60
output_buffering - 4096
max_execution_time - 60
memory_limit - 16M
file_uploads - On
upload_max_filesize - 2M
Loaded PHP extensions «

* libxml
* xml
* wddx
* tokenizer
* sysvshm
* sysvsem
* sysvmsg
* standard
* SimpleXML
* sockets
* SPL
* shmop
* session
* Reflection
* pspell
* posix
* mime_magic
* iconv
* hash
* gmp
* gettext
* ftp
* exif
* date
* curl
* ctype
* calendar
* bz2
* zlib
* pcre
* openssl
* apache2handler
* gd
* imap
* ldap
* mbstring
* mcrypt
* mhash
* mysqli
* mysql
* odbc
* PDO
* pdo_mysql
* PDO_ODBC
* pdo_sqlite
* Zend Optimizer


As you can see I have a newer install of php than recommended by xoops. Is this my problem?

7
Cesagonchu
Re: Error When Trying To Change Template Set

I found the problem

Login

Who's Online

73 user(s) are online (41 user(s) are browsing Support Forums)


Members: 0


Guests: 73


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits