1
rageset
2.0.18.1 to 2.3.0 Final Error: Smarty error
  • 2008/9/26 21:29

  • rageset

  • Just popping in

  • Posts: 19

  • Since: 2004/5/25


I'm getting the following error when I tried to update my XOOPS site (2.0.18.1) to 2.3.0 Final.

This page cannot be displayed due to an internal error.

You can provide the following information to the administrators of this site to help them solve the problem:

Error: Smarty error: the $compile_dir 'XOOPS_VAR_PATH/caches/smarty_compile' does not exist, or is not a directory.

This error is displayed even though I have the folders xoops_data/, xoops_data/caches, xoops_data/caches/xoops_cache/, xoops_data/caches/smarty_cache/ and xoops_data/caches/smarty_compile/ created and writable on my server.

Anyone knows of a way to solve this problem?

Frank

2
limecity
Re: 2.0.18.1 to 2.3.0 Final Error: Smarty error
  • 2008/9/27 15:55

  • limecity

  • Friend of XOOPS

  • Posts: 1602

  • Since: 2003/7/6 0


I am getting the same problem.


I am stucked on the upgrade.
i get this error upgrading from 2.0.18.2

This page cannot be displayed due to an internal error.

You can provide the following information to the administrators of this site to help them solve the problem:

ErrorSmarty errorthe $compile_dir 'XOOPS_VAR_PATH/caches/smarty_compile' does not exist, or is not a directory.
Backtrace:
/class/
smarty/Smarty.class.php (1092)
/class/
smarty/internals/core.write_compiled_resource.php (20)
/class/
smarty/Smarty.class.php (1430)
/class/
smarty/Smarty.class.php (1253)
/class/
smarty/Smarty.class.php (1105)
/include/
site-closed.php (77)
/include/
common.php (291)
/
mainfile.php (102)
/
upgrade/index.php (21)


I had done the CHMOD but still . it happens.
http://www.mounthiking.com
all your hiking gears and gadgets


3
limecity
Re: 2.0.18.1 to 2.3.0 Final Error: Smarty error
  • 2008/9/27 16:05

  • limecity

  • Friend of XOOPS

  • Posts: 1602

  • Since: 2003/7/6 0


I solved the issue. well manually.

I did a clean install on a subdomain.
copied the mainfile.php

and filled it with the data from the site intended for upgrade.
and overwrtite the existing one. that solved the problem somehow.
http://www.mounthiking.com
all your hiking gears and gadgets


4
Marco
Re: 2.0.18.1 to 2.3.0 Final Error: Smarty error
  • 2008/9/27 18:22

  • Marco

  • Home away from home

  • Posts: 1256

  • Since: 2004/3/15


hello,

it deals with Chmod. Those dir have to be writable (chmod 777)
xoops_data/
xoops_data/caches/
xoops_data/caches/smarty_cache/
xoops_data/caches/smarty_compile/
xoops_data/caches/xoops_cache/
xoops_data/configs/
Moreover, we noticed such a mistake in case of making use of the Securityimage Module in your 2.0.18x to be upgraded website.
Make sure you uploaded all files on your server. The Files integrity check can help you.
Do synergy or die.

5
Daethian
Re: 2.0.18.1 to 2.3.0 Final Error: Smarty error
  • 2008/9/28 2:34

  • Daethian

  • Quite a regular

  • Posts: 305

  • Since: 2005/3/4 1


I'm in the same place...trying this for the past 4 hours and getting no closer.

I've rechecked my chmod.

The directions recommend moving the data/lib directories but it doesn't say where and does this NEED to be done prior to running upgrade?

Where is file integrity check?

This page cannot be displayed due to an internal error.

You can provide the following information to the administrators of this site to help them solve the problem:

Error: Smarty error: the $compile_dir 'XOOPS_VAR_PATH/caches/smarty_compile' does not exist, or is not a directory.
Backtrace:
http://www.artfire.com/daethian
My Artfire store- Vintage Jewelry and New Bead Jewelry

6
Marco
Re: 2.0.18.1 to 2.3.0 Final Error: Smarty error
  • 2008/9/28 7:26

  • Marco

  • Home away from home

  • Posts: 1256

  • Since: 2004/3/15


about file integrity check, please read the release_notes in /docs directory, within the package
about moving your directories, let them as they are now, first we have to find what is the problem with your upgrade.
did you install any hack in your 2.0.18?
Quote:
XOOPS_VAR_PATH/caches/smarty_compile
exists on your server? did you set the right path in the installer about it (path to the cache directory)?
Do synergy or die.

7
Daethian
Re: 2.0.18.1 to 2.3.0 Final Error: Smarty error
  • 2008/9/28 13:31

  • Daethian

  • Quite a regular

  • Posts: 305

  • Since: 2005/3/4 1


No hacks installed.
No it doesn't exist there. The directions say to create them in xoops_data not in xoops/cache.

No I didn't set any path, the directions for upgrade didn't indicate I needed to do that.

I deleted the folders indicated in the upgrade directions, so everything after this was about missing files in INSTALL and THEME folder.

[code]./favicon.ico content invalid
./class/mail/phpmailer/language/phpmailer.lang-fo.php content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/plugins/media/img/flv_player.swf content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/plugins/media/langs/sv_dlg.js content invalid
http://www.artfire.com/daethian
My Artfire store- Vintage Jewelry and New Bead Jewelry

8
rageset
Re: 2.0.18.1 to 2.3.0 Final Error: Smarty error
  • 2008/9/28 14:34

  • rageset

  • Just popping in

  • Posts: 19

  • Since: 2004/5/25


So I'm not the only person that is going through this. I have a few hacks applied to my XOOPS site installation, but they are security hacks proposed by GIJOE.

I thought about a fresh install of xoops, but I don't want to go through all the trouble. I guess I'll wait to update my version of XOOPS on a later date.

9
tank1955
Re: 2.0.18.1 to 2.3.0 Final Error: Smarty error
  • 2008/9/28 15:25

  • tank1955

  • Module Developer

  • Posts: 276

  • Since: 2007/9/7 1


I recently upgraded several sites to 2.3.0 and had the same error where the system told me it could not find XOOPS_VAR_PATH/caches/smarty_compile. I am not sure if this is a proper solution but the following worked for me.

In the 2.3.0 install package locate the following file:
xoops-2.3.0\htdocs\class\template.php

Open the file and locate the following code near the beginning of the file

$this->template_dir XOOPS_THEME_PATH;
        
$this->cache_dir XOOPS_VAR_PATH "/caches/smarty_cache";
        
$this->compile_dir XOOPS_VAR_PATH "/caches/smarty_compile";


Change the compile_dir definition line so it appears like this:

$this->template_dir XOOPS_THEME_PATH;
        
$this->cache_dir XOOPS_VAR_PATH "/caches/smarty_cache";
        
$this->compile_dir XOOPS_ROOT_PATH "/xoops_data/caches/smarty_compile";


As I said I am not sure if this is a proper or sanctioned fix but after I made this change performing the upgrade worked like a charm.

10
Daethian
Re: 2.0.18.1 to 2.3.0 Final Error: Smarty error
  • 2008/9/28 16:20

  • Daethian

  • Quite a regular

  • Posts: 305

  • Since: 2005/3/4 1


YOU RULE!!!!!!!!!!!!!!!!

That seems to have done the job :)
http://www.artfire.com/daethian
My Artfire store- Vintage Jewelry and New Bead Jewelry

Login

Username:
Password:

Lost Password? Register now!

Who's Online

57 user(s) are online (20 user(s) are browsing Support Forums)


Members: 0


Guests: 57


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits