1
Sir_Saeed
'Remember me' doesn't work in 2.3!
  • 2008/9/24 16:39

  • Sir_Saeed

  • Just popping in

  • Posts: 41

  • Since: 2007/10/10


in some sites I've used XOOPS 2.3 final, remember me for login works, and in some others it doesn't.
what the reason?

2
Marco
Re: 'Remember me' doesn't work in 2.3!
  • 2008/9/24 17:01

  • Marco

  • Home away from home

  • Posts: 1256

  • Since: 2004/3/15


hum,well, what do you mean by does not work exactly?
Do synergy or die.

3
Sir_Saeed
Re: 'Remember me' doesn't work in 2.3!
  • 2008/9/24 17:55

  • Sir_Saeed

  • Just popping in

  • Posts: 41

  • Since: 2007/10/10


well, in one site, as I close Firefox (3.0.1) (don't log out) and open it again, I'm logged out!

in another one, I had a problem only with FF (everything's ok in IE 7) that I've got sth like session time-out or sth, as I don't do any activities for some minutes, and then I try a link, I see I'm logged out and then, even when I log in and receive welcome message, in the next page, I'm still logged out!
in this case, I cleared FF cookies and problem was solved, but I think it can't be a permanent solution!

4
Marco
Re: 'Remember me' doesn't work in 2.3!
  • 2008/9/24 18:06

  • Marco

  • Home away from home

  • Posts: 1256

  • Since: 2004/3/15


check the cookie security options in your browser, it seems to be the solution
i've no problem here with FF3.x
Do synergy or die.

5
Sir_Saeed
Re: 'Remember me' doesn't work in 2.3!
  • 2008/9/24 22:55

  • Sir_Saeed

  • Just popping in

  • Posts: 41

  • Since: 2007/10/10


I still have the problem!
When I leave my site and come back some hours later, I'm logged out ('remember me' does not work!)
in IE, I can normally log in, but in FF I must remove cookies to be able to log in, if not, I enter and see welcome page, but in next page I'm not logged in still.

what's this damn problem??

6
jimbofoxman
Re: 'Remember me' doesn't work in 2.3!

Where does the "REMEMBER ME" option get turned on in 2.3?

7
Marco
Re: 'Remember me' doesn't work in 2.3!
  • 2008/9/26 17:34

  • Marco

  • Home away from home

  • Posts: 1256

  • Since: 2004/3/15


in the general preferences, it's turned on by default. if you don't set a cookie session name, it's deactivated
Do synergy or die.

8
ghia
Re: 'Remember me' doesn't work in 2.3!
  • 2008/9/26 18:01

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1


Quote:
in the general preferences, it's turned on by default
I believe it would be better that it is by default off and the option of 'Remember me' is unchecked.

9
colossus
Re: 'Remember me' doesn't work in 2.3!
  • 2008/9/26 19:16

  • colossus

  • Just popping in

  • Posts: 43

  • Since: 2007/9/30


Hi:

Quote:
I believe it would be better that it is by default off and the option of 'Remember me' is unchecked.


I agree. Besides, the template involved throws a HTML validation error:

Quote:
…ue="On" class ="formButton" checked />Remember me<br />
"VI delimiter" is a technical term for the equal sign. This error message means that the name of an attribute and the equal sign cannot be omitted when specifying an attribute. A common cause for this error message is the use of "Attribute Minimization" in document types where it is not allowed, in XHTML for instance. How to fix: For attributes such as compact, checked or selected, do not write e.g <option selected ... but rather <option selected="selected" ...


That's line 7 in modules/system/templates/blocks/system_block_login.html. Deleting the "checked" in that line will make the remember me off by default, and avoid one validation error at the same time.

Regards: Colossus

10
Sir_Saeed
Re: 'Remember me' doesn't work in 2.3!
  • 2008/9/29 13:34

  • Sir_Saeed

  • Just popping in

  • Posts: 41

  • Since: 2007/10/10


first of all, someone told me that I must delete system module and upload the new one. it didn't seem to be reasonable but I did, and It worked! the problem was solved and auto login started to work!

but still, there's similar problem as Firefox's being updated. any time a new version of FF is installed, I'm logged out, and can't log in again as long as I haven't removed specified cookies.

does anybody knows how this procedure goes which leads to this problem?

Login

Who's Online

68 user(s) are online (42 user(s) are browsing Support Forums)


Members: 0


Guests: 68


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jul 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits