1
agf8623
text editors not working
  • 2008/1/27 1:42

  • agf8623

  • Just popping in

  • Posts: 59

  • Since: 2004/5/15


I have a bunch of text editors in my root/class/xoopseditor folder, and in a couple of modules like News, I'm able to select these editors. However, only the default XOOPS editors are working. Was there something that I needed to do during installation to get the other editors to work? tinymce, koivi, FCKeditor... none of them work. Only the default DHTML and simple text editor.

I tried to search on this, but a bunch of non-related stuff came up. Can someone point me to a topic about this problem?

Thanks!

2
McDonald
Re: text editors not working
  • 2008/1/27 2:47

  • McDonald

  • Home away from home

  • Posts: 1072

  • Since: 2005/8/15


You need Framework too, see here.

3
agf8623
Re: text editors not working
  • 2008/1/27 5:25

  • agf8623

  • Just popping in

  • Posts: 59

  • Since: 2004/5/15


It worked! Thank you!

4
rgidon
Re: text editors not working
  • 2008/2/17 8:01

  • rgidon

  • Just popping in

  • Posts: 1

  • Since: 2008/1/22


I install FCKeditor And Framework but the FCKeditor dosn't work with news module... why ?

5
McDonald
Re: text editors not working
  • 2008/2/17 11:10

  • McDonald

  • Home away from home

  • Posts: 1072

  • Since: 2005/8/15


I have never used FCKEditor, so I don't know.
My prefered WYSIWYG editor for XOOPS is TinyEditor. It's TinyMCE adapted for XOOPS. Comes with loads of plugins etc.
You can download it here (point 13): http://members.lycos.nl/mcdonaldsstore/

6
Anonymous
Re: text editors not working
  • 2008/2/17 11:28

  • Anonymous

  • Posts: 0

  • Since:


Quote:
rgidon wrote:

I install FCKeditor And Framework but the FCKeditor dosn't work with news module... why ?


It is because News (and to my knowledge SmartSection) look for the wysiwyg editors in a different directory. They look for the editors in:

xoops_root/class/wysiwyg

rather than

xoops_root/class/xoopseditor

I think this will work......

1. copy the FCKeditor directory (or any other xoopseditor that you want to use) from xoops_root/class/xoopseditor/ to the /class directory, e.g.

xoops_root/class/FCKeditor

2. rename the new folder to "wysiwyg", i.e.

xoops_root/class/wysiwyg


This FAQ refers.

7
AndyM
Re: text editors not working
  • 2008/2/19 20:57

  • AndyM

  • Quite a regular

  • Posts: 296

  • Since: 2003/8/31


I have this problem in my Articles module - it was a while ago, so I forget what happened now, but something changed in either the XOOPS editors package, or XOOPS itself which caused anything other than the default editors to stop working in Articles and News, etc.

As far as I remember, CBB has its own solution, but when I last tried it, it seemed a bit hit and miss as to whether it would work.

I think it will work with some of the editor packages if you still get them, as they were before the editors package was released.

I don't think the problem has ever been sorted - if anyone knows how to fix it properly, please let me know!

8
Anonymous
Re: text editors not working
  • 2008/2/19 21:47

  • Anonymous

  • Posts: 0

  • Since:


Quote:
AndyM wrote:

As far as I remember, CBB has its own solution, but when I last tried it, it seemed a bit hit and miss as to whether it would work.

I think it will work with some of the editor packages if you still get them, as they were before the editors package was released.


CBB 3.0x uses the xoopseditors package (which is a required download along with the Frameworks).

Nothing "hit or miss" about CBB using the xoopseditors. As long as "Allow HTML" is set to "Yes" each Forum's set-up the the editors can be used.

HTH

9
stefan88
Re: text editors not working
  • 2008/2/19 22:17

  • stefan88

  • Community Support Member

  • Posts: 1085

  • Since: 2004/9/20


Quote:
My prefered WYSIWYG editor for XOOPS is TinyEditor. It's TinyMCE adapted for XOOPS. Comes with loads of plugins etc.


I remember it has a multilanguage plugin, but it works with one of the hacks (I think it was for marcans multilanguage hack). Is there a xLanguage plugin for TinyEditor?
..

10
AndyM
Re: text editors not working
  • 2008/2/19 22:27

  • AndyM

  • Quite a regular

  • Posts: 296

  • Since: 2003/8/31


Quote:

JAVesey wrote:

CBB 3.0x uses the xoopseditors package (which is a required download along with the Frameworks).

Nothing "hit or miss" about CBB using the xoopseditors. As long as "Allow HTML" is set to "Yes" each Forum's set-up the the editors can be used.

HTH


It was probably over a year ago I was having problems with CBB on one or two sites, it wouldn't pick up the editors - but the "problem" could have been caused by not allowing HTML, I don't know now as it was so long ago.

Login

Who's Online

55 user(s) are online (28 user(s) are browsing Support Forums)


Members: 0


Guests: 55


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits