1
Blixer
How Do I Edit a Page in Wiwi?
  • 2007/3/22 21:49

  • Blixer

  • Just popping in

  • Posts: 21

  • Since: 2007/3/3 1


I have installed Wiwi 0.86.

I'm using:
xoops 2.0.16
Apache 2.2
mysql 5.0.27-community-nt

The default page shows up, but I don't seem to be able to edit the page. I've tried accessing it from the "Pages" tab in the Module Admin functions. If I click on the Page ID Name or on History or anything else, nothing seems to happen. If I leave the administration mode and go directly to the page, I don't seem to have any edit options there. Sometimes and "update" button will show up but I can't seem to do anything that allows a change. If I click on the "update" button, nothing seems to happen.

Any thoughts or ideas?

Since I've never seen this module actually function, I don't even have a clue as to what it should look like when it is operating properly.

Thanks!

2
skenow
Re: How Do I Edit a Page in Wiwi?
  • 2007/3/23 0:01

  • skenow

  • Home away from home

  • Posts: 993

  • Since: 2004/11/17


Blixer - I know you've been trying to get this module to work, so hopefully I can help you through this. (based on 0.8.3 and the fact that you have been following the Starting a new XOOPS site thread)

After you install Wiwimod, you will need to set some preferences to get the WYSIWYG editor by default. Go to Admnistration Menu - Wiwi - Preferences. Change the editor to XoopsEditor in the first box. Then, select Koivi WYSIWYG Editor in the second box.

You won't be able to set the default profile, yet, but the next 3 options can be set - I usually set them all to 'Yes'. Leave the last 4 options for now, you can come back to them later. Click the Go! button to save your settings.

Go to the public area of your site and click on the Wiwi link in the main menu. You should see an Edit button below the content of the page - click it and the page will open in edit mode. Type in the text area, make changes, and click the Preview button at the bottom of the page. Once you are satisfied, click on the New Revision button at the bottom of the page - this will save a new copy and make it the one displayed. Later, you can view history and restore the original version if you would like.

Please note: If you have set this module to be cached (in System Admin - Preferences) your changes may not appear immediately, even though you were told your changes were saved. The cache can also keep the Edit button from appearing if you have viewed the page before logging in and gaining access to editing (not a problem if anonymous visitors can edit). I usually set the cache pretty low (1 minute), since I spend a fair amount of time editing/previewing before saving.

Also note: current browsers block access to the clipboard so copy/right-click/paste won't work. There is an extension for Firefox called AllowClipboard Helper to customize your browser and allow this.

3
Blixer
Re: How Do I Edit a Page in Wiwi?
  • 2007/3/23 0:20

  • Blixer

  • Just popping in

  • Posts: 21

  • Since: 2007/3/3 1


Quote:

skenow wrote:

You won't be able to set the default profile, yet, but the next 3 options can be set - I usually set them all to 'Yes'. Leave the last 4 options for now, you can come back to them later. Click the Go! button to save your settings.

Go to the public area of your site and click on the Wiwi link in the main menu. You should see an Edit button below the content of the page - click it and the page will open in edit mode. Type in the text area, make changes, and click the Preview button at the bottom of the page. Once you are satisfied, click on the New Revision button at the bottom of the page - this will save a new copy and make it the one displayed. Later, you can view history and restore the original version if you would like.



skenow,
I have set the editors as you said. There was no place for default profile unless it doesn't show up till later.

When I go to the main page and click on the Wiwi link in the main menu, I do get the default page with an "Edit" button at the bottom. But when I click on the "Edit" button, the page flashes and just returns to the same content page. I never get any text area to make changes. That has been my frustration. I thought I should get a text area or something. But nothing ever allows me to do that.

Here are some links to some screen shots from the setup.

Screen shot of the xoopseditor subdirectory
Wiwi Module Configuration screen
Wiwi Default Page with Edit Button that doesn't seem to work

So now what?

Thanks

4
skenow
Re: How Do I Edit a Page in Wiwi?
  • 2007/3/23 1:38

  • skenow

  • Home away from home

  • Posts: 993

  • Since: 2004/11/17


David -

Here's what the preferences page should look like and here is what the edit page should look like.

I recommend a fresh start for this module - deactivate it, uninstall it, delete the folder from the /modules folder and delete the files from /templates_c, except for index.html. Brief list of instructions, I know, I'll add this to this list of posts to add to Starting a New XOOPS Site.

5
Blixer
Re: How Do I Edit a Page in Wiwi?
  • 2007/3/23 2:14

  • Blixer

  • Just popping in

  • Posts: 21

  • Since: 2007/3/3 1


When I try to access the manual it says that it is a restricted access page.

6
Blixer
Re: How Do I Edit a Page in Wiwi?
  • 2007/3/23 2:40

  • Blixer

  • Just popping in

  • Posts: 21

  • Since: 2007/3/3 1


Steve,

I uninstalled everything as you suggested. I deleted my original download and got a new zip from the download site. I unpacked it and installed it. I did have the "Default Profile" option now. But when I go to the home page and select wiwi and then click on the "edit" button the screen just flashes and I'm right back where I started from with no editing screen. I'm at a total loss and just a tad bit frustrated.

Any more insight?

7
skenow
Re: How Do I Edit a Page in Wiwi?
  • 2007/3/23 3:03

  • skenow

  • Home away from home

  • Posts: 993

  • Since: 2004/11/17


Your reference to an 'update' button confuses me, I have never seen this, and I use the module a lot.

8
Blixer
Re: How Do I Edit a Page in Wiwi?
  • 2007/3/23 3:39

  • Blixer

  • Just popping in

  • Posts: 21

  • Since: 2007/3/3 1


Sorry, it's the "Edit" button. It's been a long day. I made the correction in my previous post.

Main Page with Edit button

This is all I ever see. When I click the "Edit" button there is a quick flash and nothing changes. There is no editing screen. Just this same screen over and over again.

9
WarDick
Re: How Do I Edit a Page in Wiwi?
  • 2007/3/23 6:45

  • WarDick

  • Just can't stay away

  • Posts: 890

  • Since: 2003/9/13


You did not mention what version of PHP you are using. I believe this module has issues with PHP5.

I used to be a big fan of wiwimod. I have stopped using it in favor of pico.
Urging XOOPS to be the Best It Can Be.
Richard......

10
Anonymous
Re: How Do I Edit a Page in Wiwi?
  • 2007/3/23 8:26

  • Anonymous

  • Posts: 0

  • Since:


Quote:
Blixer wrote:

I have installed Wiwi 0.86.


I'm confused.........thought that the latest XOOPS version was 0.8.3? See the wiwimod homepage here.

I can confirm that 0.8.3 works well with XOOPS 2.0.16 - not sure what version of php I'm using, though. Will find out.

Cheers

Login

Who's Online

298 user(s) are online (204 user(s) are browsing Support Forums)


Members: 0


Guests: 298


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Apr 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits