Can No Longer Install Modules!
  • 2007/3/11 19:16

  • cwebb02

  • Just popping in

  • Posts: 10

  • Since: 2007/1/25

Hello there. Before recently, I've been able to add modules no problem. Then one failed, and since then, anytime I put a module in the moduels folder, it doesn't show up or says file not found. I'm certain that I have the right folder in there, and no I'm not putting up the zip/.tar file in there. Is there a way to refresh or delete or a fix?? Thanks

Re: Can No Longer Install Modules!
  • 2007/3/11 20:05

  • Stewdio

  • Community Support Member

  • Posts: 1560

  • Since: 2003/5/7 1

Log in through FTP, and delete any faulty modules as a starter. Log into your site and head ovder to module administration and verify that the modules don't show up on the bottom half of the page.

Upload a module for testing, and see if you get the same results. Try to make this one of the ones that failed on you. As soon as it installs, uninstall it to remove the tables it added to your Database. This is just for kicks at this stage. If it happens to work, your in luck. If not, well, you have to dig a little deeper.

Log into phpmyadmin through your site administration panel, this will either be Plesk or CPanel, depending on your hosting environment.

Back up your database.

Look for and delete any module tables that point to the faulty modules. Don't be afraid to browse around a bit, you won't harm anything. You will more then likely find the offending faulty module installation tables on the first page of your phpmyadmin page.

Check them off, and drop the tables. This will effectively uninstall your module. Go back to your FTP and delete the test module we did above if it's still failing.

Why all this is happening, I can't tell you. This is what I Would do if I were in your shoes and shouldn't take more then 10 or 15 minutes of your time.

Good Luck.
XOOPS Community Support

Re: Can No Longer Install Modules!
  • 2007/3/11 23:50

  • perrbr

  • Just popping in

  • Posts: 2

  • Since: 2007/3/11

I'm working on this with cwebb02, and so I tried (part of) your suggestions. We can't install a module to test, because they will not show up on the modules page. We did have some modules installed that sort of worked (XoopsGallery) but I deleted it since it wouldn't work how I wanted it to. So, in phpMyAdmin I deleted a bunch of tables left over from XoopsGallery, and WordPress, since we got rid of these modules, but it still won't let us add new ones. The modules we have installed and working right now are:
NewBB 2.0
and Polls
These are also the only modules that show up in the 'xoops_modules' table.
We have tried a couple of different modules, so it doesn't seem to be a problem with the modules we are trying to install. Any suggestions would be great!

Re: Can No Longer Install Modules!
  • 2007/3/12 2:35

  • skenow

  • Home away from home

  • Posts: 993

  • Since: 2004/11/17

This can happen if you upload a module that requires Frameworks and the Frameworks folder has not been uploaded. Have you added the recent verions of CBB or Article?

Re: Can No Longer Install Modules!
  • 2007/3/12 2:59

  • perrbr

  • Just popping in

  • Posts: 2

  • Since: 2007/3/11

Well I don't think any of our modules require frameworks. Are you saying if you try to use one that does require frameworks, then other modules won't work either? I'm guessing you just mean the ones that require frameworks won't work, and if that is the case, then I don't think that is the problem. I'm not sure if some of the modules we have tried have required other stuff, but I have removed pretty much everything that we decided not to use. (both deleted folders via FTP, and removed their database tables)

EDIT: thinking more about Stewdio's advice, I might have left some database tables that I should remove. Is there any list anywhere of what tables should be included with the default XOOPS installation? Is there also a good way to know what tables each module will add?


Who's Online

50 user(s) are online (32 user(s) are browsing Support Forums)

Members: 0

Guests: 50



Goal: $100.00
Due Date: Feb 28
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits