1
LionHeart
Changed theme folder = White page for all themes
  • 2006/10/9 2:55

  • LionHeart

  • Just popping in

  • Posts: 70

  • Since: 2005/5/14


XOOPS Version: 2.0.15
PHP Version: 4.4.4
MySQL Version: 4.1.21
Web Server Software (Apache/IIS/Other): Apache/1.3.37
Operating System: Linux
Theme you are using: phpkaox
Custom template: (Yes/No) No

A full description of the issue:

This is a fresh installation, only a few days old. Modules are installed, and a theme designer is working on a custom theme for me. I have phpkaox set as default.

The designer sent me the latest build, the theme name is "Classic". I wanted to install the latest build alongside the earlier one, so that we could compare the update, so I renamed the themes in the directory (and I think this is where I screwed it up). I renamed the earlier builds to "Classic01" and "Classic02", and renamed the latest build to "Classic03". I enabled the themes in preferences.

I think tried to go back to the home page, and got the 'white screen'. I back-paged to return to the admin. I went to the System module and updated it. I created a new template set and selected it, as a just in case (probably too late, but it was a shot). I deleted all the files from template_c/ except for the index.html. I checked to make sure that no module caching was enabled.

Nothing helped. I still have a white screen, even the default theme comes up white.

I searched here, and the only thing I could find was a note that said, "Don't rename the theme folder or bad things will happen". I think I've found the 'bad thing'. :(

Please, anyone, help? Any ideas for fixing this?

2
snow77
Re: Changed theme folder = White page for all themes
  • 2006/10/9 5:19

  • snow77

  • Just can't stay away

  • Posts: 864

  • Since: 2003/7/23


Quote:

The designer sent me the latest build, the theme name is "Classic". I wanted to install the latest build alongside the earlier one, so that we could compare the update, so I renamed the themes in the directory (and I think this is where I screwed it up). I renamed the earlier builds to "Classic01" and "Classic02", and renamed the latest build to "Classic03". I enabled the themes in preferences.


If the very first theme you had active before doing all this was named Classic, then have one of those themes be named just the same as the one defined in preferences of your website, so I would guess you should name it Classic, just classic with no number to it.

You could also change the default theme setting from the database in the config table, when you examine it, you should be able to see an entry called theme_set; you could edit it and put the exact name of folder of the theme found in the themes folder of your XOOPS install which you want to set as default.

If it continues blank then maybe it could be that this new theme needs some corrections done to it, so maybe you could consult with your theme designer if he could show you the theme working at a demo site.

- creating a new template set will not solve the problem.

3
LionHeart
Re: Changed theme folder = White page for all themes
  • 2006/10/9 16:20

  • LionHeart

  • Just popping in

  • Posts: 70

  • Since: 2005/5/14


Hi Snowy

I restored the folder name to "Classic", updated the System module, made sure the themes were properly selected, but no joy.

I went into the database and checked, theme_set has "phpkaox" in it, as it should. Still a white-screen.

Good ideas, thanks for thinking on it!

4
snow77
Re: Changed theme folder = White page for all themes
  • 2006/10/9 18:34

  • snow77

  • Just can't stay away

  • Posts: 864

  • Since: 2003/7/23


now that is strange... no error messages on the blank page? can you turn debug on? first php? then smarty and report which errors displayed? what is the url to the site?

make sure cache, templates_c and uploads directories have 777 permissions

5
LionHeart
Re: Changed theme folder = White page for all themes
  • 2006/10/17 3:57

  • LionHeart

  • Just popping in

  • Posts: 70

  • Since: 2005/5/14


Debug was on, permissions were correct, and I dumped the cache directories (except for the index file), nothing helped.

Since the site is a fairly new install and I was still configuring, after a day of frustration, I deleted the installation and started from scratch. Everything's fine now, I just wish I knew exactly why XOOPS went south on me, and how to bring it back if it happens again.

6
unimatrix
Re: Changed theme folder = White page for all themes
  • 2006/10/26 18:25

  • unimatrix

  • Just popping in

  • Posts: 17

  • Since: 2005/12/24


I'm having similar problems. FInally I got a new theme to work, but when I try to log in as admin, I get a blank white page...how do I fix this so I can go in and at least reset the main theme.

Also I've found clearing browser caches help if you go to a new theme.

7
tmreg
Re: Changed theme folder = White page for all themes
  • 2006/10/30 16:56

  • tmreg

  • Not too shy to talk

  • Posts: 137

  • Since: 2006/7/20


I just had the same problem and found a fix for it. I attempted to change the filename of a theme from the server, thus giving me the "white screen of death". I could get into the backend of the site.

FIX: I set the theme to default, saved the other theme to my desktop, deleted them on the server, cleared my browser's cache, reinstalled the theme with the name I wanted, and then went back into the backend and changed the theme to the newly uploaded one. Worked for me.
-Matt

Login

Username:
Password:

Lost Password? Register now!

Who's Online

61 user(s) are online (31 user(s) are browsing Support Forums)


Members: 0


Guests: 61


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits