xoops forums

etcpinoy

Just popping in
Posted on: 2005/1/12 10:29
etcpinoy
etcpinoy (Show more)
Just popping in
Posts: 10
Since: 2004/12/7
#1

Problem with AMS... Please help!!!

Can anyone help me with this?
I recently installed the latest AMS 2.2. I encountered several errors including the blank pages mentioned somewhere in this support forum and tried also the corresponding solutions mentioned but got the same problems again and again and so I tried to reinstall AMS. What I've found is something worse. I got these errors when I tried to change the submit/approve permissions:


Warning [PHP]: array_keys(): The first argument should be an array in file class/xoopsform/grouppermform.php line 135
Warning [PHP]: Invalid argument supplied for foreach() in file class/xoopsform/grouppermform.php line 135
Warning [PHP]: Invalid argument supplied for foreach() in file class/xoopsform/grouppermform.php line 255
Notice [PHP]: Undefined variable: option_ids in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: implode(): Bad arguments. in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: Invalid argument supplied for foreach() in file class/xoopsform/grouppermform.php line 255
Notice [PHP]: Undefined variable: option_ids in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: implode(): Bad arguments. in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: Invalid argument supplied for foreach() in file class/xoopsform/grouppermform.php line 255
Notice [PHP]: Undefined variable: option_ids in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: implode(): Bad arguments. in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: Invalid argument supplied for foreach() in file class/xoopsform/grouppermform.php line 255
Notice [PHP]: Undefined variable: option_ids in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: implode(): Bad arguments. in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: array_keys(): The first argument should be an array in file class/xoopsform/grouppermform.php line 135
Warning [PHP]: Invalid argument supplied for foreach() in file class/xoopsform/grouppermform.php line 135
Warning [PHP]: Invalid argument supplied for foreach() in file class/xoopsform/grouppermform.php line 255
Notice [PHP]: Undefined variable: option_ids in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: implode(): Bad arguments. in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: Invalid argument supplied for foreach() in file class/xoopsform/grouppermform.php line 255
Notice [PHP]: Undefined variable: option_ids in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: implode(): Bad arguments. in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: Invalid argument supplied for foreach() in file class/xoopsform/grouppermform.php line 255
Notice [PHP]: Undefined variable: option_ids in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: implode(): Bad arguments. in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: Invalid argument supplied for foreach() in file class/xoopsform/grouppermform.php line 255
Notice [PHP]: Undefined variable: option_ids in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: implode(): Bad arguments. in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: array_keys(): The first argument should be an array in file class/xoopsform/grouppermform.php line 135
Warning [PHP]: Invalid argument supplied for foreach() in file class/xoopsform/grouppermform.php line 135
Warning [PHP]: Invalid argument supplied for foreach() in file class/xoopsform/grouppermform.php line 255
Notice [PHP]: Undefined variable: option_ids in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: implode(): Bad arguments. in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: Invalid argument supplied for foreach() in file class/xoopsform/grouppermform.php line 255
Notice [PHP]: Undefined variable: option_ids in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: implode(): Bad arguments. in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: Invalid argument supplied for foreach() in file class/xoopsform/grouppermform.php line 255
Notice [PHP]: Undefined variable: option_ids in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: implode(): Bad arguments. in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: Invalid argument supplied for foreach() in file class/xoopsform/grouppermform.php line 255
Notice [PHP]: Undefined variable: option_ids in file class/xoopsform/grouppermform.php line 273
Warning [PHP]: implode(): Bad arguments. in file class/xoopsform/grouppermform.php line 273

Plus I got this error:

Notice [PHP]: Undefined index: fct in file modules/wordpress/include/updateblock.inc.php line 4

I don't know how wordpress got into this.

jdseymour

Friend of XOOPS
Posted on: 2005/1/12 10:42
jdseymour
jdseymour (Show more)
Friend of XOOPS
Posts: 3782
Since: 2004/11/11
#2

Re: Problem with AMS... Please help!!!

Sorry to ask this, I know the output from PHP debug is long.

Did your changes you made save within AMS?

etcpinoy

Just popping in
Posted on: 2005/1/12 10:52
etcpinoy
etcpinoy (Show more)
Just popping in
Posts: 10
Since: 2004/12/7
#3

Re: Problem with AMS... Please help!!!

If you're referring to the articles, yeah, I have made copies of them with notepad just in case. But I am willing to start from zero with AMS if required but not zero with the whole XOOPS sytem.

jdseymour

Friend of XOOPS
Posted on: 2005/1/12 10:54
jdseymour
jdseymour (Show more)
Friend of XOOPS
Posts: 3782
Since: 2004/11/11
#4

Re: Problem with AMS... Please help!!!

No, I am speaking of the submit/approve permissions. Did these changes save for you?

etcpinoy

Just popping in
Posted on: 2005/1/12 10:57
etcpinoy
etcpinoy (Show more)
Just popping in
Posts: 10
Since: 2004/12/7
#5

Re: Problem with AMS... Please help!!!

No. They return back to zero (I mean, with all the checkboxes unchecked)

jdseymour

Friend of XOOPS
Posted on: 2005/1/12 11:12
jdseymour
jdseymour (Show more)
Friend of XOOPS
Posts: 3782
Since: 2004/11/11
#6

Re: Problem with AMS... Please help!!!

Ok on that page it is kind of confusing. brash is working on an updated version that should be released soon to make it more user friendly.
On that page you have three permission areas:

The top one is "Approve Permissions" and there is a submit button at the bottom of that area.

The middle is "Submit Permissions" and there is a submit button at the bottom of that area also.

The bottom is "View Permissions" and at the bottom of that section is a submit button.

Each of these sections have to be set separately, using the submit button for that category of permissions. Not saying that you did not do it this way. But it got me confused the first few times I set it up.

I entered all the permissions in all sections and then hit submit in the bottom most submit button and the only changes made were to view permissions.

etcpinoy

Just popping in
Posted on: 2005/1/12 11:16
etcpinoy
etcpinoy (Show more)
Just popping in
Posts: 10
Since: 2004/12/7
#7

Re: Problem with AMS... Please help!!!

The first time I installed AMS everything was not as worse as this time. I can set permissions to user groups without any problem. Only that when I reinstalled AMS module that this problem came out. By the way the previous problem I had was with the topic ID being set to zero everytime I add a new topic so I had to reassign it again directly in the database.
With the current problem I'm having, do you think it might be caused by my upgrade to XOOPS 2.0.9.2?

jdseymour

Friend of XOOPS
Posted on: 2005/1/12 11:20
jdseymour
jdseymour (Show more)
Friend of XOOPS
Posts: 3782
Since: 2004/11/11
#8

Re: Problem with AMS... Please help!!!

No, I use AMS on 2.0.9.2 without any problems. brash is here maybe he has some ideas.

I would also suggest joining or visiting his support site.

brash

Friend of XOOPS
Posted on: 2005/1/12 11:23
brash
brash (Show more)
Friend of XOOPS
Posts: 2206
Since: 2003/4/10
#9

Re: Problem with AMS... Please help!!!

Just to make you feel better etcpinoy, I've never seen those errors you posted before.....hang on, I said make you feel better didn't I ...

It sounds like something is seriously twisted up in your AMS tables. Can you point me to the instructions you used to try and fix your AMS install first time around? It *should* help me back track you problems.

etcpinoy

Just popping in
Posted on: 2005/1/12 11:34
etcpinoy
etcpinoy (Show more)
Just popping in
Posts: 10
Since: 2004/12/7
#10

Re: Problem with AMS... Please help!!!

Thank you.

Here's the link the the topic

https://xoops.org/modules/news/article ... flat&com_order=0&start=10

The one posted by irmtfan saying:

i install this module in my test site and when i import from news1.2 i get this error in index:
Fatal error: Call to a member function on a non-object in /home/.../public_html/test/modules/AMS/class/class.newsstory.php on line 740
and this notice:
Notice [PHP]: Undefined index: 0 in file modules/AMS/class/class.newsstory.php line 82