News 1.2.1
  • 2004/9/18 17:16

  • Josem

  • Just popping in

  • Posts: 18

  • Since: 2004/8/22

"News 1.2.1 module". This is the newest module and I cannot upgrade to it. For one thing, when substituting the module to the "/modules" directory and attempting to upgrade through the admin page, the icon is not present on the page. It says "Module file for news Module Not found! (twice). The upgrade script...I don't know. I cannot make it work, it is probbaly something to do with permissions but my webserver has permissions over those directories. But I believe using this script is not necessary if I am able to upgrade through the main Admin page.

I am running XOOPS with the latest version except, the news module. So the news module for version works fine (1.1), but not with News 1.2.1 (or 1.2).

I would like to know is anybody found a problem like this and how it was solved.

I want to take advantage of News 1.2.1(especially the columns attribute so I can have 2 or 3 columns)

Re: News 1.2.1
  • 2004/9/18 20:45

  • sbkiller

  • Just can't stay away

  • Posts: 461

  • Since: 2004/6/9 2

Make sure you have a xoops_version.php in your news folder, otherwise upload it again.

Re: News 1.2.1
  • 2004/9/19 1:58

  • Josem

  • Just popping in

  • Posts: 18

  • Since: 2004/8/22

The version file was there allright, but the I checked the permissions and they were 600.

Here is where the problem was as far as I can see:
When I uploaded "/news" to the module directory, the directories in this module had the permissions set to 700 and the files contained in them to 600. I changed the permisisons to 755 for the directories (I am always referring to the "News 1.2.1" module in this post) and 644 for the single files and the module worked. I am thinking about changing them back to 600 and have 'chown www-data' (running debian) to be owned by the webserver. Hopefully this will work also. i like the improvements in this module. Very good.

Re: News 1.2.1
  • 2005/1/17 16:22

  • simonvl

  • Just popping in

  • Posts: 44

  • Since: 2004/1/28

Does anyone know where you can download a version of news 1.2.1 with all the permissions correct. it takes ages to go through and change all the permissions of all the files!!!
thanks in advance- have searched around with no luck!


Who's Online

121 user(s) are online (81 user(s) are browsing Support Forums)

Members: 0

Guests: 121



Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits