1
stealth
Admin login problem
  • 2004/8/20 15:58

  • stealth

  • Just popping in

  • Posts: 8

  • Since: 2004/8/20


Hi folks,

I did a clean 2.0.7 install today and the installation went off without a hitch.

When I tried to access my site for the first time, I realized I couldn't log on as admin user. I created a normal user, but no luck either. I just get redirected to the the login page again. If I try to access the /admin directory directly, it of course displays an error message ("You don't have the right to access this area") and tries to re-direct me to the login page again wich fails because it dosen't know where I came from. That should be the out of the box behavior I suppose.

I went to the forum and did some digging but the stuff that turned up didn't fix my problem. I guess my server conf would be of help here:

OS: GNU/Linux
Httpd: Apache 2.0.49
PHP: 4.3.6

Since I've read that the standard Apache 2.x conf does fine for Xoops, this should be out of the question.
Here some settings from my php.ini

safe_mode = on
register_globals = off

session.autostart = 0
session.entropy_length = 16
session.entropy_file = /dev/urandom
session.use_trans_sid = 0

I'm also using output buffering and zlib compression but that shouldn't be a problem I believe.

What I did so far:
I've set the value for debug_mode in the conf table to true, to catch error messages but that didn't help. Seems like that problem dosen't raise an error

I've chmod'ed all files that don't need write access by the webserver to 644.
I've chmod'ed all directories that don't need write access by the webserver to 755
I've chmod'ed all directories that need write access by the webserver to 777
I've chmod'ed all files that need write access by the webserver to 666

That's all.

I'm looking forward to your replies as I grow more impatient by the minute

2
m0nty
Re: Admin login problem
  • 2004/8/20 16:05

  • m0nty

  • XOOPS is my life!

  • Posts: 3337

  • Since: 2003/10/24


if you'd typed admin login problem into the search bar at top right of this site it would have returned a list of topics covering this problem..

https://xoops.org/search.php?query=Adm ... &action=showall&andor=AND

i'm sure you'll find your answer and solution in 1 of those :)

3
stealth
Re: Admin login problem
  • 2004/8/20 22:23

  • stealth

  • Just popping in

  • Posts: 8

  • Since: 2004/8/20


As I said in my posting earlier, i did check the many threads regarding this issue into all their depth but none of the things suggested there did do it for me.

What I've done now:
checking cookies again... ON
checking php_ini again... register_globals = off

I even did download the source again and did a clean re-install. Still the same...

checking again the file and dir permissions... OK
trying different debug modes (php,mysql,smarty)... no errors

BTW:I'm testing on localhost, no packet filtering or firewalling on that machine.

The funny part is that it displays the message "Thank you for logging in 'username'" <- where username is my username.
It seems to recognize me but for some reason decides to redirect me to the login page again. My guess were the http headers so I've turned off ouput buffering and also zlib compression, restarted the httpd ... nothing. Same ol' sh...
Maybe something is wrong with session handling. Could a setting in my php.ini be provoking this behavior ? Honestly, I don't think I've any "fancy" settings in my php.ini. Especially not for the session module.

Well, something is off here but for the life of me I can't figure it out. Next thing I'll do is trying to provoke error msg. from some functions, just to see how far the login process goes. I don't really want to start hacking this thing before I've even been able to see what it can do.

Any better suggestions ?

4
intel352
Re: Admin login problem
  • 2004/8/22 16:23

  • intel352

  • Module Developer

  • Posts: 824

  • Since: 2003/11/23


clear your cookies, then visit the site, hopefully it recognizes you as a guest. login, see if it lets you in this time, or not.

btw, what browser are you using?

5
stealth
Re: Admin login problem
  • 2004/8/23 10:27

  • stealth

  • Just popping in

  • Posts: 8

  • Since: 2004/8/20


Cleared cookies (again). I still can't log in.
Yeah I'm sure I'm using the correct password because the system greets me with "Thank you for logging in $username" < - where $username is my user, then redirects me to the login screen again.

Browser is "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040508 Firefox/0.8"

I've found out that lynx (Textbased browser) get's me to this "Hey you're loggin in for the first time..." screen. But then I'm in this endless loop So it must have to do with Firefox somehow.

6
igzme
Re: Admin login problem
  • 2004/8/25 7:33

  • igzme

  • Just popping in

  • Posts: 1

  • Since: 2004/8/25


Had the same problem testing on a local machine. Although I haven't checked the code base, XOOPS seemts to be very dependent on cookies to manage session. Turning off cookies on the browser won't allow you administrator access in the default install. This was my first clue. You might want to check if session_use_cookies is set to 0. I adjusted this to 1 and presto, my admin user menu appeared. Hope this helps.

7
dominiclee
Re: Admin login problem
  • 2004/8/25 16:44

  • dominiclee

  • Just popping in

  • Posts: 2

  • Since: 2004/8/25


Don't know if my problem is the same as stealth's.
After I login from the 1st page, there will be another login screen on the right. After I login again on the right, there is a menu on the left including "Administration Menu".

When I click "Administration Menu", it gives screen with the message "This is your first time to enter the administration section. Press the button below to proceed." When I click <Submit>, another screen saying "Logging you in" appears for a few second and then it returns to the screen "This is your first time to enter the administration section" again. It is endless loop.

I can't find any solution yet. Someone said it is related to firewall but I tried to disable all firewall but same problem exists.

I'm now going to trace the code from what I saw on screen. I'm pleased to share with anybody with same problem after I found the solution.

8
randelld
Re: Admin login problem
  • 2004/9/6 18:49

  • randelld

  • Just popping in

  • Posts: 2

  • Since: 2004/9/6 1


Hi,
I have the exact same problem. I am nor experienced in php but am also not stupid "i think"
If you fiund out the cause of this could you p;lease let me know.

Thanks
Dean

9
randelld
Re: Admin login problem
  • 2004/9/6 18:54

  • randelld

  • Just popping in

  • Posts: 2

  • Since: 2004/9/6 1


Hi, in which file can i find session_use_cookies
I think this might be my problem.
Thanks
Dean

10
JasonMR
Re: Admin login problem
  • 2004/9/6 21:53

  • JasonMR

  • Just can't stay away

  • Posts: 655

  • Since: 2004/6/21


I've had that problem, when I hard coded URL's into a theme. I then realized, that I had a missmatch in virtual URL's.

Hope this will help, and put you on track

Login

Username:
Password:

Lost Password? Register now!

Who's Online

58 user(s) are online (33 user(s) are browsing Support Forums)


Members: 0


Guests: 58


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits