1
roele
Installing Problems!!
  • 2002/4/15 10:08

  • roele

  • Just popping in

  • Posts: 7

  • Since: 2002/3/2 1


Problems with installing Xoops!!
Is PHP not configured correctly ??? .... following Warnings apears:
Warning: Undefined variable: xoopsConfig in D:\wwwroot\rolandschaer.ch\xoops\html\class\mysql.php on line 30

Warning: Failed opening 'class/database.php' for inclusion (include_path='c:\php4\pear') in D:\wwwroot\rolandschaer.ch\xoops\html\class\mysql.php on line 30


XOOPS Installation


Warning: Use of undefined constant dbhost - assumed 'dbhost' in D:\wwwroot\rolandschaer.ch\xoops\html\install.php on line 96

Warning: Use of undefined constant dbname - assumed 'dbname' in D:\wwwroot\rolandschaer.ch\xoops\html\install.php on line 96

Warning: Use of undefined constant xoops_url - assumed 'xoops_url' in D:\wwwroot\rolandschaer.ch\xoops\html\install.php on line 96

Warning: Use of undefined constant prefix - assumed 'prefix' in D:\wwwroot\rolandschaer.ch\xoops\html\install.php on line 96

Warning: Use of undefined constant dbhost - assumed 'dbhost' in D:\wwwroot\rolandschaer.ch\xoops\html\install.php on line 96

Warning: Use of undefined constant dbuname - assumed 'dbuname' in D:\wwwroot\rolandschaer.ch\xoops\html\install.php on line 96

Warning: Use of undefined constant dbpass - assumed 'dbpass' in D:\wwwroot\rolandschaer.ch\xoops\html\install.php on line 96

Warning: Use of undefined constant dbname - assumed 'dbname' in D:\wwwroot\rolandschaer.ch\xoops\html\install.php on line 96

Warning: Use of undefined constant xoops_url - assumed 'xoops_url' in D:\wwwroot\rolandschaer.ch\xoops\html\install.php on line 96

Warning: Use of undefined constant prefix - assumed 'prefix' in D:\wwwroot\rolandschaer.ch\xoops\html\install.php on line 96

The following database was not found on the server:


2
Herko
Re: Installing Problems!!
  • 2002/4/15 11:25

  • Herko

  • XOOPS is my life!

  • Posts: 4238

  • Since: 2002/2/4 1


Did you set the correct values in your mainfile.php and include/config.inc files? See the install.txt for more info on how to set those values.

Herko

3
roele
Re: Installing Problems!!
  • 2002/4/15 11:35

  • roele

  • Just popping in

  • Posts: 7

  • Since: 2002/3/2 1


I'm sure the path in the mainfile is the right one!
But for hostname i tried different ones but it seems that XOOPS is not able to read them.
When i run checkenv.php in the extras folder the same errors occurs.
I think is the configuration of PHP on my server that is not correctly ...

4
Radio
Re: Installing Problems!!
  • 2002/4/15 13:36

  • Radio

  • Just popping in

  • Posts: 2

  • Since: 2002/4/13


Did you changed permisions for cache folders and files?
Did you chcecked dbname, host and password?

5
roele
Re: Installing Problems!!
  • 2002/4/15 13:47

  • roele

  • Just popping in

  • Posts: 7

  • Since: 2002/3/2 1


dbname and password is correct!
Hostname i'm not sure.... i installed phpmyadmin some time ago and there i set it to localhost and it runs but XOOPS wouldn't......

6
roele
Re: Installing Problems!!
  • 2002/4/17 14:09

  • roele

  • Just popping in

  • Posts: 7

  • Since: 2002/3/2 1


I got it but one Error still occurs....

Warning: Failed opening 'class/database.php' for inclusion (include_path='c:\php4\pear') in D:\wwwroot\flashadvanced.net\class\mysql.php on line 30

What that means ?

7
roele
Re: Installing Problems!!
  • 2002/4/18 9:33

  • roele

  • Just popping in

  • Posts: 7

  • Since: 2002/3/2 1


i ignored this error and continued installation the mainsite will shown up.
But when i'm in AdminPanel i can get to the sections like Modules or Users... only a blank page will shown up.
I chmod the modules folder to 755 and all underlying folders to 666.

8
Radio
Re: Installing Problems!!
  • 2002/4/19 2:10

  • Radio

  • Just popping in

  • Posts: 2

  • Since: 2002/4/13


You have something wrong with your php.ini file.

9
roele
Re: Installing Problems!!
  • 2002/4/19 6:13

  • roele

  • Just popping in

  • Posts: 7

  • Since: 2002/3/2 1


I'm new to PHP what is the best setting in the php.ini file ???
I use PHP 4.1.2..... Windows NT 4.0 Server.

<small>[ Edited by roele on 2002/4/19 10:31:00 ]</small>

10
onokazu
Re: Installing Problems!!
  • 2002/4/19 8:54

  • onokazu

  • XOOPS Founder

  • Posts: 617

  • Since: 2001/12/13


That version is the current latest version, and it's perfect.

Login

Who's Online

65 user(s) are online (37 user(s) are browsing Support Forums)


Members: 0


Guests: 65


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits