41
alfredxz
Re: "This is your first time to enter the administration section." loop - problem still unsolved
  • 2006/7/6 20:17

  • alfredxz

  • Just popping in

  • Posts: 15

  • Since: 2003/2/11


Quote:

scoobster wrote:
I've been having the same problem for the last day or so and found that the solution was to re-configure my firewall (Norton Internet Security).

I had to change the Privacy Control option to uncheck the Enable Browser Privacy Control.


This was helpful, thank you!

42
dtm
Re: "This is your first time to enter the administration section." loop
  • 2006/7/21 7:24

  • dtm

  • Just popping in

  • Posts: 5

  • Since: 2002/9/6 7


Did you guys see this FAQ for the server-side workaround?

https://xoops.org/modules/smartfaq/faq.php?faqid=310

I found it nearly instantly by simply pasting the browser message into google. ^_^

43
dtm
Re: "This is your first time to enter the administration section." loop
  • 2006/7/21 8:25

  • dtm

  • Just popping in

  • Posts: 5

  • Since: 2002/9/6 7


I find it hard to believe, but that didn't fix everything.

I applied the workaround as stated above to my brand new XOOPS 2.0.14 installation. I put it into the first line of that function, although that function is different in this XOOPS version than in the version listed. So that should have disabled HTTP_REFERER checks altogether.

It let me continue to the administration module but I can't change any settings therein until I uncheck "disable referers" in my WebDeveloper plugin for Firefox.

I'm using Firefox 1.5.0.2 on CentOS 4.3 (equivalent of Fedora Core 3) and XOOPS on FC3.

So I guess maybe that workaround is partially obsolete now that XOOPS has changed? Basic public usability demands that this setting should be fully optional at installation time, and disabled by default with a warning and a link to the FAQ! Sorry I'm not a coder or I'd do it.

44
khuhner
Re: "This is your first time to enter the administration section." loop
  • 2006/10/31 2:07

  • khuhner

  • Quite a regular

  • Posts: 232

  • Since: 2006/1/6 3


Quote:

Bender wrote:
Firewall: HTTP Referrer?

Xoops-rootpath/cache: Directory permissions still 777?


I'm now getting this problem when migrating my XOOPS_URL from an IP # to the domain name (I just finished the domain transfer).

Upon changing the XOOPS_URL variable in mainfile.php, I now get into the Admin loop. This was the only change.

Suggestions?

45
khuhner
Re: "This is your first time to enter the administration section." loop
  • 2006/11/1 1:33

  • khuhner

  • Quite a regular

  • Posts: 232

  • Since: 2006/1/6 3


I'm unable to access my Admin area....

Can someone assist me?

Regards,
Kurt


Quote:

khuhner wrote:
Quote:

Bender wrote:
Firewall: HTTP Referrer?

Xoops-rootpath/cache: Directory permissions still 777?


I'm now getting this problem when migrating my XOOPS_URL from an IP # to the domain name (I just finished the domain transfer).

Upon changing the XOOPS_URL variable in mainfile.php, I now get into the Admin loop. This was the only change.

Suggestions?

46
marluch
Re: "This is your first time to enter the administration section." loop - problem still unsolved
  • 2007/1/18 22:57

  • marluch

  • Just popping in

  • Posts: 9

  • Since: 2005/6/29


I had the same problem. Caught in the admin--submit loop. I tried different browsers, cleared the caches, etc... After viewing this info, I turned off my internet security from Zonelabs because their security is tight. Problem solved!
Thank you!!

47
Rosenheimer
Re: "This is your first time to enter the administration section." loop
  • 2007/5/10 18:10

  • Rosenheimer

  • Just popping in

  • Posts: 1

  • Since: 2007/4/30


I had the same problem and resolved it:

I used capitals in the URL that is specified in mainfile.php, so the URL comes closer to the name.

Xoops replaces that character with lowercase characters. It seems to be a security function that XOOPS checks the referrer - with then does not match.

If one of the developers reads this, may I suggest the following solutions:
a) Either just use in the links the URL as it is typed in the mainfile.
b) Or avoid that people configer uppercase characters in their URL
c) Or make the referrer check case ignoring the case.

Thank you

Tonio

48
jandrews
Re: "This is your first time to enter the administration section." loop
  • 2007/7/4 1:42

  • jandrews

  • Just popping in

  • Posts: 31

  • Since: 2005/6/5 9


My XOOPS based site has crashed.

I have tried everything to fix it and finally resorted to e installing it anew, but now I am stuck in the This is your first time to enter the administration section." loop.

There is no explanation for this, nothing has changed in regards to my computer or the server.

HEEEEEEEEEELP...please.

49
BlueStocking
Re: "This is your first time to enter the administration section." loop

In my case my server backs up my files and database on a regular basis. Have you checked your root folder to see if you have a zip backup that was created maybe without your knowledge. Mine keeps three most current backups of the MySQL also. I go to where they allow for restoring the zipped files.

Good luck
https://xoops.org/modules/repository .. It is time to get involved - XOOPS.ORG

50
jandrews
Re: "This is your first time to enter the administration section." loop
  • 2007/7/4 1:59

  • jandrews

  • Just popping in

  • Posts: 31

  • Since: 2005/6/5 9


Hi,

I have tried reinstalling everything. Old files, newer files but I am stuck in the same loop.

What I cannot figure out is why I cannot install a new installation?

If I can install, I can rebuild easily.

I do not know why this loop exists and is happening all of a sudden?

Login

Who's Online

59 user(s) are online (28 user(s) are browsing Support Forums)


Members: 0


Guests: 59


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits