11
vietnam
Re: problem in newbb after upgrade to xoops 2.3.1
  • 2008/10/29 15:43

  • vietnam

  • Just popping in

  • Posts: 59

  • Since: 2007/5/25


Quote:

voltan wrote:
We had a site that worked with XOOPS 2.2, and after we upgrade to XOOPS 2.3.1 in apparently everything works well. Then, we update the modules from admin
But after updating the module, all the data in newbb were deleted. something about 25000 posts and 900 topics. aproximately 50 mb were off the database after updating the modules. we did this upgrade process on a subdomain, and the main server software versions didn't change.
newbb 3.0.8
xoops 2.2.4 to 2.3.1
php 5.2.5
mysql 5.0.51a-community

newbb in XOOPS 2.2.4
http://www.darrenshanfans.ir/modules/newbb/index.php

newbb in XOOPS 2.3.1 ( after upgrade )
http://www.darrenshanfans.ir/up231/modules/newbb/index.php

[size=xx-large]me too[/size]
57MB ? 12MB

12
voltan
Re: problem in newbb after upgrade to xoops 2.3.1
  • 2008/10/29 17:53

  • voltan

  • Theme Designer

  • Posts: 724

  • Since: 2006/12/5


Do you think I should wait before upgrading to XOOPS 2.3.1 or I should upgrade now, and not change the module newbb?

13
Anonymous
Re: problem in newbb after upgrade to xoops 2.3.1
  • 2008/10/29 18:29

  • Anonymous

  • Posts: 0

  • Since:


Quote:
voltan wrote:

Do you think I should wait before upgrading to XOOPS 2.3.1 or I should upgrade now, and not change the module newbb?


Only you can decide that, but I upgraded to 2.3.x had had no trouble with the CBB until I refreshed the module.

I restored from a back up after refreshing the module and all is okay again.

For what it's worth, and so far as I can tell from my own site, the Forum and its blocks work fine so long as you don't refresh/update the module in modules admin.

Just take regular (and frequent!) backups until there's word from the modules devs about what to do. Would be nice to hear from them, even to say that they are looking into it......

So, from my own purely personal perspective, I think that the benefits of upgrading to 2.3.x outweigh this inconvenience. For other people, I guess that depends upon how well their other modules work.

14
Mamba
Re: problem in newbb after upgrade to xoops 2.3.1
  • 2008/10/29 19:34

  • Mamba

  • Moderator

  • Posts: 11367

  • Since: 2004/4/23


phppp is looking into it - I've exchanged some messages with him today.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

15
Anonymous
Re: problem in newbb after upgrade to xoops 2.3.1
  • 2008/10/29 19:53

  • Anonymous

  • Posts: 0

  • Since:


Quote:
Mamba wrote:

phppp is looking into it - I've exchanged some messages with him today.


Thanks mate

If you exchange more messages with him, please could you ask him if he could clarify what is the preferred Frameworks version for use with XOOPS 2.3.x? Is it the Frameworks for XOOPS 2.3+ that was released a few weeks ago or the Frameworks that comes with the XOOPS 2.3.1 download package (or are these one and the same thing?)?

Many thanks

16
vietnam
Re: problem in newbb after upgrade to xoops 2.3.1
  • 2008/10/30 14:23

  • vietnam

  • Just popping in

  • Posts: 59

  • Since: 2007/5/25


xoops 2.2.4 UTF-8 + cbb 3.08 upgrade to XOOPS 2.3
Then, we update the modules from admin. OK normal


but
if XOOPS 2.2.4 UTF-8 + cbb 3.08 upgrade to XOOPS 2.3.1
After updating, we sent a post (made a topic) in forum and again updated the module. again that post was gone!
bug ????

17
Anonymous
Re: problem in newbb after upgrade to xoops 2.3.1
  • 2008/10/30 14:29

  • Anonymous

  • Posts: 0

  • Since:


Possibly part of the same problem..... although by site isn't UTF8.

Beginning to sound more and more like an incompatibility between 2.3.x and CBB3.08.

As posted above, phppp is on the case, so I'd suggest not panicking about it. The module works okay except from when updating it. Let's see what phppp comes up with. Let's give him time to look at properly though

18
vietnam
Re: problem in newbb after upgrade to xoops 2.3.1
  • 2008/10/31 15:12

  • vietnam

  • Just popping in

  • Posts: 59

  • Since: 2007/5/25



Found?xoops 2.3.1
htdocs\class\model\sync.php
line 63 - 701

if (empty($this->handler->table_link) || empty($this->handler->field_link)) {
            
trigger_error("The linked table is not set for '" get_class($this->handler) . "' yet."E_USER_WARNING);
            return 
null;
        }
        
        if (empty(
$this->handler->field_object)) {
            
$this->handler->field_object $this->handler->field_link;
        }

[size=x-large]Change XOOPS 2.3[/size]
if (empty($this->handler->table_link) || empty($this->handler->field_link)) {
            
trigger_error("The linked table is not set yet."E_USER_WARNING);
            return 
null;
        }

[size=x-large]
OK.
why ???
I do not know
[/size]

19
vietnam
Re: problem in newbb after upgrade to xoops 2.3.1
  • 2008/11/19 9:18

  • vietnam

  • Just popping in

  • Posts: 59

  • Since: 2007/5/25


Give me a hand!

20
Anonymous
Re: problem in newbb after upgrade to xoops 2.3.1
  • 2008/11/19 9:32

  • Anonymous

  • Posts: 0

  • Since:


Quote:
vietnam wrote:

Give me a hand!


Okay everyone...... round of applause for Vietnam

Are you saying that your solution above has solved the problem or would you like folks on here to help by trying it?

I'm game for the latter - I have CBB3.08 on my test-site. Yes?

Login

Who's Online

155 user(s) are online (115 user(s) are browsing Support Forums)


Members: 0


Guests: 155


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits