11
peterr
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/4 7:39

  • peterr

  • Just can't stay away

  • Posts: 518

  • Since: 2004/8/5 9


David is still having the (same) problems.

I tried to download the file mentioned in this post , and got a "server not found" message.
NO to the Microsoft Office format as an ISO standard.
Sign the petition

12
skenow
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/4 13:34

  • skenow

  • Home away from home

  • Posts: 993

  • Since: 2004/11/17


Here is the proper link - form.php

copy all this text into a new file - form.php - and replace <xoops_root>/class/xoopsform/form.php

13
ipwgc
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/4 15:45

  • ipwgc

  • Quite a regular

  • Posts: 216

  • Since: 2005/8/13


Quote:

skenow wrote:
Here is the proper link - form.php

copy all this text into a new file - form.php - and replace <xoops_root>/class/xoopsform/form.php


Thank you Steve to try to solve this small problem, but very important for my.

The curious thing seems that I am the only one that has this problem??
Nobody has problems with the newbb 2.0.2 in English, Spanish, Portuguese and French?

Remember I check the Newbb 2.0.2
1. I erase the old form.php and change for this last "form.php"
Now another problem appeared, when I make a forum inside the administrator appears the white page with the text edit forum. before it was when I gave click in the edit clipart.

2. in another portal I try to install CBB 3.08 with Frameworks 1.10, the module doesn't appear in the install list.

Regards,
David

14
skenow
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/4 23:43

  • skenow

  • Home away from home

  • Posts: 993

  • Since: 2004/11/17


Did you also add the xoopseditors?

Latest information available - NewBB/CBB project page

15
davidl2
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/4 23:46

  • davidl2

  • XOOPS is my life!

  • Posts: 4843

  • Since: 2003/5/26


And make sure "Frameworks" starts with a capital "F" in it's directory name...

16
ipwgc
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/5 4:59

  • ipwgc

  • Quite a regular

  • Posts: 216

  • Since: 2005/8/13


Hi, skenow and davidl2

This is the progress.
I used one of my site to test the cbb 3.08 this onehttp://ipwgc.net/portugues/

1. I change the "form.php" and I insert on the folder class/xoopform/
2. I upload the module Framaworks 1.10 with a capital "F"
3. I upload /class/xoopseditors
4. I upload the forum cbb 3.08
5. Below is the error message, and the module NewBB not appear to install it.

=========================
Fatal error: Call to undefined function: mod_ismoduleaction() in /portugues/modules/newbb/xoops_version.php on line 59

All errors (3) queries (13) blocks (0) extra (0) timers (3)
=========================
Errors
Notice: Only variables should be assigned by reference in file /modules/system/admin/modulesadmin/modulesadmin.php line 46
=========================
Warning: main(/Frameworks/art/functions.ini.php) [function.main]: failed to open stream: No such file or directory in file /modules/newbb/xoops_version.php line 57
=========================
Warning: main() [function.include]: Failed opening '/Frameworks/art/functions.ini.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in file /modules/newbb/xoops_version.php line 57
=========================

I don't have another alternative that to return for the version XOOPS 2.16 until release the version XOOPS 2.1.7.1

Regards,
David

17
peterr
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/5 6:01

  • peterr

  • Just can't stay away

  • Posts: 518

  • Since: 2004/8/5 9


David,

I'm finding it difficult to understand which module is producing which error/s, and also there are now a number of portals mentioned, so I'm confused as to which one has what version of XOOPS and modules.

It would be better, to try and either get the problem fixed with the module 'newbb' or 'cbb' (not both at once), and also to keep the modifications and testing to just one portal (english ??).

So, if you can decide what you want, either newbb or CBB, that would be great, and then tell us what portal you are working on please.

Quote:

ipwgc wrote:
I don't have another alternative that to return for the version XOOPS 2.16 until release the version XOOPS 2.1.7.1


As far as I can tell, the only function that doesn't work with XOOPS 2.0.17 and newbb 2.02 is to edit a forum.

Unless you have a need to modify the forum details all the time, until this (minor) problem is fixed, simply use phpMyAdmin to modify the forum details.

I had a very quick look at /modules/newbb/admin/admin_forum_manager.php , and it only updates one table - "bb_forums".

Also, I assume this site is using XOOPS 2.0.17 and newbb 2.02, so can the webmaster of this site tell us if there is a problem editing a forum ?

Let's not throw out the baby with the bath water.
NO to the Microsoft Office format as an ISO standard.
Sign the petition

18
peterr
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/5 10:59

  • peterr

  • Just can't stay away

  • Posts: 518

  • Since: 2004/8/5 9


Prior to XOOPS 2.0.17, I assume the file /modules/newbb/admin/admin_forum_manager.php worked okay, and updated the forum details.

So, we can assume there is some code in 2.0.17 that is causing the problem. I ran Beyond compare on 2.0.16 <==> 2.0.17 and there are _many_ differences, and even started to go through admin_forum_manager.php, and try to see if anything was obvious.

.. but I got lost very quickly. :(

I would suggest to do some testing on one of the portals that is low volume and not being 'used', as such yet (the Portuguese one ??), and turn on php debugging, and then try editing a forum.

Surely there will be some output to help solve this.

HTH
NO to the Microsoft Office format as an ISO standard.
Sign the petition

19
skenow
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/5 14:16

  • skenow

  • Home away from home

  • Posts: 993

  • Since: 2004/11/17


Quote:

ipwgc wrote:

=========================
Fatal error: Call to undefined function: mod_ismoduleaction() in /portugues/modules/newbb/xoops_version.php on line 59

All errors (3) queries (13) blocks (0) extra (0) timers (3)
=========================
Errors
Notice: Only variables should be assigned by reference in file /modules/system/admin/modulesadmin/modulesadmin.php line 46
=========================
Warning: main(/Frameworks/art/functions.ini.php) [function.main]: failed to open stream: No such file or directory in file /modules/newbb/xoops_version.php line 57
=========================
Warning: main() [function.include]: Failed opening '/Frameworks/art/functions.ini.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in file /modules/newbb/xoops_version.php line 57
=========================

Regards,
David


The fatal error occurs because /Frameworks/art/functions.ini.php is not where it is expected to be - /portugues/Frameworks/art/functions.ini.php

Frameworks is not a module - it goes in your xoops_root directory.

Please confirm.

20
davidl2
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/5 15:03

  • davidl2

  • XOOPS is my life!

  • Posts: 4843

  • Since: 2003/5/26


Quote:

peterr wrote:


Also, I assume this site is using XOOPS 2.0.17 and newbb 2.02, so can the webmaster of this site tell us if there is a problem editing a forum ?


This site is currently NOT using 2.0.17 - although this will change shortly I believe.

Login

Who's Online

114 user(s) are online (49 user(s) are browsing Support Forums)


Members: 0


Guests: 114


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits