11
peterr
Re: New 2.0.15 install - activation key appended ??
  • 2006/10/2 5:24

  • peterr

  • Just can't stay away

  • Posts: 518

  • Since: 2004/8/5 9


As you can see by here , it hasn't been assigned to anyone as yet.

My memory isn't good at all, but I just checked thru some emails to the site that had the problem. The owner restored an earlier version of user.php, for some reason the user.php in version 2.0.1.15 had a few extra lines of code, that should not be there.

See the comments in the earlier posts in this thread.

HTH
NO to the Microsoft Office format as an ISO standard.
Sign the petition

12
iHackCode
Re: New 2.0.15 install - activation key appended ??

ok.. here is a solution to the redirect.

i added stuff in GREEN
if ($op == 'actv') {
    
$id intval($_GET['id']);
    
$actkey trim($_GET['actkey']);
    if (empty(
$id)) {
        
redirect_header('index.php',1,'');
        exit();
    }
    
$member_handler =& xoops_gethandler('member');
    
$thisuser =& $member_handler->getUser($id);
    if (!
is_object($thisuser)) {
        exit();
    }
    if (
$thisuser->getVar('actkey') != $actkey) {
        
redirect_header('index.php',5,_US_ACTKEYNOT);
    } else {
        if (
$thisuser->getVar('level') > ) {
            
redirect_header('user.php',5,_US_ACONTACT[color=009900],false[/color]);
        } else {
            if (
false != $member_handler->activateUser($thisuser)) {
                
$config_handler =& xoops_gethandler('config');
                
$xoopsConfigUser =& $config_handler->getConfigsByCat(XOOPS_CONF_USER);
                if (
$xoopsConfigUser['activation_type'] == 2) {
                    
$myts =& MyTextSanitizer::getInstance();
                    
$xoopsMailer =& getMailer();
                    
$xoopsMailer->useMail();
                    
$xoopsMailer->setTemplate('activated.tpl');
                    
$xoopsMailer->assign('SITENAME'$xoopsConfig['sitename']);
                    
$xoopsMailer->assign('ADMINMAIL'$xoopsConfig['adminmail']);
                    
$xoopsMailer->assign('SITEURL'XOOPS_URL."/");
                    
$xoopsMailer->setToUsers($thisuser);
                    
$xoopsMailer->setFromEmail($xoopsConfig['adminmail']);
                    
$xoopsMailer->setFromName($xoopsConfig['sitename']);
                    
$xoopsMailer->setSubject(sprintf(_US_YOURACCOUNT,$xoopsConfig['sitename']));
                    include 
'header.php';
                    if ( !
$xoopsMailer->send() ) {
                        
printf(_US_ACTVMAILNG$thisuser->getVar('uname'));
                    } else {
                        
printf(_US_ACTVMAILOK$thisuser->getVar('uname'));
                    }
                    include 
'footer.php';
                } else {
                    
redirect_header('user.php',5,_US_ACTLOGIN[color=009900],false[/color]);
                }
            } else {
                
redirect_header('index.php',5,'Activation failed!');
            }
        }
    }
    exit();
}


the first addition is for when the user.. accidentally clicks their activation link again.
the secone one is for the first time the user clicks the link. so it doesnt do the redirect looop.
CBB / LatestNews / Publisher / XM-Spotlight

(ノ◕ヮ◕)ノ*:・゚✧

13
peterr
Re: New 2.0.15 install - activation key appended ??
  • 2006/10/4 4:35

  • peterr

  • Just can't stay away

  • Posts: 518

  • Since: 2004/8/5 9


Thanks "Bandit-X", I see you have posted the solution at XOOPS Sourceforge , so hopefully it will get updated in the core.
NO to the Microsoft Office format as an ISO standard.
Sign the petition

14
Will_H
Re: New 2.0.15 install - activation key appended ??
  • 2006/10/4 4:44

  • Will_H

  • Friend of XOOPS

  • Posts: 1786

  • Since: 2004/10/10


Yes there is a relatively easy fix to this one.

Install 2.0.14 first then upgrade to 2.0.15.

There is something wrong with the 2.0.15(full) package, but none of the right people are encountering these issues.

15
cyberspace
Re: New 2.0.15 install - activation key appended ??

what's wrong with the 2.0.15(full) package?cuz I'm using that one, although I've been having alot of trouble with different modules using this version of xoops. And it's the first version/only I've used so far?is it better for me to downgrade to 2.0.14?and how do I do that?Search or use the FAQ or support forums I guess?
"Feed the children of the next generation cocaine, LSD, and XTC"

16
cyberspace
Re: New 2.0.15 install - activation key appended ??

what's wrong with the 2.0.15(full) package?cuz I'm using that one, although I've been having alot of trouble with different modules using this version of xoops. And it's the first version/only I've used so far?is it better for me to downgrade to 2.0.14?and how do I do that?Search or use the FAQ or support forums I guess?
"Feed the children of the next generation cocaine, LSD, and XTC"

17
cyberspace
Re: New 2.0.15 install - activation key appended ??

Oops I accidently clicked submit twice so it posted my entry double. I'll just edit this last one to something else.
"Feed the children of the next generation cocaine, LSD, and XTC"

18
JCDunnart
Re: New 2.0.15 install - activation key appended ??
  • 2006/10/4 11:01

  • JCDunnart

  • Not too shy to talk

  • Posts: 114

  • Since: 2006/7/1 5


XOOPS 2.0.15 has 1 confirmed bug which I think is causing some issues - an insertLine function from the form.php file, if I remember correctly (read it somewhere on this site, a search should find it)

This activation key issue seems to be common, but it's not confirmed by the core devs yet - at least, I haven't seen any posts by them about it so far. It's great that the people posting in this thread are alerting the core devs to the problem by using the bug tracker, hopefully we'll get some info about it soon.

For the problems with some modules and 2.0.15 I believe that is because those modules are bypassing the XOOPS API and directly manipulating core database tables. That's something you should take up with the module developers, nothing the core devs can do about that.

This is all info I've picked up by reading posts on this site, and following the core dev forum postings and SVN commits. For me XOOPS 2.0.15 works perfectly

19
Dalziel
Re: New 2.0.15 install - activation key appended ??
  • 2006/10/13 23:37

  • Dalziel

  • Just popping in

  • Posts: 11

  • Since: 2006/10/13


This is occurring with my new build as well of 2.0.15. I'll try the code above.

20
Dalziel
Re: New 2.0.15 install - activation key appended ??
  • 2006/10/13 23:47

  • Dalziel

  • Just popping in

  • Posts: 11

  • Since: 2006/10/13


Quote:

Dalziel wrote:
This is occurring with my new build as well of 2.0.15. I'll try the code above.

Well that small change seems to have fixed that problem - only tested once so far but had the correct message.

Login

Who's Online

79 user(s) are online (53 user(s) are browsing Support Forums)


Members: 0


Guests: 79


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jan 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits