xoops forums

JammerPro

Just popping in
Posted on: 12/9 23:56
JammerPro
JammerPro (Show more)
Just popping in
Posts: 38
Since: 2008/8/24
#1

PHP 7.0 Mods and Responsive Themes

Greetings all (and Mamba). It's nice to be back...

There's been quite a bit of development since I was last active and have a few catch up questons.

A few of my Xoops sites run nicely on PHP 7 with the latest MySQL... a few don't.

1) Is AMS News php 7.0 friendly (I don't think it is)? If it is comliant, where can I get an update? If not, I know News is compliant because I have it running on another Xoops site in php 7.0

2) Can anyone recommend English responsive themes that are php 7.0 complian? I've found a few Dutch and German beautiful themes, but I just need something in English that's simple for now...

Best wishes and holiday wishes to all!!!

JammerPro

Mamba

Moderator
Posted on: 12/10 7:06
Mamba
Mamba (Show more)
Moderator
Posts: 10779
Since: 2004/4/23
#2

Re: PHP 7.0 Mods and Responsive Themes

a) For AMS, You might test if it works for you: https://github.com/XoopsModulesArchive/ams
If you're more adventurous, you might try: https://github.com/mambax7/ams
Please note: it has not been very much tested here.

For other modules, you can check: https://github.com/XoopsModules25x/

b) The themes in XOOPS 2.5.9 (xbootstrap and xswitch) are both responsive and PHP 7 compliant.

For other themes, you can try: https://github.com/Xoopsthemes

Happy Holidays to you too!
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

JammerPro

Just popping in
Posted on: 12/10 13:21
JammerPro
JammerPro (Show more)
Just popping in
Posts: 38
Since: 2008/8/24
#3

Re: PHP 7.0 Mods and Responsive Themes

Thanks for the quick response...

I tried the new myiframe in php7 and it doesn't work yet. That one is really important.

Is there something I can do about that?

I am busy learning the Xoops interface again and might be productive in development again LOL.

I will be adventurouse with AMS and try the responsive themes you mentioned...

Thanks again!!!!!

JammerPro

Just popping in
Posted on: 12/11 23:16
JammerPro
JammerPro (Show more)
Just popping in
Posts: 38
Since: 2008/8/24
#4

Re: PHP 7.0 Mods and Responsive Themes

OK.

Here's what I've done, but still can't get the site to run under php 7.0 (Centos 6 with WHM and CPanel Multiphp manager). MySQL ver. 5.7.

I upgraded to 2.5.9, upgraded the mods as follows:

System - 2.14 | User Profile - 1.89 Final | Private Messages 1.12 Final | Protector - 3.51 Final...

However, both versions of AMS didn't install under any circumstances, whether PHP 5.6 or 7.0.

I am using the xsimpleblocks theme (nice, responsive). I do have banners turned on.

Wondering what to do next?

Any suggestions on what to use rather than AMS for an article editor? Is xsimpleblocks 7.0 friendly...

Any advice would be helpful. Would love to know that Xoops can run with just a few of the essentials in php 7.0 with MySQL 5.7.

Hope all else is well!!!

HAPPY HOLIDAYS!

JammerPro

Mamba

Moderator
Posted on: 12/12 8:20
Mamba
Mamba (Show more)
Moderator
Posts: 10779
Since: 2004/4/23
#5

Re: PHP 7.0 Mods and Responsive Themes

I would suggest to use Publisher - it's probably the most stable and also the most actively developed.
Please test Publisher and see if it works for you.

What is in AMS that you want to use it? When you say that it doesn't install, what errors are you getting, if any? And which version of AMS and myIframe do you use?
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

JammerPro

Just popping in
Posted on: 12/12 16:47
JammerPro
JammerPro (Show more)
Just popping in
Posts: 38
Since: 2008/8/24
#6

Re: PHP 7.0 Mods and Responsive Themes

I have myiframe-master.zip (I renamed to myiframe when unzipped), also, had ams-master.zip... from GitHub. Both gave me the "white screen of death" when trying to install. AMS had a red 3 in the version number... I have publisher-master and can uninstall AMS to see if that was the issue. The version I have is called publisher-master.zip from the GitHub repository...

JammerPro

Just popping in
Posted on: 12/13 3:03
JammerPro
JammerPro (Show more)
Just popping in
Posts: 38
Since: 2008/8/24
#7

Re: PHP 7.0 Mods and Responsive Themes

OK, did a fresh install of 2.5.9 with XBootstrap Theme at http://MyTrademarkSearch.com. Congrats to you. Xoops is working with the initial bare minimal install.

Can you help me a little with some initial issues putting the site back together. I will test each mod one by one and report back.

ISSUE 1 ---------------------------------------------------------------------------
First, I need to customize the XBootstrap theme which is giving me some trouble.

At themes/xbootstrap/tpl/slider.tpl starting at line 11 is the overlay text for the pictures in the slider as follows:
<div class="carousel-caption hidden-xs">
                <
h1>Lorem ipsum dolor sit amet</h1>

                <
p>Cras justo odiodapibus ac facilisis inegestas eget quamDonec id elit non mi porta gravida at eget metusNullam id dolor id
                    nibh ultricies vehicula ut id elit
.</p>

                <
p><a href="javascript:;" class="btn btn-large btn-primary"><{$smarty.const.THEME_READMORE}></a></p>
            </
div>
        </
div>
        <
div class="item"><img alt="XOOPS" src="<{$xoops_imageurl}>images/slider2.jpg">

            <
div class="carousel-caption hidden-xs">
                <
h1>Lorem ipsum dolor sit amet</h1>

                <
p>Cras justo odiodapibus ac facilisis inegestas eget quamDonec id elit non mi porta gravida at eget metusNullam id dolor id
                    nibh ultricies vehicula ut id elit
.</p>


No matter what language I insert between the H1 tags and the P tags, the overlay doesn't change!

What's up with that?

ISSUE 2 ---------------------------------------------------------------------------
Which version of publisher should I try first? Could you give me a link?

ISSUE 3 ---------------------------------------------------------------------------
Which version of myIFrame should I try first? Could you give me a link?

Let's see of I can get a totally compliant site, just using the above for now!!!

Best wishes...

Elliot

JammerPro

Just popping in
Posted on: 12/13 8:06
JammerPro
JammerPro (Show more)
Just popping in
Posts: 38
Since: 2008/8/24
#8

Re: PHP 7.0 Mods and Responsive Themes -Last Question

I was able to get publisher installed, and the overlay language is now displaying... but I have no idea why it took hours to begin to display...

Now I'm not understanding how to use the the nav-menu.tpl

<div class="navbar-collapse collapse">
                <
ul class="nav navbar-nav">
                    <
li class="active"><a href="<{$xoops_url}>"><{$smarty.const.THEME_HOME}></a></li>
                    <
li><a href="javascript:;"><{$smarty.const.THEME_MODULE1}></a></li>
                    <
li class="dropdown"><a data-toggle="dropdown" class="dropdown-toggle" href="javascript:;"><{$smarty.const.THEME_MODULE2}><class="caret"></b></a>
                        <
ul class="dropdown-menu">
                            <
li><a href="#">Topic 1</a></li>
                            <
li><a href="#">Topic 2</a></li>
                            <
li><a href="#">Topic 3</a></li>
                            <
li class="dropdown-submenu">
                                <
a href="#" class="dropdown-toggle" data-toggle="dropdown">Topic 4</a>
                                <
ul class="dropdown-menu">
                                    <
li><a href="#">Sub-Topic A</a></li>
                                    <
li><a href="#">Sub-Topic B</a></li>
                                    <
li><a href="#">Sub-Topic C</a></li>
                                    <
li><a href="#">Sub-Topic D</a></li>
                                </
ul>
                            </
li>
                            <
li><a href="#">Topic 5</a></li>
                        </
ul>
                    </
li>
                    <
li><a href="<{$xoops_url}>/modules/newbb"><{$smarty.const.THEME_MODULE3}></a></li>
                    <
li><a href="<{$xoops_url}>/modules/contact"><{$smarty.const.THEME_MODULE4}></a></li>
                </
ul>


I was able to get publisher installed, in 2.5.9...

Can't call it from the menu...

I saw Rocha's note and did the following:
Go to publisher >> Preferences
Change "Articles display type" to: -WF Section Style-

How do I use the navbar for publisher?

For example. if I wanted to show the index I would simply type in the URL like this:
http://mytrademarksearch.com/modules/publisher/


What do I do with the nav-menu command above... Let;s say we use the contact choice:


How do I code this and show Docs as the heading? This doesn;t work:


<li><a href="<{$xoops_url}>/modules/publisher"><{$smarty.const.THEME_MODULE4}</a></li>


Where am I going wrong?

Mamba

Moderator
Posted on: 12/14 4:44
Mamba
Mamba (Show more)
Moderator
Posts: 10779
Since: 2004/4/23
#9

Re: PHP 7.0 Mods and Responsive Themes -Last Question

1) Quote:
I was able to get publisher installed, and the overlay language is now displaying... but I have no idea why it took hours to begin to display...

It could be that you didn't set in Preferences the option "Check templates for modifications?" to Yes.
Then you had to wait till the cache expired.

2) The "nav-menu.tpl" file is for the top horizontal menu.
To see the Publisher there, you set it up correctly:
<li><a href="<{$xoops_url}>/modules/publisher"><{$smarty.const.THEME_MODULE4}</a></li>

Now you have to define the "THEME_MODULE4" in:
\themes\xbootstrap\language\english\main.php

3) The WF Section Style is only for the display of articles, it has nothing to do with the Menu itself

Again, make sure that you have the "Check templates for modifications?" set to "Yes".
Once you done with changing the them, you should set it to "No", so XOOPS doesn't recompile the templates every time, but instead reads it from cache.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

JammerPro

Just popping in
Posted on: 12/16 22:11
JammerPro
JammerPro (Show more)
Just popping in
Posts: 38
Since: 2008/8/24
#10

Re: PHP 7.0 Mods and Responsive Themes -Last Question

First, thanks for all the help!

I am getting back up to speed and now understand how to install and upgrade Xoops, and use the xbootstrap generated themes.

Take a look! http://CyberEntertainmentLaw.com

I got publisher working, but its acting up a little with respect to approving the new publications. They show up under published within the summary section right away, but not in the articles section.

I did manage to load myiframe, and thought it might work, but it didn't because it thought I hadn't filled out all the fields. Would love to see that mod work.

LAST, BUT MOST IMPORTANT. At the above referenced site, I was hit by some kind of mass register spam bot in the past and have over 10,000 users... Is there a MASS DELETION TOOL in 2.5.9? Couldn't find it.

I WOULD LOVE TO DELETE ALL USERS BUT ME... admin. Is there a single command or table I can drop?

I remember we discussed this years ago. It would take me quite some time to dump users 100 at a time.

Anyhow, one older Xoops site updated to php 7.0, 4 to go LOL.

All the best.

JammerPro