1
guineapig
You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 11:29

  • guineapig

  • Just popping in

  • Posts: 8

  • Since: 2004/12/13


My installation went fine and everything seems to be ok. However, when I log on as administrator and I click on the link that is supposed to take me to the page to configure groups, I get:

You don't have permission to access /modules/system/admin.php on this server.

Any ideas? Should I change some permissions? All the other administrator pages seem to work...

2
irmtfan
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 11:47

  • irmtfan

  • Module Developer

  • Posts: 3419

  • Since: 2003/12/7


do you have software firewall?
do you upload all files correctly?

3
guineapig
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 11:52

  • guineapig

  • Just popping in

  • Posts: 8

  • Since: 2004/12/13


I do have a softwarefirewall. But the problem stays, even if I disable it.

All the files are uploaded. Permissions are set as mentioned in the installation guide.

4
irmtfan
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 11:57

  • irmtfan

  • Module Developer

  • Posts: 3419

  • Since: 2003/12/7


strange problem. maybe someone else can help you.
btw what is your xoops/php/mysql version?

5
guineapig
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 12:16

  • guineapig

  • Just popping in

  • Posts: 8

  • Since: 2004/12/13


Xoops: 2.0.7.3
PHP: 4.3.9
MySQL: 4.0.22-standard-log

I should mention that I uploaded the DUTCH language pack before installing (so I could choose dutch during installation). Strange thing is that everything else works fine. It's just the groups-module.

6
JMorris
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 12:17

  • JMorris

  • XOOPS is my life!

  • Posts: 2722

  • Since: 2004/4/11


Is the error server generated or XOOPS generated?
Have you double-checked that the /cache and /modules/system directories, and /modules/system/admin.php file have the proper permissions?
What firewall are you using?
Is your XOOPS install on a remote server, or on a local server?

EDIT: Have you tried a default install?

7
guineapig
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 12:30

  • guineapig

  • Just popping in

  • Posts: 8

  • Since: 2004/12/13


Server generated.

In the installation guide it says to change the permissions on the folders upload, cache and templates_c and on the file mainfile.php. Nothing on /modules/system directories, and /modules/system/admin.php file in the installation guide... should I change permissions on this?

Firewall = ZoneAlarm. I have the same error when the firewall is disabled, btw...

Xoops is on remote server (never had problems there, used it before for Invision Board, Nucleus, etc...)

Default install? Well, yes and no... Did everything according to the instructions in the install guide, except from uploading (and installing) the Dutch language pack...

8
JMorris
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 12:40

  • JMorris

  • XOOPS is my life!

  • Posts: 2722

  • Since: 2004/4/11


The reason I asked about /modules/system/admin.php is becuause some server admins set higher default file permissions that others. It's pretty rare that a problem is caused, but it never hurts to check.

The only thing I can see here that might be the cause is the Dutch language pack, but I'm baffled as to how that could cause a problem.

My suggestion, do a clean default [without Dutch language pack] install in a subdirectory [http://yoursite.com/testdirectory/] and see if you get the same error. If you don't, then add the language pack. Test again to see if you get the same error. If you don't get the error at all, then start from scratch and reinstall XOOPS in your public directory w/o the Dutch language pack. (if you have any content, backup your database first). Then once XOOPS is installed, add the language pack.

9
guineapig
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 12:55

  • guineapig

  • Just popping in

  • Posts: 8

  • Since: 2004/12/13


Well, I did a local install with EasyPHP and without using the Dutch language pack. Everything works fine, even the groups administration. So, you're probably right, the error is probably related to the Dutch language pack... I'll do some more testing and a fresh (remote server) install without the language pack.

10
guineapig
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 15:02

  • guineapig

  • Just popping in

  • Posts: 8

  • Since: 2004/12/13


...

And that didn't work out...
Deleted all the XOOPS files on the server as well as the database and I started from scratch, this time without the Dutch languagepack.
Again, everything works, every administration link, except for the groups administration... Still the same error...

So, it wasn't the language pack...

What now?

Login

Who's Online

180 user(s) are online (128 user(s) are browsing Support Forums)


Members: 0


Guests: 180


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits