1
redentor
Problem in the Protector Module
  • 2023/2/1 5:23

  • redentor

  • Just popping in

  • Posts: 3

  • Since: 2023/2/1 4


Hi, Please help me to solve the problem of the protector module, (I have installed the version xoop 2..5.10)

Check the problem here

Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/chileoramosporti/public_html/radioredentor.cl/class/file/folder.php on line 818

Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/chileoramosporti/public_html/radioredentor.cl/class/file/folder.php on line 834

Deprecated: Function get_magic_quotes_gpc() is deprecated in /home/chileoramosporti/redentor/xoops_lib/modules/protector/class/protector.php on line 627

Deprecated: Function get_magic_quotes_gpc() is deprecated in /home/chileoramosporti/redentor/xoops_lib/modules/protector/class/protector.php on line 627

Deprecated: Function get_magic_quotes_gpc() is deprecated in /home/chileoramosporti/redentor/xoops_lib/modules/protector/class/protector.php on line 627

2
Mamba
Re: Problem in the Protector Module
  • 2023/2/1 8:33

  • Mamba

  • Moderator

  • Posts: 11366

  • Since: 2004/4/23


What PHP version are you using?

Normally you can ignore "deprecated" notices, as they are meant for developers.

Also, you should make sure that the config value of "debugLevel" in your file \xoops_data\configs\xoopsconfig.php is 2:

'debugLevel' => 2

/**
     * Debug level for XOOPS
     *
     * Displaying debug information to different level(s) of users:
     *   0 - To all users
     *   1 - To members
     *   2 - To admins only
     */
    
'debugLevel' => 2,


You might download and install the latest XOOPS 2.5.11 Beta2 code from GitHub
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

3
redentor
Re: Problem in the Protector Module
  • 2023/2/1 15:00

  • redentor

  • Just popping in

  • Posts: 3

  • Since: 2023/2/1 4


Thank you Mamba for your quick answer.
I check the xoopsconfig.php file and is correct on 'debugLevel' => 2,

The PHP hosting version in radioredentor.cl is ea-php74
Current PHP version Native (8.1) current see the image bellow
Resized Image


/**#@+
* Debug level for XOOPS
*
* Note: temporary solution only. Will be re-designed in XOOPS 3.0
*
* <ul>Displaying debug information to different level(s) of users:
* <li> 0 - To all users</li>
* <li> 1 - To members</li>
* <li> 2 - To admins only</li>
* </ul>
*/
'debugLevel' => 2,

4
redentor
Re: Problem in the Protector Module
  • 2023/2/1 17:38

  • redentor

  • Just popping in

  • Posts: 3

  • Since: 2023/2/1 4


Mamba, according to your recommendation to update to version XOOPS 2.5.11 Beta2 I did, and the problem is over.
Now I am going to update two more sites to this new version 2.5.11 and all the files in Spanish as well.
May God continue to blessing you.

5
Mamba
Re: Problem in the Protector Module
  • 2023/2/3 6:17

  • Mamba

  • Moderator

  • Posts: 11366

  • Since: 2004/4/23


I'm glad to hear that it's working now
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Login

Who's Online

97 user(s) are online (59 user(s) are browsing Support Forums)


Members: 0


Guests: 97


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Apr 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits