1
oswaldo
Errors or warnings XOOPS 2.5.11-Beta2, PHP 8.1.1
  • 1/20 20:39

  • oswaldo

  • Quite a regular

  • Posts: 212

  • Since: 2008/8/22


I have the following errors in a new installation of Xoops

Version XOOPS 2.5.11-Beta2
Version PHP 8.1.1
Version mySQL 5.7.37

ERRORS
Unknown: Function strftime() is deprecated in the file /class/smarty/Smarty_Compiler.class.php líne 395

Unknown: preg_match_all(): Passing null to parameter #2 ($subject) of type string is deprecated in the file /class/smarty/Smarty_Compiler.class.php líne 1531

Unknown: trim(): Passing null to parameter #1 ($string) of type string is deprecated in the file /class/smarty/xoops_plugins/compiler.xoAppUrl.php líne 55

Unknown: preg_match_all(): Passing null to parameter #2 ($subject) of type string is deprecated in the file /class/smarty/Smarty_Compiler.class.php líne 260

Unknown: preg_replace_callback(): Passing null to parameter #3 ($subject) of type array|string is deprecated in the file /class/smarty/Smarty_Compiler.class.php líne 265

Unknown: str_replace(): Passing null to parameter #3 ($subject) of type array|string is deprecated in the file /kernel/object.php líne 881

Unknown: Function strftime() is deprecated in the file /class/smarty/plugins/modifier.date_format.php líne 53

2
Mamba
Re: Errors or warnings XOOPS 2.5.11-Beta2, PHP 8.1.1

Yes, we're aware of the issues, and hopefully we'll be able to provide fixes for at least some of the issues.

With Smarty, it is hard to say, because we depend on their official release. I have communicated the PHP 8.1 issues to them back in July last year

https://github.com/smarty-php/smarty/issues/672

but unfortunately, they didn't release yet anything.

I would probably stick for the time being to PHP 7.4 or PHP 8.0
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

3
oswaldo
Re: Errors or warnings XOOPS 2.5.11-Beta2, PHP 8.1.1
  • 1/21 2:26

  • oswaldo

  • Quite a regular

  • Posts: 212

  • Since: 2008/8/22


I'm just testing Xoops with PHP 8.1 but I'm not using it on any website yet. Thank you Mamba for your great work.

4
Mamba
Re: Errors or warnings XOOPS 2.5.11-Beta2, PHP 8.1.1

That's awesome that you're testing XOOPS 2.5.11 Beta 2 on PHP 8.1 !!!

Please keep posting here all the issues that you find, and also please submit them to our Issues on GitHub.

We definitely appreciate it!
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

5
Mamba
Re: Errors or warnings XOOPS 2.5.11-Beta2, PHP 8.1.1

Oswaldo, I started a new branch to address some of the PHP 8.1 issues:

https://github.com/mambax7/XoopsCore25/tree/feature/PHP8.1

Please note: this is NOT an official branch, but my personal "sandbox" to play with PHP 8.1, i.e. the Core Team might take some of the fixes, but they don't have to, because they might have a better solution to address the issues. There is also always a risk that instead of fixing something, I might introduce a new bug and break some functionality.

So feel free to fork the PHP 8.1 branch, but use it only for testing and never for production!

You can check out the changelog here
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

6
oswaldo
Re: Errors or warnings XOOPS 2.5.11-Beta2, PHP 8.1.1
  • 1/23 22:58

  • oswaldo

  • Quite a regular

  • Posts: 212

  • Since: 2008/8/22


that's good friend
Thank you for your great commitment to make Xoops a great CMS and prepare it to act on the latest technologies.

7
oswaldo
Re: Errors or warnings XOOPS 2.5.11-Beta2, PHP 8.1.1
  • 1/24 5:00

  • oswaldo

  • Quite a regular

  • Posts: 212

  • Since: 2008/8/22


I still get these errors in module installer

Unknown: Function strftime() is deprecated in file /class/smarty/Smarty_Compiler.class.php line 395
Unknown: str_replace(): Passing null to parameter #3 ($subject) of type array|string is deprecated in file /kernel/object.php line 881
Unknown: preg_match_all(): Passing null to parameter #2 ($subject) of type string is deprecated in file /class/smarty/Smarty_Compiler.class.php line 1531Quote:
You can check out the changelog here

8
Mamba
Re: Errors or warnings XOOPS 2.5.11-Beta2, PHP 8.1.1

I'm afraid, you didn't download the right files

For example, the line 395 in Smarty_Compile in my code is commented out, see here:
https://github.com/mambax7/XoopsCore25 ... Smarty_Compiler.class.php

So you shouldn't get any error pointing to that line!

To download the files, you need to go to the PHP 8.1 branch, click on the green button "Code", and then download the Zip file

Or you can use this link directly: https://github.com/mambax7/XoopsCore25 ... /heads/feature/PHP8.1.zip
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

9
oswaldo
Re: Errors or warnings XOOPS 2.5.11-Beta2, PHP 8.1.1
  • 1/26 14:57

  • oswaldo

  • Quite a regular

  • Posts: 212

  • Since: 2008/8/22


Thank you MAMBA
You are right, there are no more errors.
I tested the modules:
- Countdown
- eXtGallery
- Publisher
- Tdmdownloads
- Headlines
- XOOPS Polls
- Members

In its latest version without errors In its last version without errors, I also tested the xForms module, it generates the error:
Unknown: trim(): Passing null to parameter #1 ($string) of type string is deprecated in file /class/libraries/vendor/symfony/yaml/Inline.php line 49

10
Mamba
Re: Errors or warnings XOOPS 2.5.11-Beta2, PHP 8.1.1

Most of the time, any errors or warnings coming from the /class/libraries/vendor/ folder are outside of our control, because these are 3rd Party libraries, and they would need to update them for PHP 8.1

Of course, it is good to check it out on our side if we're sending the right data to them
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Login

Username:
Password:

Lost Password? Register now!

Who's Online

67 user(s) are online (43 user(s) are browsing Support Forums)


Members: 0


Guests: 67


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits