xoops forums

liomj

Just popping in
Posted on: 8/18 1:38
liomj
liomj (Show more)
Just popping in
Posts: 58
Since: 2012/4/10
#1

Xlanguage Module - Default Language Issue

Hi, How do i set my language as Default ?

What did i miss, i setup it like this

a. add my language folder in root/language/ and also in root/modules/xxx/language also others place where language folder exists
b. change the Preferences - General Settings - Default Language
c. Install xlanguage module
d. Add base language, my local language and English language
f. Activate block language
g. try to change language using block - success

but my site default language is still English .. i need to click the flag image in the language block to change to my local language,

i've cleared my cache, use incognito and private browser mode and also use another pc..same problem

if i deactive uninstall the xlanguage module, i will see my translation

Im using
XOOPS Version XOOPS 2.5.11-Beta2
PHP Version 7.4.21
MySQL Version 5.5.5-10.4.20-MariaDB
xlanguage 3.1.2

https://github.com/XoopsModules25x/xlanguage

liomj

Just popping in
Posted on: 8/18 1:40
liomj
liomj (Show more)
Just popping in
Posts: 58
Since: 2012/4/10
#2

Re: Xlanguage Issue

i solved it temporarily by using old version of xlanguge 3.0 from an older installation...

liomj

Just popping in
Posted on: 8/18 1:54
liomj
liomj (Show more)
Just popping in
Posts: 58
Since: 2012/4/10
#3

Re: Xlanguage Issue

i made some self troubleshooting testing with xoops 2.5.11 beta and xlanguage 3.1.2 with different browsers

a. Firefox - remove english as language settings in browser
- clear cache now my translation is working as default without clicking the flag image

b. chrome - remove english language from setting
- clear cache - translation not working

im not sure if this got to do with browser language setting but if i used the old xlanguage, i dont have this problem

Mamba

Moderator
Posted on: 8/18 2:55
Mamba
Mamba (Show more)
Moderator
Posts: 11154
Since: 2004/4/23
#4

Re: Xlanguage Issue

Thanks for reporting it!

All sounds very strange, but I'll look into it and do some testing.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

alain01

Just can't stay away
Posted on: 8/18 8:08
alain01
alain01 (Show more)
Just can't stay away
Posts: 477
Since: 2003/6/20
#5

Re: Xlanguage Module - Default Language Issue

Hi Liomj

I used the 3.1.2 xlangage module on XOOPS 2.5.11 beta2 with 2 bases languages :
- main language : French ([xfr][/xfr])
- other base language : English ([xen][/xen])

I used Google Chrome and I have not your problem.
After cleaned cache, the site is on the main language, french.

Just a question :
Do you used extented languages ?
IF yes,
may be the problem is here.
SO, If yes,
please try to test with 2 bases languages, not with extension and see the result...

Just an idea...

Mamba

Moderator
Posted on: 8/18 15:00
Mamba
Mamba (Show more)
Moderator
Posts: 11154
Since: 2004/4/23
#6

Re: Xlanguage Issue

I was able to replicate the behavior. It seems like xLanguage insists on using English as the "default" language, unless you select it actively via xLanguage.

I'll look now how to make it more consistent. ..
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

alain01

Just can't stay away
Posted on: 8/18 15:05
alain01
alain01 (Show more)
Just can't stay away
Posts: 477
Since: 2003/6/20
#7

Re: Xlanguage Module - Default Language Issue

Strange,
did you create Config file ?

Tab Manage Languages, bottom ! (create config file).

In my config file :
<?php
    $cachedConfig
['xlanguage_base'] = array(
        
"english"=>array(
            
"lang_id"=>1,
            
"weight"=>20,
            
"lang_name"=>"english",
            
"lang_desc"=>"English version",
            
"lang_code"=>"xen",
            
"lang_charset"=>"UTF-8",
            
"lang_image"=>"english.gif"
        
),
        
"french"=>array(
            
"lang_id"=>2,
            
"weight"=>10,
            
"lang_name"=>"french",
            
"lang_desc"=>"Version fran├žaise",
            
"lang_code"=>"xfr",
            
"lang_charset"=>"UTF-8",
            
"lang_image"=>"french.gif"
        
),
    );
?>

Mamba

Moderator
Posted on: 8/19 6:05
Mamba
Mamba (Show more)
Moderator
Posts: 11154
Since: 2004/4/23
#8

Re: Xlanguage Issue

LiomJ,
could you test the 3.1.3 RC-1 version and let me know if it works for you?

https://github.com/mambax7/xlanguage/releases
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

liomj

Just popping in
Posted on: 8/19 8:00
liomj
liomj (Show more)
Just popping in
Posts: 58
Since: 2012/4/10
#9

Re: Xlanguage Module - Default Language Issue

Quote:

alain01 wrote:
Strange,
did you create Config file ?

Tab Manage Languages, bottom ! (create config file).

In my config file :
<?php
    $cachedConfig
['xlanguage_base'] = array(
        
"english"=>array(
            
"lang_id"=>1,
            
"weight"=>20,
            
"lang_name"=>"english",
            
"lang_desc"=>"English version",
            
"lang_code"=>"xen",
            
"lang_charset"=>"UTF-8",
            
"lang_image"=>"english.gif"
        
),
        
"french"=>array(
            
"lang_id"=>2,
            
"weight"=>10,
            
"lang_name"=>"french",
            
"lang_desc"=>"Version fran├žaise",
            
"lang_code"=>"xfr",
            
"lang_charset"=>"UTF-8",
            
"lang_image"=>"french.gif"
        
),
    );
?>


Hi alain,

I dont use any ext language and config file is created but i still have the problem

liomj

Just popping in
Posted on: 8/19 8:08
liomj
liomj (Show more)
Just popping in
Posts: 58
Since: 2012/4/10
#10

Re: Xlanguage Issue

Quote:

Mamba wrote:
LiomJ,
could you test the 3.1.3 RC-1 version and let me know if it works for you?

https://github.com/mambax7/xlanguage/releases


Mamba

It seems working the site is now in default my local translation

but now it introduces a new issue - blocks and contents are not translating it will show the tags with the translation

Resized Image

only after clicking the flag image it will translate