xoops forums

Mamba

Moderator
Posted on: 9/22 11:06
Mamba
Mamba (Show more)
Moderator
Posts: 10446
Since: 2004/4/23
#21

Re: Publisher 1.05 RC 2 for XOOPS 2.5.9 and PHP 7.1 Released for Testing

Quote:
And what about the date and time settings in the modules? They do not work.

Even if you use: "m-d-Y" ?

Please always provide details. Stating that "They do not work" is not enough to address anything.
a) what have you done
b) what was the expected result
c) what have you got?

Please read this article How to Report Bugs Effectively and these Tips and Tricks!!!
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs

aerograf

Not too shy to talk
Posted on: 9/22 13:12
aerograf
aerograf (Show more)
Not too shy to talk
Posts: 172
Since: 1/7 19:01
#22

Re: Publisher 1.05 RC 2 for XOOPS 2.5.9 and PHP 7.1 Released for Testing

Sorry, was not right.
After clearing the cache everything worked.
For all localizations, you need to make the change. In many, the date format is specified as d/m/ Y.

mydarkglobe

Just popping in
Posted on: 9/25 12:25
mydarkglobe
mydarkglobe (Show more)
Just popping in
Posts: 11
Since: 2014/11/10
#23

Re: Publisher 1.05 RC 2 for XOOPS 2.5.9 and PHP 7.1 Released for Testing

Hi, I have a new trouble (default english language, so no translation issue).
Sometimes, trying to modify an existing article, publisher, in the editing page, changes the stored date with the current one.
Futhermore, if I correct the date to the old one, the first time I republish the article I receive an "invalid token" error, but on the 2nd attempt it goes correctly.

Mamba

Moderator
Posted on: 9/27 12:00
Mamba
Mamba (Show more)
Moderator
Posts: 10446
Since: 2004/4/23
#24

Re: Publisher 1.05 RC 2 for XOOPS 2.5.9 and PHP 7.1 Released for Testing

the "invalid token" is normally when you spend too much time editing.
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs

Bleekk

Theme Designer
Posted on: 11/9 19:35
Bleekk
Bleekk (Show more)
Theme Designer
Posts: 922
Since: 2002/12/14
#25

Re: 2 problems

Quote:

2 - Publishing an article in home page using the block "Recent Articles (Details)" I get the below error:
Fatal error: Call to a member function getVar() on null in [...]htdocs/modules/publisher/class/item.php on line 1229 with only 1 article on the db. The same error for "Random Item" or other blocks.

This bug is still there. Just installed a fresh xoops with latest publisher
https://github.com/XoopsModules25x/publisher/releases

Mamba

Moderator
Posted on: 11/11 6:07
Mamba
Mamba (Show more)
Moderator
Posts: 10446
Since: 2004/4/23
#26

Re: 2 problems

Try the RC-3 that I just uploaded: https://github.com/XoopsModules25x/publisher/releases
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs

Bleekk

Theme Designer
Posted on: 11/11 15:25
Bleekk
Bleekk (Show more)
Theme Designer
Posts: 922
Since: 2002/12/14
#27

Re: 2 problems

Thank you,
this version works :)

Bleekk

Theme Designer
Posted on: 11/11 15:52
Bleekk
Bleekk (Show more)
Theme Designer
Posts: 922
Since: 2002/12/14
#28

Re: 2 problems

Can you please change one line in publisher/class/category.php
line 161
please change it to
$ret $parentObj->getCategoryPath($withAllLink) . ' <li> ' $ret '</li>';

there is a small bug if you have subcategories. the breadcrumb was not well formatted

Mamba

Moderator
Posted on: 11/12 3:10
Mamba
Mamba (Show more)
Moderator
Posts: 10446
Since: 2004/4/23
#29

Re: 2 problems

Done!

Thanks for testing!
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs