xoops forums

ginryl

Just popping in
Posted on: 1/14 23:38
ginryl
ginryl (Show more)
Just popping in
Posts: 7
Since: 1/12 17:32
#1

xoops upgrade from 2.0.18 to 2.4.5 Cant enable Registration

php5.2.17
mysql 5.0.96
apache 2.2.0

I have upgraded my old xoops and the registration will not enable . Even if I check to allow user registration, it wont display the registration forms. I have checked the database and it is changing the "allow registration" table but when I click to Register it says Registration is not allowed at this moment.

any Ideas?

Mamba

Moderator
Posted on: 1/15 9:33
Mamba
Mamba (Show more)
Moderator
Posts: 10406
Since: 2004/4/23
#2

Re: xoops upgrade from 2.0.18 to 2.4.5 Cant enable Registration

Did you run the "upgrade" (i.e. www.mysite.com/upgrade) , or only an "update" (i.e. run the System update)?

My recommendation would be to upgrade PHP to something like PHP 5.6+ and then XOOPS to 2.5.8.2, and run the "upgrade"

Of course, you would need to check on the modules, as their should be upgraded too...

Unfortunately, some of them might not work anymore on the new PHP version.
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs

ginryl

Just popping in
Posted on: 1/15 10:29
ginryl
ginryl (Show more)
Just popping in
Posts: 7
Since: 1/12 17:32
#3

Re: xoops upgrade from 2.0.18 to 2.4.5 Cant enable Registration

hi. I have updated system, profile . I have deactivated the modules, changed the theme. nothing works.
I was having trouble with my 2.0.1.8 site staying logged in after login. The site would say "you are logged in sucessfully" but would not stay logged in or show any logged in screens. End user would have to refresh and refresh and eventully some users would gain access. Some have to switch browsers. some cant access at all. This site had been working fine for 10yrs until christmas and then the problem staying logged in

so I upgraded from 2.0.18 to 2.4.5 the upgraded site had the same problem staying logged in on 2.4.5 , on a different server.

so I did a new install and everything worked good, so I started moving the xoops_users via the phpmyadmin .. added 3000 users and then went to admin and updated Profile and System.. I could not register after that, It says" Registration Not allowed come back later"

Is it possible to import the database data from 2.0.1.8 to 2.4.5?

Mamba

Moderator
Posted on: 1/17 0:31
Mamba
Mamba (Show more)
Moderator
Posts: 10406
Since: 2004/4/23
#4

Re: xoops upgrade from 2.0.18 to 2.4.5 Cant enable Registration

Quote:
Is it possible to import the database data from 2.0.1.8 to 2.4.5?

Yes, you can import module data from another module, unless there was a change in the data structure

But is there a reason why you want to stay with XOOPS 2.4.5, instead of upgrading to XOOPS 2.5.8.2?
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs

ginryl

Just popping in
Posted on: 1/18 6:34
ginryl
ginryl (Show more)
Just popping in
Posts: 7
Since: 1/12 17:32
#5

Re: xoops upgrade from 2.0.18 to 2.4.5 Cant enable Registration

Hey. I found the problem. My profile data tables were deleted during my installation process. I am not sure what deleted them, I upgraded several modules. Its running fine now.

The problem with upgrading . We have a leased server and run several sites with different app, moodle and InvisionPB and the server is on php5.2 .. There seems to be a major recompile for a linux server to upgrade to 5.5 and eventully up to php7. its been a mess to get everything past the php hump. I installed xoops 10-15yrs ago it was running 2.0.1.3a. so I have upgraded to 2.4.5 on the php5.2 thats as far as I could go. It was hard finding old 2.4.5 stuff.. everyone is on to the 2.5.8 and thats where I wanna be. We have leased another server, starting with php5.6 .. I will move the 2.4.5 xoops over and upgrade it as I get the other apps moved over and brought up to date.

Everything works fine, the modules all work, some of them dont have authors or support any longer
All the data moved fine, back and forth . its a solid app.

Is there a subscription and payment module thats available? thanks for your help !

ginryl

Just popping in
Posted on: 1/18 6:37
ginryl
ginryl (Show more)
Just popping in
Posts: 7
Since: 1/12 17:32
#6

Re: xoops upgrade from 2.0.18 to 2.4.5 Cant enable Registration

the donate button on you signature doesnt work... :o)

Cesagonchu

Moderator
Posted on: 1/19 23:36
Cesagonchu
Cesagonchu (Show more)
Moderator
Posts: 857
Since: 2010/2/1 2
#7

Re: xoops upgrade from 2.0.18 to 2.4.5 Cant enable Registration

Until the link is restored, you can use Google cache :
http://goo.gl/99o8GD