xoops forums

Mamba

Moderator
Posted on: 2015/8/17 9:52
Mamba
Mamba (Show more)
Moderator
Posts: 10838
Since: 2004/4/23
#11

Re: xfguestbook captcha not working

Quote:
I have uploaded it to GitHub. You can fork it from there to your account, make changes and submit a Pull Request back to it.

Also, you had already your branch on XOOPS SVN:
https://svn.code.sf.net/p/xoops/svn/Xo ... guestbook/branches/roby73
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Mamba

Moderator
Posted on: 2015/8/17 11:06
Mamba
Mamba (Show more)
Moderator
Posts: 10838
Since: 2004/4/23
#12

Re: xfguestbook captcha not working

Quote:
I have uploaded it to GitHub. You can fork it from there to your account, make changes and submit a Pull Request back to it.

FYI: I have done some standardization there, i.e. renamed the templates to .tpl, and moved /images to /assets, so this is consistent with other modules.

I hope, you're OK with it....
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Roby73

Friend of XOOPS
Posted on: 2015/8/18 20:24
Roby73
Roby73 (Show more)
Friend of XOOPS
Posts: 262
Since: 2011/6/15
#13

Re: xfguestbook captcha not working

Thank you mamba!
@mjoel

The captcha code can be set in core setting, you must setting it in class/captcha modify the file: config.php and config.recaptcha.php (if you want use recaptcha you can add key of google in this file).

For able security code you must able it in the admin xfguestbook module.
The secure code, work only for anonymous users (this is a problem of the core).

You can see the module working in a photography website that i'm doing:

http://circolofotografico.altervista.org/modules/xfguestbook/