xoops forums

DrMartinus

Just popping in
Posted on: 2015/4/12 19:50
DrMartinus
DrMartinus (Show more)
Just popping in
Posts: 8
Since: 2007/9/9 9
#1

upgrade to newer version from 2.3.1 - howto?

Hi,

I have Xoops working for a long time, but for an almost as long time no new members can register. I checked the version from the administration panel, there it says it's 2.3.1. Now I want to upgrade to find out if the problem is caused somehow by the old system. But I'm a bit puzzled:
There is no upgrade package from 2.3.1 to 2.3.3, which would, I guess, be the right step (to 2.3.3). So which files do I copy to the server in order not to damage existing settings, but at the same time to let the upgrade go on smoothly?

goffy

Quite a regular
Posted on: 2015/4/14 6:27
goffy
goffy (Show more)
Quite a regular
Posts: 381
Since: 2010/12/27
#2

Re: upgrade to newer version from 2.3.1 - howto?

hi

you find all upgrades under http://sourceforge.net/projects/xoops ... 0%28stable%20releases%29/

If you want to be uptodate you should use xoops 2.5.7.1

As there have been a few bigger steps in xoops from 2.3 to 2.5 I think, you could have several problems especially with older modules.

I would recommend:
- to set up a new xoops
- install then module by module (check first for newer versions of each module)
- if the complete system and all modules working proper then import the content data of your modules

of course, this is more work than updating step by step, but at the end you have a clean new system.
Additional, if more then one module is not compatible with new xoops version, it is easier to find out which one.

redheadedrod

Home away from home
Posted on: 2015/4/15 5:58
redheadedrod
redheadedrod (Show more)
Home away from home
Posts: 1296
Since: 2008/2/26
#3

Re: upgrade to newer version from 2.3.1 - howto?

There are a few ways of doing this project and all of them start out with you backing up the database and the website files.

Chances are your server changed the PHP version on you to one not compatible with 2.3.x and you are having issues with that. (In that case you will need to move to ATLEAST the last version of 2.4 but due to security issues and bug fixes you will want to move to the latest 2.5.7.1 but it will take some work to do from that old of xoops.

If you are able to start from scratch that may be the easiest solution and less time consuming for you. But assuming you have hundreds of users and lots of content you don't want to lose we can help step you through the process but in order to do so you should list your PHP version and the installed modules and their versions.

Be glad your on a xoops machine.. Unless you have something very specialized on your site the chances are you will be able to update to the latest with a bit of time spent. Which is something you are not able to do with most if any of the other major CMS's...