1
noo-b
NivoSlider & mytabs not working together
  • 2014/7/22 8:03

  • noo-b

  • Just can't stay away

  • Posts: 456

  • Since: 2007/10/23


Hi

I have integrate NivoSlider in XOOPS site using custom block

its working fine

but now i have installed the mytabs modules, i put some publisher blocks in the tabs

and i noticed mytabs (mootools) and nivoslider (jquery) is not working properly together when activated in the same page

when the nivoslider slides change from one slide-to slide user sometimes unable to click the title link of the recent publisher article block inside the tab and have to refresh the page to make it clickable..sometimes it will be ok..sometime it will be not

i search on the internet and got to know Mootools and jQuery both use $. so we can’t use both unless we save off the jQuery $ using $.noConflict.

i have this nivoslider code where i put in custom block

<script type="text/javascript">
    $(
window).load(function() {
        $(
'#slider').nivoSlider();
    });
    </
script>


i tried to change it to like this but it is not working.. slideshow is not showing
<script type="text/javascript">
 
jQuery.noConflict();
jQuery(window).load(function() {
   
jQuery('#slider').nivoSlider();
});
</
script>


anyone have a clue how to make this work together ?

-------------------------
My tabs version 2.2 (Final)
Publisher 1.02 Beta 3 (2014/6/21)
NivoSlider 3.2
XOOPS Version XOOPS 2.5.7
PHP Version 5.4.30
mySQL Version 5.5.37-cll
Server API cgi-fcgi
OS Linux

2
Bleekk
Re: NivoSlider & mytabs not working together
  • 2014/7/22 9:43

  • Bleekk

  • Theme Designer

  • Posts: 937

  • Since: 2002/12/14


xoops should support only one JS framework and this should be jquery.
I do not know how good you are in html/jquery but I would change mytabs to work with jquery

3
noo-b
Re: NivoSlider & mytabs not working together
  • 2014/7/22 23:43

  • noo-b

  • Just can't stay away

  • Posts: 456

  • Since: 2007/10/23


How i wish Trabis is here to update his module

my jquery/php knowledge is limited

what im trying now to is to change any reference to $ in nivo and mytabs script

but so far not working

4
Mamba
Re: NivoSlider & mytabs not working together
  • 2014/7/23 5:22

  • Mamba

  • Moderator

  • Posts: 11211

  • Since: 2004/4/23


Quote:
and i noticed mytabs (mootools) and nivoslider (jquery) is not working properly together when activated in the same page

Where do you see "mootools" in MyTabs?

I cannot find any reference to it...

I see only one JavaScript file there: Tab Content script v2.0 from Dynamic Drive DHTML code library (http://www.dynamicdrive.com)
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

5
noo-b
Re: NivoSlider & mytabs not working together
  • 2014/7/23 5:32

  • noo-b

  • Just can't stay away

  • Posts: 456

  • Since: 2007/10/23


Sorry My bad i got confused with mastop slideshow i used last time before changing to nivoslider

Mastop is using mootools if im not mistaken and i have uninstalled it long time ago

Still mytabs and nivoslider not working properly together..t

Still trying to figure this out

6
Mamba
Re: NivoSlider & mytabs not working together
  • 2014/7/23 5:55

  • Mamba

  • Moderator

  • Posts: 11211

  • Since: 2004/4/23


Quote:
Still mytabs and nivoslider not working properly together..t
Still trying to figure this out

If you're using Chrome, right click on the Publisher block in MyTabs and select "inspect Element" - sometimes you're getting good information about what is going on there. Firefox has also something similar.

Also, provide info on how could we replicate it. For example, I have no idea how you have implemented the NivoSlider, and there could tons of different ways to do it. Maybe it's the problem there.

There were some themes using NivoSlider. Maybe you should try them and see if MyTabs is working with these themes. If it does, then it's not MyTabs, but your implementation of NivoSlider in a block.

The biggest challenge in this kind of situations is to be aware of what exactly is expected, and see if you're getting these results, and be able to go step by step and check if you have what you expect. And be able to reproduce it on another system with another browser. Sometimes it is the browser...
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

7
noo-b
Re: NivoSlider & mytabs not working together
  • 2014/7/23 10:38

  • noo-b

  • Just can't stay away

  • Posts: 456

  • Since: 2007/10/23


thank you Mamba for the tips

finally i think i have figure this it out..it is a problem with the slide effects of the nivoslider

my current setting is random effects..i have changed it to only one single effect and right now mytabs and nivoslider is working perfectly together

still trying to figure out which slide effect that cause the problem with the tabs

8
Mamba
Re: NivoSlider & mytabs not working together
  • 2014/7/23 12:09

  • Mamba

  • Moderator

  • Posts: 11211

  • Since: 2004/4/23


I am glad to hear that things start finally to work for you!

Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Login

Username:
Password:

Lost Password? Register now!

Who's Online

63 user(s) are online (36 user(s) are browsing Support Forums)


Members: 0


Guests: 63


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits