1
ipwgc
All days are recorded as spam users on my site.
  • 2014/4/2 18:39

  • ipwgc

  • Quite a regular

  • Posts: 216

  • Since: 2005/8/13


Hi,
All days are recorded as spam users on my site.
I run several website with xoops system.
Plese give me the solution to this problem.
This is one of the siteshttp://www.coniev.com/

Example:
I upgrade the site from 2.5.5 to 2.5.6
I upgrade the xoops_2.5.6_SecurityPatch_htdocs
What thing I gave do to in order stop spam to become registered users of the site?

Regards, DAVID

Resized Image

2
Mamba
Re: All days are recorded as spam users on my site.
  • 2014/4/2 22:16

  • Mamba

  • Moderator

  • Posts: 11335

  • Since: 2004/4/23


Unfortunately, there will be always spammers who will try to register

See this thread:
https://xoops.org/modules/newbb/viewtopic.php?post_id=353391#forumpost353391

1) set up the Profile correctly, with saving after 2nd step
2) set up the text captcha with text option, so it ask a math question
3) activate Protector for the spam on Forums, and set it "ban" there (important)
4) from time to time change the mandatory fields
5) update to 2.5.7 RC from SVN

That's all what we do here, and we have very few spammers actually.

But the focus is actually to make sure that they don't post spamming messages on the Forums. If few of them register, I am not losing sleep over that
Most of them register, but never connect, anyway....
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

3
alain01
Re: All days are recorded as spam users on my site.
  • 2014/4/3 7:38

  • alain01

  • Just can't stay away

  • Posts: 523

  • Since: 2003/6/20


Quote:

Mamba wrote:
4) from time to time change the mandatory fields

Means change name of fields ?
Not sure to understand...

4
Mamba
Re: All days are recorded as spam users on my site.
  • 2014/4/3 10:16

  • Mamba

  • Moderator

  • Posts: 11335

  • Since: 2004/4/23


Quote:
Means change name of fields ?
Not sure to understand...

Just to change which fields are mandatory. You can make it one time "location", and the next time "interests". This is in case the spammers have a bot which figured out what you have as a mandatory field. Of course, if the spammer is a real person, this won't matter.

But I think, we might need to develop a local language captcha, which was suggested by Irmtfan, where the "math" question will be in your local language. If you Website is not international and you're looking only for people speaking your language, this might prevent some people from the spamming countries to register, because in order to pass the Captcha, they would have to understand the question first, and if the question is in French, that would be more difficult for them.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

5
alain01
Re: All days are recorded as spam users on my site.
  • 2014/4/3 10:36

  • alain01

  • Just can't stay away

  • Posts: 523

  • Since: 2003/6/20


Sure,
like this french question :
"Quelle est le sommet le plus connu des Alpes Fran├žaises" :

Mont-Blanc

lile : "Which is the famous mountain name (and higher) in the French Alpes" ?

This will be great to use this suggestion from Irmtfan.

6
ipwgc
Re: All days are recorded as spam users on my site.
  • 2014/4/5 3:34

  • ipwgc

  • Quite a regular

  • Posts: 216

  • Since: 2005/8/13


Hi, Mamba,
I not post the report immediately because I wanted to see if it really Works.
Well, I follow all your instructions and there are no more spam register, on the site.

NOTE: The only step that I understood very well is this.
2) set up the text captcha with text option, so it ask a math question.

QUESTION: Where I have to do this, in which administrator section?

I Update to version 2.5.7 and is working fine without the spam.

A big Hug.
David

7
Mamba
Re: All days are recorded as spam users on my site.
  • 2014/4/5 4:41

  • Mamba

  • Moderator

  • Posts: 11335

  • Since: 2004/4/23


I am glad to hear that things are better

Quote:
2) set up the text captcha with text option, so it ask a math question.
QUESTION: Where I have to do this, in which administrator section?

It's here:

/class/captcha/config.php

make sure that the text is selected like here:

'mode' => 'text',  // default mode, you can choose 'text', 'image', 'recaptcha'(requires api key)
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Login

Who's Online

184 user(s) are online (62 user(s) are browsing Support Forums)


Members: 0


Guests: 184


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits