xoops forums

Mamba

Moderator
Posted on: 2014/1/10 15:06
Mamba
Mamba (Show more)
Moderator
Posts: 10993
Since: 2004/4/23
#11

Re: System broke down???

Quote:
Well if you say so, but i have 3 other site running with php 5.2.17 and no problems there...

We have issued a Security Patch for XOOPS 2.5.6, which requires PHP 5.3.7.
So if your other sites are still working on PHP 5.2.17, they must have not been updated yet (and they should ASAP).

Please note: Using PHP 5.2.17 is like using Windows 95 or Windows XP. There are simply outdated, and with security holes.

Even PHP 5.3 is pretty much outdated, since it is not developed anymore.

We recommend to use PHP 5.4.x, with the PHP 5.3.7 as the minimum.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

ORbit2

Just popping in
Posted on: 2014/1/11 5:20
ORbit2
ORbit2 (Show more)
Just popping in
Posts: 36
Since: 2008/5/12
#12

Re: System broke down???

What the problem was i don't know, my host has put back a backup and now al is working again.

Where can I see if that security update is made? The overview says xoops version 2.5.6

ORbit2

Just popping in
Posted on: 2014/1/12 7:59
ORbit2
ORbit2 (Show more)
Just popping in
Posts: 36
Since: 2008/5/12
#13

Re: System broke down???

My site is being moved to another server with php 5.4 so I can update.

Hopefully I loose this stupid problem because it is still there.



ORbit2

Just popping in
Posted on: 2014/1/12 13:56
ORbit2
ORbit2 (Show more)
Just popping in
Posts: 36
Since: 2008/5/12
#14

Re: System broke down???

my is site(s) have been moved but isn't functioning any more

this is the error I recieve:

Quote:
Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method ProtectorCorePreload::eventCoreIncludeCommonStart() should not be called statically in /www/htdocs/mansolei/class/preload.php on line 140

Strict Standards: Non-static method Protector::getInstance() should not be called statically in /www/htdocs/mansolei/puntje_lib/modules/protector/include/precheck_functions.php on line 12


what can I do ? I don't really want to reinstall 4 new sites!!

Mamba

Moderator
Posted on: 2014/1/12 14:48
Mamba
Mamba (Show more)
Moderator
Posts: 10993
Since: 2004/4/23
#15

Re: System broke down???

Quote:
what can I do ? I don't really want to reinstall 4 new sites!!

Don't reinstall. Just upgrade to XOOPS 2.5.6. If you already have XOOPS 2.5.6 that you have installed before September 2013, please install the Security Patch

My guess is that you have forgotten to copy files from /xoops_lib to your folder:

/www/htdocs/mansolei/puntje_lib/
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

ORbit2

Just popping in
Posted on: 2014/1/12 15:20
ORbit2
ORbit2 (Show more)
Just popping in
Posts: 36
Since: 2008/5/12
#16

Re: System broke down???

Thanks Mamba, I'm going to upgrade.

ORbit2

Just popping in
Posted on: 2014/1/12 16:17
ORbit2
ORbit2 (Show more)
Just popping in
Posts: 36
Since: 2008/5/12
#17

Re: System broke down???

Well I have done the security patch but still I get this error

Quote:
Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method ProtectorCorePreload::eventCoreIncludeCommonStart() should not be called statically in /www/htdocs/mansolei/class/preload.php on line 140

Strict Standards: Non-static method Protector::getInstance() should not be called statically in /www/htdocs/mansolei/puntje_lib/modules/protector/include/precheck_functions.php on line 12

Mamba

Moderator
Posted on: 2014/1/12 17:42
Mamba
Mamba (Show more)
Moderator
Posts: 10993
Since: 2004/4/23
#18

Re: System broke down???

But did you copy the files from the XOOPS 2.5.6 /xoops_lib to your folder:

/www/htdocs/mansolei/puntje_lib/

It seems like these files are outdated.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs