51
cerbero
Re: Extgallery nightmares...
  • 2013/11/12 16:13

  • cerbero

  • Not too shy to talk

  • Posts: 191

  • Since: 2003/9/11


dear bleekk, i'm very sorry for my poor english, this is not the way i was looking for, my intention is to show every category in a cell of the table, represented by a thumb, not many thumbs for each category, with X rows and X columns, you can see the example

http://www.elfisgon.com/images/aaabrb.jpg

52
Bleekk
Re: Extgallery nightmares...
  • 2013/11/12 18:27

  • Bleekk

  • Theme Designer

  • Posts: 940

  • Since: 2002/12/14


aaaaah ok, nothing easier then this.
how many columns do you want?

53
Bleekk
Re: Extgallery nightmares...
  • 2013/11/12 21:24

  • Bleekk

  • Theme Designer

  • Posts: 940

  • Since: 2002/12/14


HERE IS the modified gallery index template
I have created 5 columns
To change the column number edit the line 55

It is up to you to do the style to the columns

54
cerbero
Re: Extgallery nightmares...
  • 2013/11/14 16:13

  • cerbero

  • Not too shy to talk

  • Posts: 191

  • Since: 2003/9/11


That's the right way, many thanks bleekk, it works like a charm

55
hipoonios
Re: Extgallery nightmares...
  • 2014/2/16 9:07

  • hipoonios

  • Friend of XOOPS

  • Posts: 298

  • Since: 2005/9/24


There is a problem with the "download original" feature. It doesn't work with low resolution pictures.

Try upload a 640x480 picture and download it. You will get the same picture that is used online.

Another guy reported a similar problem in 2010 here. Unfortunately his fix did not work.

This is not a permission thing. I think it's a bug in the public-download.php file.

56
Mamba
Re: Extgallery nightmares...
  • 2014/2/16 12:33

  • Mamba

  • Moderator

  • Posts: 11254

  • Since: 2004/4/23


Quote:
Try upload a 640x480 picture and download it. You will get the same picture that is used online.

Works here just fine.

You probably didn't set in Preferences:

"Save original photo" to "Yes"

Just check if you have the correct sizes in the folders:

\uploads\extgallery\public-photo\original
\uploads\extgallery\public-photo\large
\uploads\extgallery\public-photo\medium
\uploads\extgallery\public-photo\thumb
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

57
hipoonios
Re: Extgallery nightmares...
  • 2014/2/16 13:22

  • hipoonios

  • Friend of XOOPS

  • Posts: 298

  • Since: 2005/9/24


Thanks for testing Mamba.

The directories and "save original" is checked in preferences. So that's not the problem.

I forgot to mention that the image resolution must be smaller than set in preferences.

I see now the default is 600px. So forget what i first said about 640px. Upload a picture image smaller than the size your have set in preferences.
You should not be able to download the original file (compare the file size and see for yourself).

I see the original file is saved on the server. But still the medium image (that file is used when viewing images online) will be downloaded when you click "download original".

Resized Image

58
Mamba
Re: Extgallery nightmares...
  • 2014/2/17 1:32

  • Mamba

  • Moderator

  • Posts: 11254

  • Since: 2004/4/23


Quote:
I forgot to mention that the image resolution must be smaller than set in preferences.

I was able to reproduce it, so I'll look into it this week...
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

59
Mamba
Re: Extgallery nightmares...
  • 2014/2/17 12:12

  • Mamba

  • Moderator

  • Posts: 11254

  • Since: 2004/4/23


Quote:
I see the original file is saved on the server. But still the medium image (that file is used when viewing images online) will be downloaded when you click "download original".

1) I've tested Tom's solution and it seems to be working just fine, so I'll include it in the next update.

2) The issue what you have, is probably because you might not set the Permissions correctly.

There are two relevant permissions:

Can download pictures (needed to see the link to download)
Can download original pictures (needed for download of the original picture)

If you set only the first, user will have the download link visible, but be able to download only the "medium" picture. To download the original, the user needs both permissions set.

The bug was that if you uploaded a smaller picture than the default, it didn't set in the database the flag for "photo_havelarge".

Unfortunately, the original download routine was testing for this flag, and if the picture didn't have it, you would always get only the "medium" picture, even if you had permission to download original picture.

Tom's suggested fix solves the issue, i.e.:

a) if you have permission to original picture download, you'll get it, regardless of the size
b) if you don't have the permission, extGallery will check for the flag "photo_havelarge" and if set, it will get you the "large" picture, and if not, you'll get the "medium" picture.

So go ahead, use Tom's fix, set both the permissions, and then upload a small picture and see if it works.

And I'll commit the fix to SVN
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

60
hipoonios
Re: Extgallery nightmares...
  • 2014/2/19 19:03

  • hipoonios

  • Friend of XOOPS

  • Posts: 298

  • Since: 2005/9/24


Thanks, now it's working!! I didn't have the correct permissions when I first tried Tom's solution.

Another question:

What is the "large" image folder used for? It's make no sense to have that folder. The file that gets stored there is not the original. Just a bigger file than the original with worse quality. So it's not used for anything what I can see.

Also the system displays the file size of this large file instead of the original. But I don't care about that. Just want to mention it since it can be another bug.

Login

Who's Online

63 user(s) are online (34 user(s) are browsing Support Forums)


Members: 0


Guests: 63


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits