1
Anonymous
Extgallery 1.1 upload problem
  • 2012/3/21 23:26

  • Anonymous

  • Posts: 0

  • Since:


Xoops version has had some updates and after updating to xoops 2.5.2 uploading pictures in extgallery stopped working. Uploading pictures in standard mode results in a white screen, in extended javascript mode there is a simple warning telling something has gone wrong.

Today I upgraded the site to xoops 2.5.4 and Extgallery to version 1.1 (most recent build on sourceforge) but nothing has changed, uploading is not possible...

Debug does not show any error, does anybody have a clue?

2
redheadedrod
Re: Extgallery 1.1 upload problem

This should be working without issue...

Recently there was a problem with the Java upload (NOT javascript) but the fix was to download the latest version of that script and it worked fine. I believe this was an issue for a while.

I have had extgallery working with 2.5.4 without issue myself and I believe it might even be in the basic module pack.

It is likely something in your system is not setup right or you are missing something.

There was a thread recently about this.. (2-3 months ago)



Rodney
Attending College working towards Bachelors in Software Engineering and Network Security.

3
Anonymous
Re: Extgallery 1.1 upload problem
  • 2012/3/22 9:33

  • Anonymous

  • Posts: 0

  • Since:


Thanks for your reply Rodney. I have solved the problem now, it was Imagemagick not working (or not present). I changed settings to GD and upload is working again. My hoster migrated sites to another server some months ago, I guess graphic library setup was changed...

4
terrion
Re: Extgallery 1.1 upload problem
  • 2012/3/31 12:50

  • terrion

  • Friend of XOOPS

  • Posts: 299

  • Since: 2004/9/19


I've just confirmed what the previous poster was observing. It seems there's a bug in the java upload policy that when using ImageMagick 6 binaries option in extgallery you get an error when using the java up-loader on the front end.

The batch up-loader in the control panel works fine, so it's definitely as issue with the java up-loader in combination with Imagemagick. The GD option seems to work fine.

Terrion
Purchase, renew, or transfer your domain name to Ultranet Domains and get a FREE 10GB hosting account. Virtual Dedicated Servers around $35/monthly, no contract. FREE 24/7 telephone ...

5
Anonymous
Re: Extgallery 1.1 upload problem
  • 2012/3/31 14:26

  • Anonymous

  • Posts: 0

  • Since:


There is also this thread about the java upload issue. I guess it is not a typical Imagemagick issue as I am having the same problem with GD.

6
terrion
Re: Extgallery 1.1 upload problem
  • 2012/3/31 14:32

  • terrion

  • Friend of XOOPS

  • Posts: 299

  • Since: 2004/9/19


One thing to check, my host has GD version 5 binaries in /usr/bin while the GD version 6 binaries are in /usr/local/bin

If you're still having trouble you might have to hunt a little to find the right version of GD's convert utility.

Hope this helps,
Terrion
Purchase, renew, or transfer your domain name to Ultranet Domains and get a FREE 10GB hosting account. Virtual Dedicated Servers around $35/monthly, no contract. FREE 24/7 telephone ...

7
Anonymous
Re: Extgallery 1.1 upload problem
  • 2012/3/31 14:45

  • Anonymous

  • Posts: 0

  • Since:


I use the upload function to let visitors upload pictures to a public album, the normal upload option works fine now so I am happy. The java upload looks nice but gives to many problems, also related to older java versions and so on...

When filling albums with more pictures I always use the batch option

8
terrion
Re: Extgallery 1.1 upload problem
  • 2012/3/31 14:54

  • terrion

  • Friend of XOOPS

  • Posts: 299

  • Since: 2004/9/19


I agree. Even when it works right it's painfully slow. Better to just ftp up your images and use the batch add.
Terrion
Purchase, renew, or transfer your domain name to Ultranet Domains and get a FREE 10GB hosting account. Virtual Dedicated Servers around $35/monthly, no contract. FREE 24/7 telephone ...

9
redheadedrod
Re: Extgallery 1.1 upload problem

The original author of this program is working on an upgrade so if the Java upload does not work for you, then you might be better off waiting until the new version comes out.

You can also likely go to the site of the author for the java plugin and discuss the issues there. The link was in the other thread that discusses this.
Attending College working towards Bachelors in Software Engineering and Network Security.

10
AmyMarie
Re: Extgallery 1.1 upload problem
  • 2012/5/29 12:40

  • AmyMarie

  • Just popping in

  • Posts: 49

  • Since: 2008/9/3 1


Hello all.
I am using Xoops-2.5.5 and I am trying to install a photo gallery. I have tried a few.
I have Extgallery install with no problems but when I upload a photo it does not show up. Any Ideas? I am using a freeBSD server, apache 2.2 if that helps any.
thank you,
Amy

Login

Username:
Password:

Lost Password? Register now!

Who's Online

73 user(s) are online (46 user(s) are browsing Support Forums)


Members: 0


Guests: 73


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits