xoops forums

chefry

Home away from home
Posted on: 2011/7/2 19:30
chefry
chefry (Show more)
Home away from home
Posts: 1005
Since: 2006/10/14
#1

Tables not created

I'm trying to set up a testbed, using xoops 2.4.4 and wamp server as a localhost.

I created the database and set the user privileges, etc

But when I get to the "Table Creating" section of the install wizard I have problems

I get the message (in green) XOOPS system tables have been created. Press next to go to the next step.

But Under it I get (in red)
Unable to create table xf2f_avatar
Unable to create table xf2f_avatar_user_link
Unable to create table xf2f_banner
Unable to create table xf2f_bannerclient
Unable to create table xf2f_bannerfinish
Unable to create table xf2f_block_module_link
Unable to create table xf2f_xoopscomments
Unable to create table xf2f_xoopsnotifications
Unable to create table xf2f_config
Unable to create table xf2f_configcategory
Unable to create table xf2f_configoption
Unable to create table xf2f_groups
Unable to create table xf2f_group_permission
Unable to create table xf2f_groups_users_link
Unable to create table xf2f_image
Unable to create table xf2f_imagebody
Unable to create table xf2f_imagecategory
Unable to create table xf2f_imgset
Unable to create table xf2f_imgset_tplset_link
Unable to create table xf2f_imgsetimg
Unable to create table xf2f_modules
Unable to create table xf2f_newblocks
Unable to create table xf2f_online
Unable to create table xf2f_priv_msgs
Unable to create table xf2f_ranks
Unable to create table xf2f_session
Unable to create table xf2f_smiles
Unable to create table xf2f_tplset
Unable to create table xf2f_tplfile
Unable to create table xf2f_tplsource
Unable to create table xf2f_users
Unable to create table xf2f_cache_model

And when I check the table in phpmyadmin, there are no table created.

Clicking "NEXT" send me to "Initial Settings"
Clicking on "Next" again takes me back to "Database Configuration"

I'm using the latest wamp v2.1
apache 2.2.17
php 5.3.5
mysql 5.5.8

webmystar

Friend of XOOPS
Posted on: 2011/7/3 19:55
webmystar
webmystar (Show more)
Friend of XOOPS
Posts: 415
Since: 2008/6/23
#2

Re: Tables not created

i think you have an permission problem. check the privileges of your database user.

chefry

Home away from home
Posted on: 2011/7/3 20:13
chefry
chefry (Show more)
Home away from home
Posts: 1005
Since: 2006/10/14
#3

Re: Tables not created

i set up a user with all priveledges

chefry

Home away from home
Posted on: 2011/7/5 8:31
chefry
chefry (Show more)
Home away from home
Posts: 1005
Since: 2006/10/14
#4

Re: Tables not created

bump!

deepak267

Quite a regular
Posted on: 2011/7/5 8:51
deepak267
deepak267 (Show more)
Quite a regular
Posts: 352
Since: 2008/8/15
#5

Re: Tables not created

Chefry,

To me it looks like user previlage issue. try the follwoing test.

use the same database user credential and try to run the SQL script or atleast one SQL statement.

Check if the user has the previlage to execute the Create table statements. if you are not able to execute with your user, run the script with root user.


Good Luck,

Deepak

Mamba

Moderator
Posted on: 2011/7/5 8:53
Mamba
Mamba (Show more)
Moderator
Posts: 10770
Since: 2004/4/23
#6

Re: Tables not created

I never had problems with WAMP, unless:

- the database setup was wrong
- the user permissions were wrong
- the tables already existed

Try to create it with the Admin or Root login/password and see if you can install it. If you do, then your "user" privileges are wrong.

Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

iHackCode

Module Developer
Posted on: 2011/7/5 12:05
iHackCode
iHackCode (Show more)
Module Developer
Posts: 1036
Since: 2004/6/29
#7

Re: Tables not created

the installer isn't compatible with that version of mysql, try XOOPS 2.5
CBB / LatestNews / Publisher / XM-Spotlight

(ノ◕ヮ◕)ノ*:・゚✧

chefry

Home away from home
Posted on: 2011/7/5 12:56
chefry
chefry (Show more)
Home away from home
Posts: 1005
Since: 2006/10/14
#8

Re: Tables not created

reducing MySQL to 5.0.88 did the trick
Thanks :)

deepak267

Quite a regular
Posted on: 2011/7/5 15:48
deepak267
deepak267 (Show more)
Quite a regular
Posts: 352
Since: 2008/8/15
#9

Re: Tables not created

Good to know that you could resolve this issue.

What was the previosu version of MySQL?

Deepak

Mamba

Moderator
Posted on: 2011/7/5 16:45
Mamba
Mamba (Show more)
Moderator
Posts: 10770
Since: 2004/4/23
#10

Re: Tables not created

He had mysql 5.5.8

Kudos to iHackCode for finding the solution.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs