21
trabis
Re: Banners
  • 2009/11/6 19:54

  • trabis

  • Core Developer

  • Posts: 2269

  • Since: 2006/9/1 1


Fixed on SVN by removing rel="external" from banners code. Anyway, as far as I know banners were always opening in same page on 2.3 so this will not make a difference.

22
ajgour
Re: Banners
  • 2009/11/16 19:41

  • ajgour

  • Just popping in

  • Posts: 19

  • Since: 2009/11/16


Hmm, I have the same problem on my site:http://pikaiprijatelji.com/site/banners.php?op=click&bid=9

I was add 0 in line 310 but nothing happens!

Interesting, when I have XOOPS 2.40 banners was worked in Firefox, but not in IE and logically Chrome. When I made upgrade to XOOPS 2.41 banners was stop working.

Any other solutions?

23
kris_fr
Re: Banners
  • 2009/11/16 22:24

  • kris_fr

  • Theme Designer

  • Posts: 1009

  • Since: 2005/12/31



24
ajgour
Re: Banners
  • 2009/11/17 13:14

  • ajgour

  • Just popping in

  • Posts: 19

  • Since: 2009/11/16


I was replace those 4 files but I still have the same problem! I receive a blak page after cliking on banner. But this time in new tab or window...http://pikaiprijatelji.com/site/banners.php?op=click&bid=9

25
trabis
Re: Banners
  • 2009/11/17 13:33

  • trabis

  • Core Developer

  • Posts: 2269

  • Since: 2006/9/1 1


Please replace include/xoops.js with the one from 2.3 and see if it works ok.

26
ajgour
Re: Banners
  • 2009/11/17 14:03

  • ajgour

  • Just popping in

  • Posts: 19

  • Since: 2009/11/16


1. I was replace thishttp://xoops.svn.sourceforge.net/viewvc/xoops?view=rev&revision=3895

2. I was replace xoops.js with xoops.js from XOOPS 2.3.3b

3. I was update System

Still the same problem. New blank page.

27
trabis
Re: Banners
  • 2009/11/17 14:12

  • trabis

  • Core Developer

  • Posts: 2269

  • Since: 2006/9/1 1


Maybe now you need to refresh browser cache. So it uses new js.

28
ajgour
Re: Banners
  • 2009/11/17 14:30

  • ajgour

  • Just popping in

  • Posts: 19

  • Since: 2009/11/16


Hmm, I was refresh browser cashe, but still not working! Uff, it's so frustrating to me! ;)

What with this?:

Open banners.php, line 310 and add a '0'

if ($GLOBALS['xoopsSecurity']->checkReferer(0)) {

I have 0 in this file.

Please, go tohttp://pikaiprijatelji.com/ and try to click banner on the top of site (left)..

29
Ganga
Re: Banners
  • 2009/11/26 12:04

  • Ganga

  • Just popping in

  • Posts: 24

  • Since: 2007/10/22


This problem is in the language(Croatian), yet I have not found where ...
if you switch the language to English it works banners.


I also had this error. But if you turn on the DEBUG, you can see it immediately!

ajgour:
Probaj molimte prebacit na engleski pami reci dali onda ide reklamna poruka...Pozdrav

30
Ganga
Re: Banners
  • 2009/11/26 18:09

  • Ganga

  • Just popping in

  • Posts: 24

  • Since: 2007/10/22


I found a mistake in any language is a mistake and in xoops_root \ language \ Croatian \ banners.php and xoops_root \ language \ english \ banners.php line 52 + 53 english: Change OLD:
define('_BANNERS_SEND_STATS''Send <a href='%s' title='E-mail Stats'/>E-mail Stats</a> for this Banner');
define('_BANNERS_POINTS','This Banner points to <a href='%s' title=''>this URL</a>');
TO NEW:
define('_BANNERS_SEND_STATS',"Send <a href='%s' title='E-mail Stats'/>E-mail Stats</a> for this Banner");
define('_BANNERS_POINTS',"This Banner points to <a href='%s' title=''>this URL</a>");
croatian:http://xoopshr.org/modules/newbb/viewtopic.php?topic_id=154&post_id=876#forumpost876 A big thank you feichtl with myxoops German

Login

Who's Online

118 user(s) are online (94 user(s) are browsing Support Forums)


Members: 0


Guests: 118


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Apr 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits