xoops forums

tvn3015

Just popping in
Posted on: 2008/9/11 4:57
tvn3015
tvn3015 (Show more)
Just popping in
Posts: 53
Since: 2007/4/18
#1

Xoops 2.3 RC2 Strange Things Happened to my Administration > System > Groups

It was working great and suddenly today when I logged in and access the administration Menu, System, Groups. All the form fields and textbox used to create or edit groups is all gone. All I can see right now are the three groups webmasters, Registered Users and Anonymous Users. The form to create new group somehow disappeared. Could someone please let me know what happened and how to fix this. Thanks.

I am running on XOOPS 2.3 rc2
MySQL Version 5.0.45
PHP 5.2.2
http://www.XoopsViet.com - Xoops for Vietnamese

tvn3015

Just popping in
Posted on: 2008/9/11 7:03
tvn3015
tvn3015 (Show more)
Just popping in
Posts: 53
Since: 2007/4/18
#2

Re: Xoops 2.3 RC2 Strange Things Happened to my Administration > System > Groups

Turn on the debug mode and got the following error

Quote:
Fatal error: Call to a member function getVar() on a non-object in /xxx/xxx/xxxxxx/xxx/xxx/xxx/modules/system/admin/groups/groupform.php on line 76

All errors (1) queries (11) blocks (0) extra (0) timers (3)
Errors
Notice: Undefined variable: block in file /modules/system/admin/groups/groupform.php line 76
http://www.XoopsViet.com - Xoops for Vietnamese

trabis

Core Developer
Posted on: 2008/9/11 8:46
trabis
trabis (Show more)
Core Developer
Posts: 2268
Since: 2006/9/1 1
#3

Re: Xoops 2.3 RC2 Strange Things Happened to my Administration > System > Groups

The fix is covered here:

https://xoops.org/modules/newbb/viewto ... =ASC&type=&mode=0&start=0