1
ipwgc
Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/1 15:29

  • ipwgc

  • Quite a regular

  • Posts: 216

  • Since: 2005/8/13


Hello, I upgrade from XOOPS 2.0.16. to XOOPS 2.0.17. version.

My problem is with the Newbb forum. I have installed the version "NewBB 2.0"
I'm used this newbb 2.0 version in my 5 portals in different languages english, spanish, French, Portuguese see here
http://www.ipwgc.com/english/modules/newbb/index.php

::THE FORUM NEWBB 2.0 PROBLEMS::
Everything works well with the forums version NewBB 2.0.
1. The only problem is when I want to edit the forum.
2. The edit pages appears in white.

To check if was the compatibility with XOOPS 2.0.17 versions, I installed the forum CBB 3.0 version I download from herehttp://dev.xoops.org/modules/xfmod/project/?newbb

::THE FORUM CBB 3.0 PROBLEMS::
1. The module it doesn't appear neither to install it.

If somebody solves the problem with the area edit forum, I would like to continue with the newbb 2.0 version

Blessings,
David

2
McDonald
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/1 15:44

  • McDonald

  • Home away from home

  • Posts: 1072

  • Since: 2005/8/15


Not sure, but you might need Frameworks 1.20 (latest).

3
ipwgc
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/1 17:46

  • ipwgc

  • Quite a regular

  • Posts: 216

  • Since: 2005/8/13


Quote:

McDonald wrote:
Not sure, but you might need Frameworks 1.20 (latest).


Dear McDonald,
Thank you for you post,
I installed Frameworks 1.20 for FORUM "CBB 3.0" and this is the error message that appear on debug mode.

------------------------
Warning: main(/Frameworks/art/functions.ini.php) [function.main]: failed to open stream: No such file or directory in file /modules/newbb/xoops_version.php line 57

Warning: main() [function.include]: Failed opening '/Frameworks/art/functions.ini.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in file /modules/newbb/xoops_version.php line 57
---------------------------

Do you know if Frameworks is needed for forum NewBB 2.0?

Regards
David

4
skenow
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/1 21:08

  • skenow

  • Home away from home

  • Posts: 993

  • Since: 2004/11/17


First - CBB 3.08 does work in XOOPS 2.0.17. I have it working in several installation.

2. CBB does require Frameworks 1.10

3. There is an incompatibility problem with Frameworks 1.20 and CBB. What I know so far is posted here

5
ipwgc
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/2 0:47

  • ipwgc

  • Quite a regular

  • Posts: 216

  • Since: 2005/8/13


Quote:

skenow wrote:
First - CBB 3.08 does work in XOOPS 2.0.17. I have it working in several installation.
2. CBB does require Frameworks 1.10
3. There is an incompatibility problem with Frameworks 1.20 and CBB. What I know so far is


Thank you skenow for your info,
You are right cbb doesn't really work on XOOPS 2.0.17.
I installed Frameworks, 1.10 / 1.20/ and neither working.

My concern is really with Newbb 2.0. 2 because my forums are worked it not a problem, but if I try to edit the forum doesn't work.

You are willing to check what it happening with the edit page on newbb 2.0.2? /modules/newbb/edit.php

Thank you for any help.
David

6
skenow
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/2 1:18

  • skenow

  • Home away from home

  • Posts: 993

  • Since: 2004/11/17


David - I just registered on your site and posted in the forum. I also edited my post successfully.

Just to clarify: CBB 3.08 DOES WORK with XOOPS 2.0.17 and Frameworks 1.10. The only problems I encountered were when I upgraded Frameworks to 1.20.

7
ipwgc
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/2 1:23

  • ipwgc

  • Quite a regular

  • Posts: 216

  • Since: 2005/8/13


Quote:

skenow wrote:
David - I just registered on your site and posted in the forum. I also edited my post successfully.

Just to clarify: CBB 3.08 DOES WORK with XOOPS 2.0.17 and Frameworks 1.10. The only problems I encountered were when I upgraded Frameworks to 1.20.


Thank steve, but the problem is on the admin section,
you have the right to check as moderator,

David

8
skenow
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/2 1:36

  • skenow

  • Home away from home

  • Posts: 993

  • Since: 2004/11/17


OK - I have been looking at this for David, and his problem is in the admin area - the form to edit the forums does not load.

There are 2 solutions to this:
1. Replace class/xoopsform/form.php with an earlier version. Problem and solution found in this thread -https://xoops.org/modules/newbb/viewtopic.php?viewmode=flat&topic_id=53524&forum=7
2. Upgrade to CBB 3.08 with Frameworks 1.10

For supportability going forward, I recommend the second option (#2). Of course, backup your files and database before proceeding. Since you have some custom image sets for the forums, be sure to keep them intact, too.

9
ipwgc
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/2 1:45

  • ipwgc

  • Quite a regular

  • Posts: 216

  • Since: 2005/8/13


OK Steve,
I will follow your instructions and I will give you then a return.

Regards,
David

10
skenow
Re: Compatibility Forum Newbb with XOOPS 2.0.17 ??
  • 2007/9/2 1:50

  • skenow

  • Home away from home

  • Posts: 993

  • Since: 2004/11/17


Let me know how things work out.

I'll be dropping by the site once in a while - it is of great interest

Login

Who's Online

143 user(s) are online (117 user(s) are browsing Support Forums)


Members: 0


Guests: 143


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits