1
ron-cpw
Flash-based banners not responding to clicks
  • 2007/1/11 3:13

  • ron-cpw

  • Just popping in

  • Posts: 82

  • Since: 2006/12/19


Several affiliates are now supplying flash-based banners.

Our 'static' banners work, as do animated-GIF ones as well.

But when we create a new banner with the vendor-supplied code, the banner displays OK, but does not respond to clicks.

I have seen a few earlier threads on this topic, with no replies...

Here is the typical supplied code:

<a href="https://www.regnow.com/softsell/nph-softsell.cgi?item=4864-11&affiliate=xxxxx"><object classid='clsid:d27cdb6e-ae6d-11cf-96b8-444553540000' codebase='http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0' width='468' height='60' id='Reason 146 (468x60)' align='middle'><param name='allowScriptAccess' value='sameDomain' /><param name='movie' value='Reason 146 (468x60).swf' /><param name='menu' value='false' /><param name='quality' value='high' /><param name='bgcolor' value='#ffffff' /><embed src='http://www.acronis.com/i/banner/affiliate/Reason146(468x60).swf' menu='false' quality='high' bgcolor='#ffffff' width='468' height='60' name='Reason 146 (468x60)' align='middle' allowScriptAccess='sameDomain' type='application/x-shockwave-flash' pluginspage='http://www.macromedia.com/go/getflashplayer' /></object></a>


...any clues from this?

Thanks

2
pod
Re: Flash-based banners not responding to clicks
  • 2007/1/11 11:18

  • pod

  • Quite a regular

  • Posts: 301

  • Since: 2003/4/19


Most vendors distribute their Flash banners with a "ClickTag" variable so that you can implement their ad with your own banner click-thru tracking system. See the Microsoft guidelines here for more information on this.

In the case of your example, your object tag should look something like this:

<object classid='clsid:d27cdb6e-ae6d-11cf-96b8-444553540000' 
codebase='http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0' 
width='468' height='60' id='Reason 146 (468x60)' align='middle'>
<
param name='allowScriptAccess' value='sameDomain' />
<
param name='movie' value='Reason 146 (468x60).swf[color=FF0000]?clickTAG=https://www.regnow.com/softsell/nph-softsell.cgi?item=4864-11&affiliate=xxxxx [/color]'/>
<
param name='menu' value='false' />
<
param name='quality' value='high' />
<
param name='bgcolor' value='#ffffff' />
<
embed src='http://www.acronis.com/i/banner/affiliate/Reason146(468x60).swf[color=FF0000]?clickTAG=https://www.regnow.com/softsell/nph-softsell.cgi?item=4864-11&affiliate=xxxxx[/color]' 
menu='false' quality='high' bgcolor='#ffffff' width='468' height='60' 
name='Reason 146 (468x60)' align='middle' allowScriptAccess='sameDomain' 
type='application/x-shockwave-flash' pluginspage='http://www.macromedia.com/go/getflashplayer' />
</
object>



Hope this helps!
www.myxoops.com - MyXoops Is Your XOOPS!

3
ron-cpw
Re: Flash-based banners not responding to clicks
  • 2007/1/11 14:02

  • ron-cpw

  • Just popping in

  • Posts: 82

  • Since: 2006/12/19


Perfect...thanks so much for the insight.

Added the clickTAG and now the banner responds.

Still have minor issues to work thru,,,but this helps get them functional.

Minor issues...
admin issue...click counters do not seem to accumulate on flash banners..
..nor on banners that are pulled from external servers.
Appears that the click count only accumulates on locally stored banners. ???

also, Flash banner, upon click, opens destination in same browser window.... would like it to spawn new tab or new windows...so as not to "lose the impressee"

Thanks again for that fix, Pod

4
ron-cpw
Re: Flash-based banners not responding to clicks
  • 2007/1/12 20:18

  • ron-cpw

  • Just popping in

  • Posts: 82

  • Since: 2006/12/19


Quote:

...click counters do not seem to accumulate on flash banners..
..nor on banners that are pulled from external servers.
Appears that the click count only accumulates on locally stored banners. ???


Update on this problem...

It appears that click-count will only accumulate on simple banners, specified as Image URL and Click URL.

Any banner that uses the HTML option shows impressions but does not register clicks.

Not a killer...but a disappointment.

Has anyone seen this and have a fix for it?

Thanks

5
pod
Re: Flash-based banners not responding to clicks
  • 2007/1/12 23:01

  • pod

  • Quite a regular

  • Posts: 301

  • Since: 2003/4/19


You [should] just need to make sure that the destination link is the same as the one used by XOOPS to track click-thrus, but the same link does not seem to perform the redirect. If it did & you were trying to direct the HTML or Flash to open the URL for your Banner ID #1, the URL you should point to is:

http://www.yoursite.com/banners.php?op=click&bid=1

If you are trying to direct the HTML or Flash to open the URL for your Banner ID #2, the URL you should point to is:

http://www.yoursite.com/banners.php?op=click&bid=2

...etc.

This seems fix the issue of tracking clicks but for some reason does not redirect to the destination URL, odd. I'll have to look at banners.php & see if I can figure out what is going on there.

Regarding your previous question about the Flash banner opening the link in the same browser window, this is something that should be specified within the SWF file unless the vendor has included a 'window' variable, which your example banner did not include. If you have the FLA you can specify this in the OnClick function, ie: (clickTAG, "_blank").
www.myxoops.com - MyXoops Is Your XOOPS!

Login

Who's Online

62 user(s) are online (50 user(s) are browsing Support Forums)


Members: 0


Guests: 62


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Apr 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits