1
tingtong
installing lastest xoops
  • 2006/8/24 3:10

  • tingtong

  • Just popping in

  • Posts: 21

  • Since: 2006/1/31


I am currently running xoops2.2.3a and want to upgrade to lastest version. XOOPS version numbers are kind of confusion to me. can anyone tell me what upgrades i need to upgrade to latest version.

thanks much.

2
JCDunnart
Re: installing lastest xoops
  • 2006/8/24 5:15

  • JCDunnart

  • Not too shy to talk

  • Posts: 114

  • Since: 2006/7/1 5


XOOPS 2.2.4 is the version you need to upgrade to.

It will be good when XOOPS eventually returns to one version

3
zoullou
Re: installing lastest xoops
  • 2006/8/24 6:45

  • zoullou

  • Quite a regular

  • Posts: 250

  • Since: 2004/3/2 0


Quote:

JCDunnart wrote:
XOOPS 2.2.4 is the version you need to upgrade to.

NO. XOOPS 2.2.x aren't stable. If you want to be up to date use the downgrade script to get a XOOPS 2.0.x version and after upgrade it to the last XOOPS 2.0.x version by using dedicated version upgrade script.

Cheers

4
davidl2
Re: installing lastest xoops
  • 2006/8/24 8:08

  • davidl2

  • XOOPS is my life!

  • Posts: 4843

  • Since: 2003/5/26


Correct - downgrade to 2.0.13.2 (Downgrade is the wrong word really, as 2.0.13.2 is a newer version ) - and then upgrade to 2.0.14

Please make sure you fully backup site + database first.... just in case.

5
leostotch
Re: installing lastest xoops
  • 2006/8/24 11:35

  • leostotch

  • Just popping in

  • Posts: 76

  • Since: 2006/4/1 1


Mmmm... I understand why people get confused when they hear something like this

PHP 4.4.3 has been released after PHP 5.1.4, does that mean I was supposed to "update" my 5.1 to 4.4.3 ?

If you're using 2.2.3, you can update to 2.2.4.

If I got it right: 2.0.x and 2.2.x have many differences, and as 2.2 doesn't meet the developers' quality standards, the 2.0 code is going to be favored in the future. Now, if 2.2.3 works for you: keep using this branch, update to 2.2.4 if you can, and to 2.2.5 later if there's one.

There has been a "downgrade script" to switch from 2.2 to 2.0, but it is only for people who really need it and know what they're doing. If that's not your case: stay out of troubles, and update to any 2.2.x you may see, the fact developers choose to reuse one codebase or another one is their business, and doesn't concern regular users (you will be able to upgrade to 2.4 later, whether you're using 2.0, 2.2 )

6
davidl2
Re: installing lastest xoops
  • 2006/8/24 13:21

  • davidl2

  • XOOPS is my life!

  • Posts: 4843

  • Since: 2003/5/26


You're right Leo - if 2.2.x works for you... stick with it, but make sure you've updated to 2.2.4

7
rowdie
Re: installing lastest xoops
  • 2006/8/24 17:54

  • rowdie

  • Just can't stay away

  • Posts: 846

  • Since: 2004/7/21


It's really simple...
2.2 websites use 2.2 updates
2.0 websites use 2.0 updates

:-/

8
davidl2
Re: installing lastest xoops
  • 2006/8/24 18:02

  • davidl2

  • XOOPS is my life!

  • Posts: 4843

  • Since: 2003/5/26


That's the simplest explanation yet

Login

Username:
Password:

Lost Password? Register now!

Who's Online

68 user(s) are online (45 user(s) are browsing Support Forums)


Members: 0


Guests: 68


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits