1
daddystu
permissions or sessions problem..or both???
  • 2006/7/23 13:39

  • daddystu

  • Just popping in

  • Posts: 100

  • Since: 2004/5/25


XOOPS Version: 2.0.15 JP
Module Name/Version: all/core
PHP Version:4.4.2
MySQL Version:4.0.27
Web Server Software (Apache/IIS/Other): Apache
Operating System:Linux
Theme you are using:newcrimson (css adapted slightly)
Custom template: (Yes/No) yes
PHP Debug Messages: turned off - can't access now
MySQL Debug Messages:turned off - can't access now
Smarty Debug Messages:turned off - can't access now


Sudden change in behaviour.
All users including admin can log in successfully to the front page.
BUT clicking on any link to any module whatsoever, now gives the
'You do not have permission to access this area...' and takes the user/admin back to the log in screen.
If the user then logs in again, a blank white screen appears...

URL in the address bar...
Since this behaviour began, I have been getting session info in the address,
here is a concrete example..

->login to www.xxx.net/index.php

->URL changes to user.php briefly but then takes me to the front page with
->www.xxx.net/index.php?PHPSESSI ... f3d85b69e5ca85e8f1aeec534

->If I then click on any link, I get 'No permissions..' and then am taken to the login screen again with a redirect..

->www.xxx.net/user.php?xoops_red ... 080e07aefd74cf65a62f95c2e

->In this case, I clicked on a link to go to smartsection.

The site has been running really well up until now.
The only thing I can recall doing prior to this was install the PiCal module. This, though was working fine, logged in and out admin and user. Another remote user also logged in and out and used the PiCal module...

Another almost identical site on the same domain but different subdomain is working fine.

I now have no access to the admin side because as I said, this behaviour is the same with the admin account as well.

I have verified the behaviour not only with different browsers and user accounts from my own home but also from other ip addresses and accounts too.
All report the same behaviour.

Any suggestions welcomed

I have full access to the directory and the databases...I can do a full restore but would rather not

I can probably turn on the debug setting through the database too, haven't tried that yet though, thought I'd see if anyone here can lend a hand again.

TIA
??????- isogebamaware

2
Bender
Re: permissions or sessions problem..or both???
  • 2006/7/23 17:50

  • Bender

  • Home away from home

  • Posts: 1899

  • Since: 2003/3/10


Try to empty (not delete!) the xoops_session table in your database.
Sorry, this signature is experiencing technical difficulties. We will return you to the sheduled signature as soon as possible ...

3
daddystu
Re: permissions or sessions problem..or both???
  • 2006/7/23 22:56

  • daddystu

  • Just popping in

  • Posts: 100

  • Since: 2004/5/25


Thanks for the reply Bender.

I just tried that, emptied (carefully! ) the sessions table.
Doesn't seem to have changed anything though.
??????- isogebamaware

4
daddystu
Re: permissions or sessions problem..or both???
  • 2006/7/24 13:02

  • daddystu

  • Just popping in

  • Posts: 100

  • Since: 2004/5/25


SOLVED!!

Very sorry to have troubled you, it was something I did ..of course!!

For eduaction's sake, here is the explanation.

Previously, I had altered the language/Japanese/global.php file to try the different Japanese encodings. (I wanted to generate a pdf from smartsection module but could not get it to work...)

I edited the global.php file using the online provider's editing system.
I thought this would be the safest.

In short, the online editor added extra blank spaces to the global.php file.

That was the cause of all this hassle it seems.

In future, as my provider now advised, I will use my own text editor and ftp.

Thank you very much to my provider MyWebJapan who provided excellent support.

Interesting how blank space can cause these kinds of symptoms innit

Thanks for everyone's time, sorry to have troubled you.

Lesson well learnt...I hope!
??????- isogebamaware

Login

Username:
Password:

Lost Password? Register now!

Who's Online

67 user(s) are online (32 user(s) are browsing Support Forums)


Members: 0


Guests: 67


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jan 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits