1
Fastian
XM-memberstats ... Help Needed
  • 2005/10/15 5:55

  • Fastian

  • Not too shy to talk

  • Posts: 156

  • Since: 2005/6/6 0


Hi
Yesterday, I installed this module. Installation was with no error. Now i have this module on my main. The problem is, Its not displaying any Flag at all.
When I look for the source it leads to
"http://www.domain.com/modules/xmmemberstats/images/flags/-.gif"
No country flag. Where i did wrong ???

Secondly, Sometimes, its showing my client IP or sometimes the proxy IP whome i m connected to. Is this the way it works or its just me who is getting this ???

I use ip2location.com to check my IP.

I am using XOOPS 2.0.13.1 with XM-memberstats 2.0e
I m not a Programmer
BUT
I m a Good Learner

2
isronax
Re: XM-memberstats ... Help Needed
  • 2005/10/15 6:27

  • isronax

  • Just popping in

  • Posts: 100

  • Since: 2005/4/26


first chek out this onehttps://xoops.org/modules/newbb/viewtopic.php?topic_id=42322&forum=28&post_id=185312#forumpost185312

second: have you install xmmemberstat, www.yourdomain.com/xmmemberstats/install/

1.install betwenn admin section
2. install manually

third: dont forget to delete install folder in xmmemberstat

and check this one tohttp://www.xoopsmalaysia.org/modules/newbb/viewtopic.php?topic_id=573&start=0#forumpost3316
The Greats Xoops ... Go Ahead.
www.xoopsindonesia.com
www.indonesianschool.org

3
Fastian
Re: XM-memberstats ... Help Needed
  • 2005/10/15 7:04

  • Fastian

  • Not too shy to talk

  • Posts: 156

  • Since: 2005/6/6 0


1) I did install the correct version of the module.

2) I have installed it both ways. i.e Installing module and installing by the install script. Both went without error.

3) I didnt delete the install folder but i have done now.

BUT still my problem is there. Its not showing the Flags. (flag directory is there )
I m not a Programmer
BUT
I m a Good Learner

4
jdseymour
Re: XM-memberstats ... Help Needed

Quote:

Fastian wrote:
1) I did install the correct version of the module.

2) I have installed it both ways. i.e Installing module and installing by the install script. Both went without error.

3) I didnt delete the install folder but i have done now.

BUT still my problem is there. Its not showing the Flags. (flag directory is there )


Flag directory does not matter, are the flags to IP information in your database. In phpmyadmin check the "yourprefix_iptoc" table is there and populated in the database, there should be 53,372 entries. If not rerun the install script and give it time, over 2 megabytes of information takes some time to write.

Also doublecheck that you are using the one for 2.0x XOOPS. 2 versions are available, one for 2.0x and one for 2.2x.

HTH.

5
smdcom
Re: XM-memberstats ... Help Needed

Quote:

jdseymour wrote:
Flag directory does not matter, are the flags to IP information in your database. In phpmyadmin check the "yourprefix_iptoc" table is there and populated in the database, there should be 53,372 entries.


Check your db for this. If your iptoc table is emtpy, that's mean your installation not done yet.

SMD

6
Fastian
Re: XM-memberstats ... Help Needed
  • 2005/10/15 13:34

  • Fastian

  • Not too shy to talk

  • Posts: 156

  • Since: 2005/6/6 0


Thanks jdseymour & smdcom

That was the problem. Dont know why but the database was having half entries. I run the installer again and it solve the problem.

Now the great module is working just fine
I m not a Programmer
BUT
I m a Good Learner

7
Fastian
Re: XM-memberstats ... Help Needed
  • 2005/11/8 20:05

  • Fastian

  • Not too shy to talk

  • Posts: 156

  • Since: 2005/6/6 0


I guess this is a known issue but is there any good way to solve this or to minimise it.

The problem is that the number of user online and their IPs remain online even if the user left the site. You can see his IP for almost 1 hour. :(

The worst thing is ....
When i open the site, it shows my IP as guest, when I sign in it shows 2 users online. Me as guest and me as admin. Is there anyway to solve this issue.
I m not a Programmer
BUT
I m a Good Learner

8
Bender
Re: XM-memberstats ... Help Needed
  • 2005/11/8 20:15

  • Bender

  • Home away from home

  • Posts: 1899

  • Since: 2003/3/10


This is not a problem of xm-memberstats but the way XOOPS is handling the who is online check.

You can make it more accurate by changing the time how often its updated at a cost of performance. However if it is not a big traffic site in regards to user numbers the impact would be minimal at all.

While i used this myself i donĀ“t have the file that needs to be edited at hand. So ... sorry to say try a search on this forum about this issue. I will get back if i can find it though.
Sorry, this signature is experiencing technical difficulties. We will return you to the sheduled signature as soon as possible ...

9
Fastian
Re: XM-memberstats ... Help Needed
  • 2005/11/10 13:37

  • Fastian

  • Not too shy to talk

  • Posts: 156

  • Since: 2005/6/6 0


I searched but i am not sure if i have found the right thing.

Were u refering to the post below??

Post

Edited :

Right after posting this, I found this article on XOOPS Tips.
Xoops Tips
I hope this will help. I am about to apply this.
I m not a Programmer
BUT
I m a Good Learner

10
Fastian
Re: XM-memberstats ... Help Needed
  • 2005/11/10 19:17

  • Fastian

  • Not too shy to talk

  • Posts: 156

  • Since: 2005/6/6 0



I applied both of them but none workked for me.

I see me being displayed as 2 users. Also if a user leave the site, It shows him online for about 1 hour.

I havent enabled any cache for any module or site.

Bender I am looking to hear anything from U.
I m not a Programmer
BUT
I m a Good Learner

Login

Who's Online

172 user(s) are online (58 user(s) are browsing Support Forums)


Members: 0


Guests: 172


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits