11
maciek
Re: Problem with blocks after upgrade.
  • 2005/8/13 22:45

  • maciek

  • Just popping in

  • Posts: 5

  • Since: 2005/8/1 8


Ok, try this:
Log in to mysql, then execute following:

select bid from (prefix)_newblocks
left join (prefix)_modules on (prefix)_newblocks.mid = (prefix)_modules.mid
where (prefix)_modules.mid is null;

If there is some output (unless it is 'Empty set' of course ;)), delete all the blocks from (prefix)_newblocks table with bids you got (delete from (prefix)_newblocks where bid=bid).

Then execute next select:

select (prefix)_block_instance.bid from (prefix)_block_instance
left join (prefix)_newblocks on (prefix)_block_instance.bid = (prefix)_newblocks.bid
where (prefix)_newblocks.bid is null;

and delete the blocks from (prefix)_block_instance with bids you got.

Do not forget to make backup first.

12
azeini
Re: Problem with blocks after upgrade.
  • 2005/8/14 7:27

  • azeini

  • Just popping in

  • Posts: 19

  • Since: 2003/7/23


Yep, thanks to Mithrandir and maciek for the help. That was exactly the problem. Few modules that I had installed and removed later remained in the blocks part.
Problem solved.

13
MarcoDeMarco
Re: Problem with blocks after upgrade.

I'm having a problem with blocks as well.
Mine is that the block name is appearing but the contents are empty! I added some debug and the $block is being populated and I also tried a different theme but it's still blank. I then got so upset that I went and Hard-Coded a block - that is blank also. I tried just making a block with simple text in it. I get the Block Name but not the contents. Anyone help me with my Block of $#!T

14
jdseymour
Re: Problem with blocks after upgrade.

Hi MarcoDeMarco,

Try updating the system module in the modules administration page. Also if you are using cloned templates generate the missing system templates through the templates administration page. The blocks should show after that.

15
MarcoDeMarco
Re: Problem with blocks after upgrade.

Thanks for your response but that trick didn't work

I'm using C-Jay Content Version 3.

I also created another block with XOOPS before and after the system update and still can't see the contents of the blocks just the header of the block.

Still trying to fix my Blocks of $#!T

Login

Username:
Password:

Lost Password? Register now!

Who's Online

66 user(s) are online (49 user(s) are browsing Support Forums)


Members: 1


Guests: 65


heyula,

more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Nov 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits