xoops forums

koertzen

Just popping in
Posted on: 2005/7/31 23:45
koertzen
koertzen (Show more)
Just popping in
Posts: 79
Since: 2003/10/22
#1

Admin in 2.2: Trouble with sessions - Resolved, Found Bug (See Thread)

First of all... Thank you development team for your hard work, and all of you who were brave and smart enough to test the RC versions for the rest of us! You have all done a GREAT job. As we see in most of these postings, the problems have to do with issues that most of us have created for ourselves. Thank you for your diligence Mirth. And Herko, I'm sorry that you're getting frustrated with users and their snippy responses. I sincerely appreciate the work that both of you are doing and have done. And I believe that 2.2 is a step in the RIGHT direction for Xoops. The reason people are having so much trouble is that you've actually made important changes in the core. It will have a tendency to impact people dramatically. In any case thanks!

THE ISSUE

After botching an update to 2.2, I found that my database was entirely screwed up. Prior update attempts had created multiple entries for modules in the modules table as well as configs.

After attempting to fix the tables manually, I decided to just try a fresh install. I renamed the database, deleted all the core files, and started over. My intent will be to load the user names and some of the other content from the old database when I have the new site stable.

Now, here's the problem. While attempting to update preferences through the site, I keep getting a blank page (/modules/system/admin.php?fct=preferences) after attempts to update the preferences (i.e., /modules/system/admin.php?fct=preferences&op=showmod&mod=1&confcat_id=1).
A page refresh gives me the following error:
Quote:

No valid security token found in session


Is there some kind of configuration issue that I need to modify either on the site or on my browser settings? I use Firefox 1.04. I've tested in Firefox 1.04, Netscape 8.0, and IE. In I.E. I get the following error:
Quote:

Fatal error: Maximum execution time of 30 seconds exceeded in d:\[home]\[user]\[site]\class\smarty\core\core.rmdir.php on line 27


When I have reviewed the active sessions on the database (using mysqlcc), I see XOOPS_TOKEN_SESSION entries for my session ID, so I'm not sure if that's related to the problem or not.

My site has now been down for almost 18 hours now. Any help in this area would be GREATLY appreciated!

Thanks,
Jeff

-----------------------------------------------

Site Details (Thanks lykoszine for the suggestion to include!):

PHP? 4.3.11
SQL? MySQL 3.23.49
OS? Windows NT
Apache/ISS/Other? IIS4 5.0 build 2195
Xoops? 2.2
DB, name and pass? Yes
Hosted? Yes
Shell access? No

Register Globals, on/off? On

Xoops URL? Please request from me via PM if you can help.
Xoops Path? Upon request only

install.php? No. Deleted after installation
index.php? Yes
Can you log-in? Yes

mysql.connect_timeout: 60
Be the change you wish to see in the world.
-Ghandi

jdseymour

Friend of XOOPS
Posted on: 2005/8/1 0:04
jdseymour
jdseymour (Show more)
Friend of XOOPS
Posts: 3782
Since: 2004/11/11
#2

Re: Admin in 2.2: Trouble with sessions - Site down - Please Help!

I am not sure where to start here, but I have seen some token errors before on the forums. One question, do you use custom sessions?

See this Thread.

koertzen

Just popping in
Posted on: 2005/8/1 0:21
koertzen
koertzen (Show more)
Just popping in
Posts: 79
Since: 2003/10/22
#3

Re: Admin in 2.2: Trouble with sessions - Site down - Please Help!

Thanks jdseymour. I had searched the site earlier and found this thread. I changed the timeouts, but it doesn't seem to affect my ability to change the preferences. I've changed back and forth from using custom sessions to not using them by changing the value directly in the database (config > conf_name='use_mysession'). This also doesn't seem to help.

This problme, by the way, only occurs with preferences (configuration). I can make changes under any other menu in the Admin section, just not preferences.
Be the change you wish to see in the world.
-Ghandi

jdseymour

Friend of XOOPS
Posted on: 2005/8/1 0:33
jdseymour
jdseymour (Show more)
Friend of XOOPS
Posts: 3782
Since: 2004/11/11
#4

Re: Admin in 2.2: Trouble with sessions - Site down - Please Help!

Well I am no coder, but see This File Online. This is what is generating your error. Now just to find out why your token is invalid.

koertzen

Just popping in
Posted on: 2005/8/1 4:11
koertzen
koertzen (Show more)
Just popping in
Posts: 79
Since: 2003/10/22
#5

Admin in 2.2: Trouble with sessions - Resolved, Found Bug (See Thread)

I found the problem. I will have to log a bug for it. My site is now functioning properly (re-loading data aside :).

Through common comment debugging, I found that by commenting out the clearing of the cache in the admin/preferences/main.php page, my updates were able to process properly. I'm not sure why that would be the case, but I'll leave that up to the developers.

Quote:

341: //$xoopsTpl->clear_all_cache();
Be the change you wish to see in the world.
-Ghandi

jdseymour

Friend of XOOPS
Posted on: 2005/8/1 6:27
jdseymour
jdseymour (Show more)
Friend of XOOPS
Posts: 3782
Since: 2004/11/11
#6

Re: Admin in 2.2: Trouble with sessions - Resolved, Found Bug (See Thread)

Glad to hear that you got it working.