1
Gilian
Problems with xoops after update
  • 2005/7/3 20:37

  • Gilian

  • Not too shy to talk

  • Posts: 133

  • Since: 2002/6/13


Hello all,

It's been a while since i was active here. But i'm making a XOOPS site again.

After i updated my site to XOOPS 2.0.12a i've had some problems, i made a welcome block, with html, some text and pictures in it, it worked fine before, but since i updated to the newest xoops, the block looks empty on the site. But if i look in admin, everything is still as it's supposed to be in that block.

I tried to make the block again and to make a bb code instead of html, but in both i still had the same problem.

And now.. suddenly, i can't change blocks anymore at all, if i try to it says "Valid token expired ", same with adding a new block.

I did update to 2.0.13 now, still the same problems. I also overwritten all XOOPS files, except the mainfile.php from the newest XOOPS version. But it still doesn't work.

So, if anyone could helpe me with this, it would be appriciated.

This is the site:
http://www.slayerduck.net/

Thanks in advance,
Gilian
<--------------------------------->
DON'T SEND SPAM IT'S VERY BAD!!
<--------------------------------->

2
jdseymour
Re: Problems with xoops after update

Update the system module in modules admin, and if you have cloned templates check the system templates to see if any need to be generated.

HTH.

3
Gilian
Re: Problems with xoops after update
  • 2005/7/3 23:36

  • Gilian

  • Not too shy to talk

  • Posts: 133

  • Since: 2002/6/13


update system module didn't work and i only have to generate templates for modules i don't even use, but if i do try to generate them, it says "Valid token expired " again
emptying the template_c dir works neither

i never had this problem before.. i don't even know what is ment by "Valid token expired"..
<--------------------------------->
DON'T SEND SPAM IT'S VERY BAD!!
<--------------------------------->

4
jdseymour
Re: Problems with xoops after update

Do you use a custom session? Try turning it off.

5
Gilian
Re: Problems with xoops after update
  • 2005/7/4 11:57

  • Gilian

  • Not too shy to talk

  • Posts: 133

  • Since: 2002/6/13


i can't turn it of... it says "Valid token expired" with everything i try to change
<--------------------------------->
DON'T SEND SPAM IT'S VERY BAD!!
<--------------------------------->

6
Mithrandir
Re: Problems with xoops after update

Do you have a very high number for the custom session expiration time?
"When you can flatten entire cities at a whim, a tendency towards quiet reflection and seeing-things-from-the-other-fellow's-point-of-view is seldom necessary."

Cusix Software

7
Gilian
Re: Problems with xoops after update
  • 2005/7/4 13:24

  • Gilian

  • Not too shy to talk

  • Posts: 133

  • Since: 2002/6/13


yeah, i have the max (2147483647)
i've done that for the auto-login hack, so it works for a long time
never had problems before with it (and i have the login hack for XOOPS 2.013)
<--------------------------------->
DON'T SEND SPAM IT'S VERY BAD!!
<--------------------------------->

8
Mithrandir
Re: Problems with xoops after update

That might have something to do with the Security Token problem.

I'm mixing things together, but think I did not try to fix it in 2.0.x, but I know I did for XOOPS 2.2

Try setting the session expiration time to a lower value (10-20.000 perhaps) - you'll probably have to go directly through the database (prefix_config table) to do so.
"When you can flatten entire cities at a whim, a tendency towards quiet reflection and seeing-things-from-the-other-fellow's-point-of-view is seldom necessary."

Cusix Software

9
Gilian
Re: Problems with xoops after update
  • 2005/7/4 16:49

  • Gilian

  • Not too shy to talk

  • Posts: 133

  • Since: 2002/6/13


ok, i changed it to 10000 in the xoops_config table
thanks, it works fine now, i can change things again :)

but not i still have one problem left:
if i make any custom blocks, the content isn't visible, doesn't matter if i make it in html, auto fomrat or whatever, i don't see any content on the main page.
This also worked fine before the update.. but not anymore
<--------------------------------->
DON'T SEND SPAM IT'S VERY BAD!!
<--------------------------------->

10
jdseymour
Re: Problems with xoops after update

Now that you have the invalid token problem fixed, you should update the system module, and generate any missing system templates in your cloned templates. The content will come back then.

Login

Username:
Password:

Lost Password? Register now!

Who's Online

59 user(s) are online (41 user(s) are browsing Support Forums)


Members: 0


Guests: 59


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jan 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits