1
Max-Realms
Protector overriding debug mode off?
  • 2005/4/28 22:12

  • Max-Realms

  • Just popping in

  • Posts: 20

  • Since: 2005/3/26


I have Protector (latest version) installed and configured correctly. Now when MySQL max_questions are exceeded, I should just get a blank page because I have debug mode turned off.

But I get this message:

Quote:
Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/mysite/public_html/modules/protector/class/protector.php on line 45


Is protector superceeding the debug off command? How can I prevent this. Google is indexing this, btw.

Please help if you can.

David

2
Mamba
Re: Protector overriding debug mode off?
  • 2006/3/27 16:21

  • Mamba

  • Moderator

  • Posts: 11256

  • Since: 2004/4/23


Same situation here.

The worst part is that I cannot even login as the Admin anymory to disable the Protector module.

Am I being hacked, or what is going on?

Any help?
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

3
Dave_L
Re: Protector overriding debug mode off?
  • 2006/3/27 19:08

  • Dave_L

  • XOOPS is my life!

  • Posts: 2277

  • Since: 2003/11/7


The original post here is almost a year old, and I don't know what version of Protector or XOOPS is being referenced.

I just checked Protector 2.55 (on XOOPS 2.2.4), and the only place it calls error_reporting() is in modules/protector/class/protector.php, where it temporarily turns off all error reporting, and then restores it to the previous setting.

You might repost your question on the Protector support forum at http://www.peak.ne.jp/xoops/

P.S. You can always disable Protector by editing mainfile.php and commenting-out or deleting the two lines you added when installing the module.

Login

Who's Online

61 user(s) are online (41 user(s) are browsing Support Forums)


Members: 0


Guests: 61


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits