xoops forums

ericswebber

Just popping in
Posted on: 2004/12/31 1:06
ericswebber
ericswebber (Show more)
Just popping in
Posts: 5
Since: 2004/12/28
#1

FRESH Xoops 2.0.9.2 Install --- MODULES NOT WORKING ?

MODULES APPEAR to NOT WORK on FRESH INSTALL

My environment: Fresh, local XOOPS 2.0.9.2 Install on Win2K
PHP Version 5.0.3, MySQL 4.1.8-nt, IIS 5.X


The following modules appeared to install fine but do not really work:

Members Module - The search comes up but never finds anyone. [note in SystemAdmin Find Users does find members, but not from the main screen.]

Web Links Module - Again installed fine, can fill out submit new web link screen, but nothing is created, no notice of new web link waiting for approval. Also in SysAdmin Web Links Config, cannot creat new categories when clicking on "Add, Modify, and Delete Categories/Links" it simply comes back with same menu.

News Module - Same as above... Clicking in Sysadmin News Config on "- Topics Manager", and "- Post/Edit Articles" has no effect, the menu simply repaints.

The db access appears fine as the installation of the modules required creating tables etc, they are all there. Site appears fine in every respect, except the modules do not work for some reason.

Have not tried the other modules yet.

I must be missing something really simple. My site is local to my machine and also available over net with link which I can provide upon request.

When turning on MySQL Debug, it appears the queries related to the use of the above mentioned modules are not even being executed, despite the installation of the modules themselves having created the right tables etc.

warmest regards,

Eric Sean Webber
ericswebber@yahoo.com

onokazu

XOOPS Founder
Posted on: 2004/12/31 2:09
onokazu
onokazu (Show more)
XOOPS Founder
Posts: 617
Since: 2001/12/13
#2

Re: FRESH Xoops 2.0.9.2 Install --- MODULES NOT WORKING ?

I do not know right now what the real cause of your problem is, but 2.0.9.2 is not still 100% compatible with php5. Also you may need to downgrade MySQL to 4.0.x.

ericswebber

Just popping in
Posted on: 2004/12/31 2:22
ericswebber
ericswebber (Show more)
Just popping in
Posts: 5
Since: 2004/12/28
#3

Re: FRESH Xoops 2.0.9.2 Install --- MODULES NOT WORKING ?

Have you heard of anyone else with this problem and using the versions I am using ? In other words, before switching versions of PHP and MySQL, I wish to be more certain that this might be the cause.

So which version of PHP would you recommend ?

When is it planned for XOOPS to use PHP 5 and MySQL 4.1.X ?

So as far you know, no one is using XOOPS with latest versions of PHP and MySQL ?


XOOPS is very nice !!!

Thanks in advance !!

ericswebber@yahoo.com

ericswebber

Just popping in
Posted on: 2004/12/31 4:51
ericswebber
ericswebber (Show more)
Just popping in
Posts: 5
Since: 2004/12/28
#4

Re: FRESH Xoops 2.0.9.2 Install --- MODULES NOT WORKING ?

Again very much appreciate your responses, nice to speak with founder !!

Based on your suggestions below, Now I am using:

PHP Version 4.3.10 ISAPI
MySQL 4.0.23-nt via TCP/IP
IIS 5, on win2k


and I reinstalled XOOPS 2.0.9.2, all green lights, then logged in, and when I click on ANY of the System Admin functions I get:

Selected module does not exist!

Does this ring a bell ?

best regards,

ericswebber@yahoo.com


Quote:

onokazu wrote:
I do not know right now what the real cause of your problem is, but 2.0.9.2 is not still 100% compatible with php5. Also you may need to downgrade MySQL to 4.0.x.

kvento

Just popping in
Posted on: 2005/1/6 0:42
kvento
kvento (Show more)
Just popping in
Posts: 2
Since: 2005/1/6 0
#5

Re: FRESH Xoops 2.0.9.2 Install --- MODULES NOT WORKING ?

I also get the same error "module not installed" I can't even see the core modules in administration. I was able to upgrade my original XOOPS on a Linux machine. However, not able to install a fresh version of 2.09.2 on Windows Server.

BTW I'm using PHP 4.3.9 This is my development server so I can test any changes that might be appropriate.

Kam

donnoman

Just popping in
Posted on: 2005/2/13 18:05
donnoman
donnoman (Show more)
Just popping in
Posts: 1
Since: 2005/2/13
#6

Re: FRESH Xoops 2.0.9.2 Install --- MODULES NOT WORKING ?

xoops-2.0.9.2 && php-4.3.10
After new install on Win 2k IIS 5 when you click on anything in the system admin menu you get:
Quote:

Selected module does not exist!

find in include/common.php:
if ( !isset( $_SERVER'REQUEST_URI' ] ) ) {         // Not defined by IIS
        // Under some configs, IIS makes SCRIPT_NAME point to php.exe :-(
        
if ( !( $_SERVER'REQUEST_URI' ] = @$_SERVER['PHP_SELF'] ) ) {
            
$_SERVER'REQUEST_URI' ] = $_SERVER['SCRIPT_NAME'];
        }
        if ( isset( 
$_SERVER'QUERY_STRING' ] ) ) {
            
$_SERVER'REQUEST_URI' ] .= '?' $_SERVER'QUERY_STRING' ];
        }
    }

Even though the 'REQUEST_URI' appears to be nul, isset is returning 1.
From phpinfo();
Quote:

_SERVER["REQUEST_URI"] no value

change to:
if ( !$_SERVER'REQUEST_URI' ] )  {         // Not defined by IIS - isset returns 1 even when blank
        // Under some configs, IIS makes SCRIPT_NAME point to php.exe :-(
        
if ( !( $_SERVER'REQUEST_URI' ] = @$_SERVER['PHP_SELF'] ) ) {
            
$_SERVER'REQUEST_URI' ] = $_SERVER['SCRIPT_NAME'];
        }
        if ( isset( 
$_SERVER'QUERY_STRING' ] ) ) {
            
$_SERVER'REQUEST_URI' ] .= '?' $_SERVER'QUERY_STRING' ];
        }
    }

Mithrandir

XOOPS is my life!
Posted on: 2005/2/13 20:08
Mithrandir
Mithrandir (Show more)
XOOPS is my life!
Posts: 6320
Since: 2003/6/21
#7

Re: FRESH Xoops 2.0.9.2 Install --- MODULES NOT WORKING ?

To play it safe, maybe this is better:
if ( !isset($_SERVER['REQUEST_URI'] || !$_SERVER'REQUEST_URI' ] )  {         // Not defined by IIS - isset returns 1 even when blank
        // Under some configs, IIS makes SCRIPT_NAME point to php.exe :-(
        
if ( !( $_SERVER'REQUEST_URI' ] = @$_SERVER['PHP_SELF'] ) ) {
            
$_SERVER'REQUEST_URI' ] = $_SERVER['SCRIPT_NAME'];
        }
        if ( isset( 
$_SERVER'QUERY_STRING' ] ) ) {
            
$_SERVER'REQUEST_URI' ] .= '?' $_SERVER'QUERY_STRING' ];
        }
    }


To the original poster: Check if the directive in php.ini "register_long_arrays" is set to "on"

DuongQua

Just popping in
Posted on: 2005/4/21 4:54
DuongQua
DuongQua (Show more)
Just popping in
Posts: 4
Since: 2004/11/17
#8

Re: FRESH Xoops 2.0.9.2 Install --- MODULES NOT WORKING ?

if ( !isset($_SERVER['REQUEST_URI']) || !$_SERVER'REQUEST_URI' ] )  {         // Not defined by IIS - isset returns 1 even when blank
        // Under some configs, IIS makes SCRIPT_NAME point to php.exe :-(
        
if ( !( $_SERVER'REQUEST_URI' ] = @$_SERVER['PHP_SELF'] ) ) {
            
$_SERVER'REQUEST_URI' ] = $_SERVER['SCRIPT_NAME'];
        }
        if ( isset( 
$_SERVER'QUERY_STRING' ] ) ) {
            
$_SERVER'REQUEST_URI' ] .= '?' $_SERVER'QUERY_STRING' ];
        }
    }


Thank you in advance!