1
indikator
problem with setting chmod 444 on the mainfile.php
  • 2004/9/5 11:53

  • indikator

  • Just popping in

  • Posts: 14

  • Since: 2004/9/5 1


I can't set chmod 444 on the mainfile.php because my host does not alow it, but security is not a problem for me because i will get an other host soon anyway, but i would like to lose the errormessage on my admin pannel.

error message:

Quote:
WARNING: File /home/users/3dcc/www/meclan/mainfile.php is writeable by the server.
Please change the permission of this file for security reasons.
in Unix (444), in Win32 (read-only)

could someone please tell me how to turn the security message off? or fix it in an other way?


thanx, indi

2
irmtfan
Re: problem with setting chmod 444 on the mainfile.php
  • 2004/9/5 12:27

  • irmtfan

  • Module Developer

  • Posts: 3419

  • Since: 2003/12/7


set chmode on 644 is good for u and safe

3
indikator
Re: problem with setting chmod 444 on the mainfile.php
  • 2004/9/5 12:57

  • indikator

  • Just popping in

  • Posts: 14

  • Since: 2004/9/5 1


yes 444 is good for me, but if i set chmod 444 with my ftp client and then refresh the page and lookup the chmod settings again then it automaticly is changed back to chmod 644. i have a problem with my host, but i don't care about having a safe portal at the moment because i am going to have a new host soon, so could someone please tell me how to get rid of it ?

4
tl
Re: problem with setting chmod 444 on the mainfile.php
  • 2004/9/5 13:33

  • tl

  • Friend of XOOPS

  • Posts: 999

  • Since: 2002/6/23


644 should be safe, you could just ignore the message.

If the error message is really buging you, you could modify the admin.php located in your root directory

find [under switch ($op)]

if ( is_writable(XOOPS_ROOT_PATH."/mainfile.php" ) ) {
        
xoops_error(sprintf(_WARNINWRITEABLE,XOOPS_ROOT_PATH.'/mainfile.php'));
        echo 
'<br />';
    }

comment out the four lines - be warned you must manually check if the mainfile.php has really been chm'd to 644

5
irmtfan
Re: problem with setting chmod 444 on the mainfile.php
  • 2004/9/5 13:57

  • irmtfan

  • Module Developer

  • Posts: 3419

  • Since: 2003/12/7


but i think when u set chmode on 644 that message doesnt show.

6
tl
Re: problem with setting chmod 444 on the mainfile.php
  • 2004/9/5 14:44

  • tl

  • Friend of XOOPS

  • Posts: 999

  • Since: 2002/6/23


Quote:

irmtfan wrote:
but i think when u set chmode on 644 that message doesnt show.

Yes, it does, especially on some of BSD systems. Only chm'ding to 444 will get rid of the error message.


7
KimberlyTeed
Re: problem with setting chmod 444 on the mainfile.php

I have chmod'ed to 444 ... and I still get the message ... any other solutions?

8
tl
Re: problem with setting chmod 444 on the mainfile.php
  • 2004/9/9 15:10

  • tl

  • Friend of XOOPS

  • Posts: 999

  • Since: 2002/6/23


I would double-check the permission again afterwards. Some systems would tell that you have chmod'd 444, but in reality, it did not and maybe just 644.

9
KimberlyTeed
Re: problem with setting chmod 444 on the mainfile.php

I'm using an FTP ... it checks fine ... hmmm???

Thank you for the response