91
brutalicuss
"cumulus" stops working in flash mode

Hi guys!

Sorry Im writing again, but Ive strange problem with this nice module
First the "tag_block_cumulus" worked fine. Just set the size, colors and speed and little edit the block. Worked 2-3 days and stops working in flash mode. Very strange. Now shows tags without flash mode (only txt), like regular TAG block (mean module-block "tag_block_cumulus")
I tried to reinstall, delete and set again and again, but no flash results, continues only txt mode.
Has anyone the same problem? Im wondering where must look for this problem, seems everything is OK, but obviously its not.



92
brutalicuss
Re: Problem with CYR character when setting value

Yes, you'r right! This is the easier way! I understand right now.
I have 6 xoops sites, but for first time looked in xoopslocal... "the man learns while living"
I spent much time... this will be lesson for me
10x for opening my eyes :)



93
brutalicuss
Re: Problem with CYR character when setting value

Foud for module "catads" (latest ads)
Was easier (after first) :)

modules/catads/blocks - file: catads_new.php
replace this line:
$a_item['title'] = substr($a_item['title'],0, $options[4] - $length1)."...";
with this:
$a_item['title'] = mb_substr($a_item['title'],0, $options[4] - $length1)."...";

the difference is only "mb_substr" instead "substr"
this call "Multibyte String" - almost all hosting company support this library

These were my xoops-problems for now :)

I like xoops really!



94
brutalicuss
Re: Problem with CYR character when setting value

10x very much man, thats right, this is the real problem in "2-byte characters"

After many hours reading in the net I found decision for Ohwada's WEBLINKS.
I tried many "tricks" with strlen and substr but without success.
Finally fix it (for all they have same problem)
Its sumple:
module/happy_linux - folders "class" and "include"
add this funk at the beginning of files: strings.php (in class) and multibyte.php (in include)
<?php
mb_internal_encoding("UTF-8");
?>
Thats all!
This fix any "?" END characters in any block or title or description

Now looking for decision for module "catads", still have trouble with it

10x



95
brutalicuss
Problem with CYR character when setting value

Hi there!

Ive a "little" problem with some special cyrillic characters at the end of my "setting value" in few modules like "weblinks", "news" and others.
This characters shows like "?" only at the end of "setting" title or description in many blocks of these modules.
look here example: http://postimage.org/image/6xamfcczb/
All my pages are converted in UTF-8, there is no problem with encoding.
It happens only when "setting value" (for exp. 80 character in title and 200 in desc) falls in the word and convert the last (80th, 200th) in this strange "?"
I tried many many ways to fix this, but without success.

I'll very thankful if someone help me with this!

10x




TopTop
« 1 ... 7 8 9 (10)



Login

Who's Online

68 user(s) are online (41 user(s) are browsing Support Forums)


Members: 0


Guests: 68


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Sep 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits