xoops forums

Forum Index


Board index » All Posts (LiliVG)




LiliVG

Just popping in
Posted on: 2007/2/12 18:03
LiliVG
LiliVG (Show more)
Just popping in
Posts: 65
Since: 2005/12/25
#21

<{$XOOPS_URL}> is defined in which file?

I need to make a smarty tag, like <{$xoops_domain}> instead of xoops_url (I need it to leave out the http:// part of the address) to put in a module I'm working on. Can anyone tell me which file that's located in so i can get an idea of how to create this variable? Thanks!


LiliVG

Just popping in
Posted on: 2007/2/12 17:44
LiliVG
LiliVG (Show more)
Just popping in
Posts: 65
Since: 2005/12/25
#22

Re: My xoops got hacked!!!

where can I get the protector module? It Nequery a protector module? it's kind of hard to tell with how it's described, does it jus track traffic, or does if actually offer some kind of protection? Anyways, any pointers would be appreciated! :)


LiliVG

Just popping in
Posted on: 2007/2/12 16:44
LiliVG
LiliVG (Show more)
Just popping in
Posts: 65
Since: 2005/12/25
#23

Which file is the variable for <{$XOOPS_URL}> defined in?

Ok, I got the smarty tag thing figured out.

Can anyone tell me where the variable for <{$XOOPS_URL}> is defined? Like which file it's in? I need to tweak it and add it to my module. Thanks :)


LiliVG

Just popping in
Posted on: 2007/2/11 20:28
LiliVG
LiliVG (Show more)
Just popping in
Posts: 65
Since: 2005/12/25
#24

Smarty tags print as literal instead of value

I'm making a simple module, but the smarty tags aren't working, for example, <{$xoops_sitename}> will show exactly like that. I've included the header, footer, and mainfile in index.php...what could be wrong?

Also, is there already a defined smarty tag for the site domain, for example <{$xoops_domain}> would output "Mydomain.com" without the "http://"? If not, how would I code the variable for it to do that? Or actually, if I just knew where the code was for the <{$XOOPS_URL}> code, I could probably tweak it myself.

Thanks! :)


LiliVG

Just popping in
Posted on: 2007/1/24 20:32
LiliVG
LiliVG (Show more)
Just popping in
Posts: 65
Since: 2005/12/25
#25

Re: Kicking some ideas #2: More BB-Codes

A lot of sites that generate bb code for URLs will put it in

[ url ] ... [ /url ]

But in the text sanitizer there's only code for

[ url= ... ] ... [ /url ]

Can additional code be added to make it compatible with more widely accepted bbcode structures?


LiliVG

Just popping in
Posted on: 2007/1/12 23:11
LiliVG
LiliVG (Show more)
Just popping in
Posts: 65
Since: 2005/12/25
#26

Re: Error: mainmenu not writeable

....aaaand now I can't log in at all...my site is falling apart right in fron tof my eyes, and I don't know why, what is going on??


LiliVG

Just popping in
Posted on: 2007/1/12 21:36
LiliVG
LiliVG (Show more)
Just popping in
Posts: 65
Since: 2005/12/25
#27

Re: Error: mainmenu not writeable

I double checked all chmod in cPanel, it's all how it's supposed to be...


Thanks for all your help on this, I really appreciate it!


another update:

apearently, it's not only debug that doesn't work in preferences. If I try to save any changes to general preferences, I get a blank page. *sigh* I did a search, and this post describes exactly what's happening with the preferences problem: here


LiliVG

Just popping in
Posted on: 2007/1/12 21:34
LiliVG
LiliVG (Show more)
Just popping in
Posts: 65
Since: 2005/12/25
#28

Re: Error: mainmenu not writeable

Ok, another update. Since deleting the adminmenu.php file, I don't get errors when updating modules. No more "unable to write to mainmenu" So yay, progress! Thank you!

However, I can't use debug at all, I only get a blank page.

I am running XOOPS 2.0.16


LiliVG

Just popping in
Posted on: 2007/1/12 21:14
LiliVG
LiliVG (Show more)
Just popping in
Posts: 65
Since: 2005/12/25
#29

Re: Error: mainmenu not writeable

this is getting weirder and weirder...

when I went to turn on debug in pop-up mode and then also in inline mode, and clicked submit, I get a blank page. So basically I can't use debug at all anymore...

aaarrrggh. This is so weird and random, it just started being all weird, and I don't know why...


LiliVG

Just popping in
Posted on: 2007/1/12 21:08
LiliVG
LiliVG (Show more)
Just popping in
Posts: 65
Since: 2005/12/25
#30

Re: Error: mainmenu not writeable

hmmm...weird...I don't have an adminmenu.php file in cache...

could that be the problem?

*edit - found it. I deleted it. At least all the module images show up on the side now, Thanks! :)*



TopTop
« 1 2 (3) 4 5 6 »