xoops forums

Forum Index


Board index » All Posts (reynaldo)




reynaldo

Not too shy to talk
Posted on: 2004/4/3 22:32
reynaldo
reynaldo (Show more)
Not too shy to talk
Posts: 106
Since: 2004/2/13
#21

Re: ShortURLs hack

Karuna:

I'm glad to say I found and fixed the problem :)

Unlike some of the fixes I had posted lately, this one was related to an error inside the hack and not to a bad coded module/template.

Try downloading this version:

http://www.wtmmail.com/XoopsShortUrls/loadpage.txt7

Remember to edit line 20 of the script if your default module is other than News.

Thanks for your help Karuna.


reynaldo

Not too shy to talk
Posted on: 2004/4/3 20:55
reynaldo
reynaldo (Show more)
Not too shy to talk
Posts: 106
Since: 2004/2/13
#22

Re: ShortURLs hack

Karuna:

are you using the last version of the hack? (fix #6)

I can't reproduce this error at my sites


reynaldo

Not too shy to talk
Posted on: 2004/4/3 19:49
reynaldo
reynaldo (Show more)
Not too shy to talk
Posts: 106
Since: 2004/2/13
#23

Re: ShortURLs hack

Ullone: (and/or for those who already don't know it)

My hack doesn't work correctly (yet!) with a XOOPS installation inside a dir. As soon as I have time to write the next version, I'll fix/add this feature but for now I can't do anything about it

Sorry about it pal, but right now I'm short of time and can't work on a major version, just minor fixes.


reynaldo

Not too shy to talk
Posted on: 2004/4/3 19:44
reynaldo
reynaldo (Show more)
Not too shy to talk
Posts: 106
Since: 2004/2/13
#24

Re: ShortURLs hack

Quote:

kenogui wrote:

the parameter #4 " [4] => 539st" is wrong, it should be "539" only.
and we should have a 5th parameters called "st=10".

I think it's a start point for you, I'm currently trying to debug it, but you will be faster than me ....

thanks !


Kenogui:

Thanks a lot for your feedback. If I'm not confused, I think that problem was solved in last version. Try overwriting files with fix #6:
xoops_shorturls.txt6
loadpage.txt6

Let me know if after installing/overwriting with those you still have the same problem and I'll be glad to take a look at it.

About the SID thing, I'll take a look at it, but sometimes the easier way is to fix things right at the source. I have the same problem with my PHP installation adding a PHPSESSID to everything and I recompiled PHP without it and voila!


reynaldo

Not too shy to talk
Posted on: 2004/3/25 3:20
reynaldo
reynaldo (Show more)
Not too shy to talk
Posts: 106
Since: 2004/2/13
#25

Re: ShortURLs hack

Karuna:

When you activate debug option, it is normal for CSS to work erratic. This is because IE expects no text to be written before it interprets CSS commands.

Sorry I took so long to get back to you on this one. If you would like to try again, let me know.

regards,
Reynaldo


reynaldo

Not too shy to talk
Posted on: 2004/3/19 21:09
reynaldo
reynaldo (Show more)
Not too shy to talk
Posts: 106
Since: 2004/2/13
#26

Re: ShortURLs hack

Karuna:

Could you please activate debug for file loadpage.php

To do it, just edit the file and set line
$is_debug=1;


reynaldo

Not too shy to talk
Posted on: 2004/3/17 13:35
reynaldo
reynaldo (Show more)
Not too shy to talk
Posts: 106
Since: 2004/2/13
#27

Re: ShortURLs hack

Karuna:

Tried to take a look at your problem, but you already deactivated the hack


reynaldo

Not too shy to talk
Posted on: 2004/3/17 13:33
reynaldo
reynaldo (Show more)
Not too shy to talk
Posts: 106
Since: 2004/2/13
#28

Re: ShortURLs hack

Ullone:

This is a limitation with the last version of this hack. It still does not supports XOOPS installations within a dir.

I'll be re-adding this feature in a later revision of the hack.


reynaldo

Not too shy to talk
Posted on: 2004/3/14 14:55
reynaldo
reynaldo (Show more)
Not too shy to talk
Posts: 106
Since: 2004/2/13
#29

Re: FAQ problem (strange URL)

Sebastien (sdamain):

Your server is not parsing the loadpage.php file.

Did XOOPS worked fine before this?


reynaldo

Not too shy to talk
Posted on: 2004/3/12 0:20
reynaldo
reynaldo (Show more)
Not too shy to talk
Posts: 106
Since: 2004/2/13
#30

Re: FAQ problem (strange URL)

Bela:

This problem is caused by the hack. I'll take a deeper look at it later and try to find a solution.



TopTop
« 1 2 (3) 4 5 6 ... 11 »