xoops forums

Zap_English

Quite a regular
Posted on: 2/17 7:45
Zap_English
Zap_English (Show more)
Quite a regular
Posts: 337
Since: 2016/5/24
#1

Small problem/error with xBootstrap

I noticed when you look at a single item the name shows as

module name category > item name

I wanted to change it to

module name > category > item name

which is the way it shows in the standard Publisher without xBootstrap but I can't seem to find the code to change.

Can someone point the way?

TIA!!!

Bleekk

Theme Designer
Posted on: 2/19 13:53
Bleekk
Bleekk (Show more)
Theme Designer
Posts: 898
Since: 2002/12/14
#2

Re: Small problem/error with xBootstrap

open modules/publisher/item.php

find this (line 222)
$xoopsTpl->assign('categoryPath',$item['categoryPath'] . '> ' $item['title']);

change to
$xoopsTpl->assign('categoryPath','>'.$item['categoryPath'] . '> ' $item['title']);

Bleekk

Theme Designer
Posted on: 2/19 14:04
Bleekk
Bleekk (Show more)
Theme Designer
Posts: 898
Since: 2002/12/14
#3

Re: Small problem/error with xBootstrap

But this is not bootstrap standard

The standard would be in item.php
$xoopsTpl->assign('categoryPath''<li>'.$item['categoryPath'] . '</li><li> ' $item['title'].'</li>');


and in category.php
$xoopsTpl->assign('categoryPath''<li>'.$category['categoryPath'].'</li>');

Zap_English

Quite a regular
Posted on: 2/19 14:10
Zap_English
Zap_English (Show more)
Quite a regular
Posts: 337
Since: 2016/5/24
#4

Re: Small problem/error with xBootstrap

That fixed it/ Thanks!

Zap_English

Quite a regular
Posted on: 2/19 14:19
Zap_English
Zap_English (Show more)
Quite a regular
Posts: 337
Since: 2016/5/24
#5

Re: Small problem/error with xBootstrap

Quote:

Bleekk wrote:
But this is not bootstrap standard


I didn't make any changes. That's how it came out of the box