Modules: WF-Section v1.0.1 Released

Posted by: Anonymouson 2003/7/4 17:43:19 6750 reads
I am pleased to announce WF-Section v1.0.1.

This is mainly a bug fix version and corrects all issues reported at Xoops.org.

Bugs corrected in this version.

- Filemanager has been redone again, and corrects many of the issues reported.
- Pulldown menu bug fixed.
- Topics block fixed.
- Groupaccess in some blocks fixed.
- Attached files bug fixed.
- plus many more.

There was reports that the update script, incorrectly updated the articles table. This in fact incorrect, the 'orders' field was an un used feild in all previous versions and I replaced this with the 'weight' field, which is used.

other issues......


It has been reported to me that 'blocks' do not show content or fail to show. This is not a problem with WF-Section, but with Xoops and Smarty (This has been brought to the Core dev attention).

Q, My blocks do not show up after I update?
A, Xoops does not purge the cache files in templates_c folder after a module update. First, you must always 'update' any module after you upgrade. If this does not work, perform an update of the 'system admin' module. If this does not work, then goto the blocks admin, edit each block and save them, this should then update each module.

Q, Wf-Sections blocks do not show or place content in them!
A, Blocks by design will not show in the main page (or any other) unless they have content to show, and this includes WF-Section.

WF-Section Article links is a special type of block, as it does not show links to articles like recent articles. To use this block, WF-Section must be told to use it.

When you create an article, you are given choices in how this article will be shown. If you select the 'No Show Article' before saving, that article will not be shown in the article listing (like a normal article) but instead a link will be created in the article links block.

Q, I get upload fails with unknown error, but I have everything set correct with my config.
A, This could be for many reasons:
1, You server does not allows upload of any kind, in that case you could either contact them and ask them to enable it and if they refuse, there is nothing you can do about uploads.
2, Your server runs in safe mode (try search for safe mode in google) and this will cause any file operation type scripts problems. ie. Renaming, deleting and chaging permissons.
3, The directory you are trying to upload to does not have the correct permissions and uploads will fail. You must set the permissions for directories to 0755 or 0777 for this to work correctly.